Project

General

Profile

Feature #15666

Feature #14468: Add VeraCrypt support to Tails

Feature #14480: Fix bugs and UX issues of VeraCrypt support

Administration password required to detach a disk image from _Disks_

Added by sajolida over 1 year ago. Updated over 1 year ago.

Status:
Rejected
Priority:
Normal
Assignee:
-
Category:
-
Target version:
-
Start date:
06/18/2018
Due date:
% Done:

0%

Feature Branch:
Type of work:
Code
Blueprint:
Starter:
Affected tool:

Description

While no administration password is required to attach a disk image.

See screenshot in attachment.

detach.png View (143 KB) sajolida, 06/18/2018 03:12 PM

History

#1 Updated by segfault over 1 year ago

  • Assignee changed from segfault to sajolida
  • QA Check set to Info Needed

I can't reproduce this. Some background: udisks stores the UID of the user which set up a loop device, and only allows this user to detach it without authenticating. I tried attaching via Disks and via gnome-disk-image-mounter and in both cases udisks correctly stored the UID of amnesia and allowed me to detach the device without authenticating. Do you remember how the device was attached before you got this dialog?

#2 Updated by sajolida over 1 year ago

  • Status changed from Confirmed to Rejected
  • Assignee deleted (sajolida)
  • QA Check deleted (Info Needed)

Sorry for waisting your time, I should have been more precise when reporting this bug...

It happened to P5 in mission 1. But it involved attaching the file container twice, opening it only once, etc. I tried to follow the same sequence again today and couldn't reproduce it either. I've seen an admin login a couple of times today while doing some tests, with all sort of weird sequences but couldn't find a way to reproduce it reliably.

So indeed, let's forget about this ticket for now.

Also available in: Atom PDF