Project

General

Profile

Feature #15659

Feature #15292: Distribute a USB image

Bug #16006: USB image: adjust documentation

Bug #16007: Document the usage of graphical dd tools

Document GNOME Disks for Debian, Linux, and manual upgrades

Added by u 6 months ago. Updated about 2 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
-
Target version:
Start date:
11/01/2018
Due date:
% Done:

0%

Estimated time:
7.00 h
QA Check:
Feature Branch:
Type of work:
End-user documentation
Blueprint:
Starter:
Affected tool:

Description

  • Remove "intermediary" Tails from Linux steps
  • Reuse GNOME Disks instructions from Linux in Debian steps
  • Replace Tails Installer by GNOME Disks to install intermediary Tails in manual upgrade steps
  • Is it better to keep Debian and Linux separated?

Worker: Cody, reviewer: sajolida (1h)

History

#1 Updated by sajolida 4 months ago

  • Subject changed from Document GNOME Disks for Debian, Ubuntu, and manual upgrades to Document GNOME Disks for Debian, Linux, and manual upgrades

#2 Updated by sajolida 4 months ago

  • Parent task changed from #15292 to #15660

#3 Updated by sajolida 4 months ago

  • Description updated (diff)

#4 Updated by sajolida 4 months ago

  • Description updated (diff)

#5 Updated by u 4 months ago

  • Related to Feature #5323: Document a GUI way to securely erase Flash media via Gnome Disks added

#6 Updated by u 4 months ago

  • Related to deleted (Feature #5323: Document a GUI way to securely erase Flash media via Gnome Disks)

#7 Updated by cbrownstein 4 months ago

  • Status changed from Confirmed to In Progress
  • Assignee changed from cbrownstein to sajolida
  • QA Check set to Ready for QA
  • Remove "intermediary" Tails from Linux steps
  • Reuse GNOME Disks instructions from Linux in Debian steps
  • Replace Tails Installer by GNOME Disks to install intermediary Tails in manual upgrade steps
  • Is it better to keep Debian and Linux separated?

All done. Debian and Other Linux instructions have been combined into just Linux instructions.

However, the Debian expert instructions (command line and GnuPG) will still be for Debian/Ubuntu/Mint only. The user is instructed to install the Debian keyring and use apt. So, a Debian-based distribution is needed for the expert instructions to be valid.

https://0xacab.org/cbrownstein/tails/commits/doc/15659-doc-gnome-disks-debian

#8 Updated by sajolida 4 months ago

Stuff that still needs to be done:

  • Rescue translations
  • Clean all the code related to the defunct Debian scenario: files
  • Fix the numbering of steps in the dd toggle (if still relevant)

#9 Updated by sajolida 3 months ago

  • Assignee changed from sajolida to cbrownstein

I reviewed your branch and all the changes are good!

I did a bit more work to remove more things all around the place and update the PO files.

Please have a look at my branch.

For example, you can check:

git log -p origin/doc/15660-usb-images..origin/doc/15659-doc-gnome-disks-debian

Then we can close this ticket.

Good job!

#10 Updated by sajolida 3 months ago

  • Target version set to Tails_3.10.1

The deadline for that is October 31 → 3.10.

#11 Updated by cbrownstein 3 months ago

  • Assignee changed from cbrownstein to sajolida
  • QA Check changed from Ready for QA to Info Needed

bf5ffcd43b Add missing infography

Is this infographic a placeholder for right now? I'm asking because the infographic depicts an ISO image, rather than a USB disk image, being installed to a USB stick.

Other than this, everything looks good!

#13 Updated by u 3 months ago

  • Description updated (diff)
  • Estimated time set to 7.00 h

#14 Updated by u 3 months ago

Milestone 2

#15 Updated by sajolida 3 months ago

  • Parent task changed from #15660 to #16007

#16 Updated by sajolida about 2 months ago

  • Status changed from In Progress to Resolved
  • Assignee deleted (sajolida)
  • QA Check deleted (Info Needed)

I created a ticket to update the infographic later on: #15826.

So right now I can close this ticket. Yeah!

Also available in: Atom PDF