Project

General

Profile

Bug #15650

libtools-nrepl-clojure updates kept back on puppet-git

Added by groente about 1 year ago. Updated 12 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
Infrastructure
Target version:
Start date:
06/12/2018
Due date:
% Done:

100%

Feature Branch:
Type of work:
Sysadmin
Blueprint:
Starter:
Affected tool:

Related issues

Related to Tails - Feature #11834: Migrate our infrastructure to Puppet 4 Resolved 09/24/2016
Blocks Tails - Feature #13284: Core work: Sysadmin (Adapt our infrastructure) Confirmed 06/30/2017

History

#1 Updated by groente about 1 year ago

  • Related to Feature #11834: Migrate our infrastructure to Puppet 4 added

#2 Updated by intrigeri about 1 year ago

  • Blocks Feature #13284: Core work: Sysadmin (Adapt our infrastructure) added

#3 Updated by intrigeri about 1 year ago

  • Target version changed from Tails_3.8 to Tails_3.9

We have 0.2.12-1 installed and the newer available version (0.2.13-1, that we pin) depends on libclojure1.8-java that itself cannot be installed because:

Breaks: clojure (<< 1.8), libclojure-java (<< 1.8.0-4)
Replaces: clojure (<< 1.8), libclojure-java (<< 1.8.0-4)

… and libtools-nrepl-clojure Depends: libclojure1.8-java while puppetdb Depends: libclojure-java. Basically we need all clojure libs to stop depending on libclojure1.8-java and instead depend on libclojure-java (1.9).

Looking at https://tracker.debian.org/pkg/clojure it seems that 1.9 in sid is blocked from migrating due to a bug (https://bugs.debian.org/887382) that seems obsolete. I've asked an updated on that bug report.

So our options seem to be to wait for the transition to happen in Debian or to pin all clojure stuff to sid i.e. upgrade to clojure 1.9. Frankly the latter option scares me so for now I'd rather wait a bit and reconsider during our next dev cycle.

#4 Updated by intrigeri about 1 year ago

intrigeri wrote:

Looking at https://tracker.debian.org/pkg/clojure it seems that 1.9 in sid is blocked from migrating due to a bug (https://bugs.debian.org/887382) that seems obsolete. I've asked an updated on that bug report.

So our options seem to be to wait for the transition to happen in Debian or to pin all clojure stuff to sid i.e. upgrade to clojure 1.9. Frankly the latter option scares me so for now I'd rather wait a bit and reconsider during our next dev cycle.

No progress on the Debian side. I'll ping in a couple weeks or will try to talk to the Clojure maintainers during DebCamp/DebConf. For now, the incident is acknowledged on our monitoring and it does not seem to cause actual problems, which is why I'm reluctant to spend much time on it while the proper solution is out of our hands.

#5 Updated by intrigeri 12 months ago

clojure 1.9 should migrate to testing today or tomorrow; then hopefully this issue will be easier to solve.

#6 Updated by intrigeri 12 months ago

  • Status changed from Confirmed to Resolved
  • Assignee deleted (intrigeri)
  • % Done changed from 0 to 100

The automatic upgrade succeeded yesterday:

Start-Date: 2018-08-07  21:07:18
Commandline: /usr/bin/apt-get -o quiet=1 dist-upgrade -y -o APT::Get::Show-Upgraded=true -o DPkg::Options::=--force-confold
Install: libclojure1.8-java:amd64 (1.8.0-7, automatic)
Upgrade: libclojure-java:amd64 (1.9.0-2, 1.9.0-5), libtools-nrepl-clojure:amd64 (0.2.12-1, 0.2.13-1)
End-Date: 2018-08-07  21:07:23

… and APT does not report any held package anymore.

Also available in: Atom PDF