Project

General

Profile

Bug #15640

Suspend button shown when screen is locked

Added by Gaff about 1 year ago. Updated 4 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
-
Target version:
Start date:
06/08/2018
Due date:
% Done:

100%

Feature Branch:
feature/14556-show-suspend-button
Type of work:
Code
Blueprint:
Starter:
Affected tool:

Description

When the screen is locked a suspend button is shown in the top right menu. It seems that tails doesn't normally allow suspend so this is at-best inconsistent. At worst it would allow an attacker to suspend the machine and then perform advanced forensic attacks later.

Personally I think that the regular shutdown and restart options should be available even if the screen is locked - this would allow for emergency situations.


Related issues

Related to Tails - Feature #14556: Show a suspend to RAM button in the status menu Resolved 08/30/2017

Associated revisions

Revision 1616d490 (diff)
Added by segfault 5 months ago

status-menu-helper: Show poweroff and reboot buttons when locked (refs: #14556, #15640)

History

#1 Updated by Gaff about 1 year ago

I presume this is a 'feature' of gdm? I had a quick look to try and figure if it's customisable but I didn't get very far. Happy to dig further if anyone can point me in the right direction?

#2 Updated by mercedes508 about 1 year ago

  • Assignee set to Gaff

Hey,

The suspend to ram feature will be implemented officially in Tails as described here: https://labs.riseup.net/code/issues/14556

And when the screen is locked the emergency shutdown feature works, so it's appropriate for emergency situations, right?

#3 Updated by Gaff about 1 year ago

Hmm - well the odd thing is that when unlocked it shows "restart" and "power off". When it's locked it shows "pause". The difference is certainly unexpected!

I think it also presents a risk - the user would probably assume the machine was powered off rather than suspended and so might assume his machine was protected when it wasn't. I can see few upsides for allowing suspend.

I did dig a bit further - there's a custom gnome javascript extension that provides the unlocked powerdown options. My guess is that this javascript doesn't cover the locked case.

#4 Updated by intrigeri about 1 year ago

  • Related to Feature #14556: Show a suspend to RAM button in the status menu added

#5 Updated by intrigeri about 1 year ago

  • Status changed from New to Confirmed
  • Assignee changed from Gaff to segfault
  • QA Check set to Info Needed
  • Type of work changed from User interface design to Code

Indeed, that's inconsistent. It would be nice to fix this if it's super cheap (and skip that otherwise because we'll soon have a suspend button in the regular session too so any change we make here will have to be reverted at some point). segfault, can you please have a quick look and tell me whether it's easy to fix it?

#6 Updated by intrigeri about 1 year ago

mercedes508:

And when the screen is locked the emergency shutdown feature works, so it's appropriate for emergency situations, right?

Meta: Gaff reported a UI inconsistency. IMO this is a valid UX problem.

#7 Updated by sajolida about 1 year ago

My 2 cents. I think that this behavior is inherited from GNOME.

In the context of GNOME, it makes sense to make it harder for someone who doesn't have the password to shutdown the system. Let's say you're in the library and lock your screen, you want to make it harder for someone else to shutdown your computer without your consent.

In the context of Tails, on the other hand, it makes sense to provide shortcuts to shutdown as a security feature.

So I wouldn't say that the UX problem here is inconsistency (because it makes sense in the context of GNOME in general) but yeah, it's more about the quick access to shutdown as a security feature :)

NB: Suspend to RAM already works on laptop. I use it all the time :)

#8 Updated by segfault 5 months ago

  • Status changed from Confirmed to In Progress

#9 Updated by intrigeri 5 months ago

  • Target version set to Tails_3.14
  • QA Check changed from Info Needed to Pass
  • Feature Branch set to feature/14556-show-suspend-button

Tested, works fine!

#10 Updated by segfault 5 months ago

  • Status changed from In Progress to Fix committed
  • % Done changed from 0 to 100

Same as #14556

#11 Updated by intrigeri 4 months ago

  • Target version changed from Tails_3.14 to Tails_3.13.2

#12 Updated by anonym 4 months ago

  • Status changed from Fix committed to Resolved

#13 Updated by anonym 4 months ago

  • Target version changed from Tails_3.13.2 to Tails_3.14

#14 Updated by intrigeri 4 months ago

  • Target version changed from Tails_3.14 to Tails_3.13.2

Also available in: Atom PDF