Project

General

Profile

Bug #15622

Upgrade to Linux 4.16+ in Tails 3.9

Added by intrigeri about 1 year ago. Updated 10 months ago.

Status:
Resolved
Priority:
High
Assignee:
-
Category:
-
Target version:
Start date:
05/28/2018
Due date:
% Done:

100%

Feature Branch:
feature/15622-linux-4.16
Type of work:
Code
Blueprint:
Starter:
Affected tool:

Related issues

Related to Tails - Bug #15436: Consider upgrading Linux in Tails 3.8 Resolved 03/22/2018
Related to Tails - Bug #15681: Check getrandom() status and potential problems Resolved 06/23/2018
Blocks Tails - Feature #15139: Core work 2018Q2: Foundations Team Resolved 01/01/2018
Blocks Tails - Bug #15472: Rebase our Tor Browser AppArmor policy on top of torbrowser-launcher 0.2.9-2's Resolved 03/28/2018
Blocks Tails - Bug #15638: Remove deb.torproject.org sid APT source Resolved 06/07/2018
Blocks Tails - Bug #15116: X.Org does not start with some NVidia Maxwell and Pascal graphic cards Confirmed 12/27/2017

Associated revisions

Revision 6ff657eb (diff)
Added by intrigeri about 1 year ago

Upgrade Linux to 4.16.0-1 (refs: #15622).

Revision acb5f067 (diff)
Added by intrigeri about 1 year ago

Update the aufs4-standalone submodule to the current HEAD of the upstream aufs4.16 branch (refs: #15622)

Revision 0dab7a19 (diff)
Added by intrigeri about 1 year ago

Upgrade Linux to 4.16.0-2 (refs: #15622)

Revision cc6a9694
Added by intrigeri about 1 year ago

Merge branch 'feature/15622-linux-4.16' into devel (Fix-committed: #15622)

History

#1 Updated by intrigeri about 1 year ago

  • Related to Bug #15436: Consider upgrading Linux in Tails 3.8 added

#2 Updated by intrigeri about 1 year ago

  • Feature Branch set to feature/15622-linux-4.16

#3 Updated by intrigeri about 1 year ago

#4 Updated by intrigeri about 1 year ago

  • Status changed from Confirmed to In Progress
  • Assignee changed from intrigeri to segfault
  • % Done changed from 0 to 50
  • QA Check set to Ready for QA

Passes the full test suite! (except 1 new scenario that I've never seen pass and "Playing HTML5 audio" that's currently broken due to the remote server having exceeded their bandwidth limit).

Please review the tiny "code" changes and briefly test on whatever bare metal hardware you have handy, without spending more than 20 minutes on it.

This will only become urgence once 4.15 is removed from testing so I don't mean to distract you from your other more urgent (though less exciting perhaps) work :)

#5 Updated by intrigeri about 1 year ago

  • Assignee changed from segfault to intrigeri
  • QA Check deleted (Ready for QA)

Before merging this, I'll need to look into potential regressions caused by the getrandom() fix. Details:

#6 Updated by intrigeri about 1 year ago

  • Related to Bug #15681: Check getrandom() status and potential problems added

#7 Updated by intrigeri about 1 year ago

  • Assignee changed from intrigeri to segfault
  • Priority changed from Normal to High
  • QA Check set to Ready for QA

Linux 4.15 was removed from sid so our devel branch now FTBFS.

So please review the tiny "code" changes and briefly test on whatever bare metal hardware you have handy, without spending more than 20 minutes on it.

Before merging this, I'll need to look into potential regressions caused by the getrandom() fix.

I'll do that on #15681.

#8 Updated by intrigeri about 1 year ago

  • Blocks Bug #15472: Rebase our Tor Browser AppArmor policy on top of torbrowser-launcher 0.2.9-2's added

#9 Updated by intrigeri about 1 year ago

  • Blocks Bug #15638: Remove deb.torproject.org sid APT source added

#10 Updated by intrigeri about 1 year ago

  • Blocks Bug #15116: X.Org does not start with some NVidia Maxwell and Pascal graphic cards added

#11 Updated by segfault about 1 year ago

  • QA Check changed from Ready for QA to Pass

So please review the tiny "code" changes and briefly test on whatever bare metal hardware you have handy, without spending more than 20 minutes on it.

Done, LGTM and boots on my hardware.

#12 Updated by segfault about 1 year ago

  • Assignee changed from segfault to intrigeri

#13 Updated by intrigeri about 1 year ago

  • Status changed from In Progress to Fix committed
  • % Done changed from 50 to 100

Thanks, merging!

#14 Updated by intrigeri about 1 year ago

  • Assignee deleted (intrigeri)

#15 Updated by intrigeri 10 months ago

  • Status changed from Fix committed to Resolved

Also available in: Atom PDF