Project

General

Profile

Bug #15621

devel branch FTBFS since virtualbox 5.2.12-dfsg-2 was uploaded to sid

Added by intrigeri over 1 year ago. Updated over 1 year ago.

Status:
Resolved
Priority:
Elevated
Assignee:
-
Category:
Virtualization
Target version:
Start date:
05/26/2018
Due date:
% Done:

100%

Feature Branch:
bugfix/15621-virtualbox
Type of work:
Code
Blueprint:
Starter:
Affected tool:

Description

The following packages have unmet dependencies:
 virtualbox-guest-x11 : Depends: xorg-video-abi-24

2018-05-27_15-41.png View - qemu (13.6 KB) lamby, 05/27/2018 02:42 PM

2018-05-27_15-51.png View - version in squashfs (15.9 KB) lamby, 05/27/2018 02:51 PM


Related issues

Related to Tails - Bug #12048: Check what to do with VirtualBox on Stretch Resolved 12/20/2016
Blocks Tails - Feature #15139: Core work 2018Q2: Foundations Team Resolved 01/01/2018

Associated revisions

Revision 3ca7320c (diff)
Added by intrigeri over 1 year ago

Enable the bugfix-15621-virtualbox APT overlay (refs: #15621).

Revision 477e417f (diff)
Added by intrigeri over 1 year ago

Install virtualbox from our custom APT repository (refs: #15621)

As per https://labs.riseup.net/code/issues/12048#note-12:

"we'll ship virtualbox-guest-x11 from sid as long as it's installable on
Stretch; then we'll import the last working version in our custom APT repo.
And if/when that last working version breaks (e.g. because we get a new xorg
from stretch-backports and the virtualbox driver doesn't build against it
anymore, there's no ABI compatibility between major X.Org versions, all drivers
need to be rebuilt against the new one; it's happened a few times already that
whatever virtualbox backport we were shipping wasn't compatible with the xorg
from backports, etc.), then we'll reconsider and possibly drop
VirtualBox support."

Revision f70308d3
Added by intrigeri over 1 year ago

Merge branch 'bugfix/15621-virtualbox' into devel (Fix-committed: #15621)

History

#1 Updated by intrigeri over 1 year ago

#2 Updated by intrigeri over 1 year ago

As per #12048#note-12, for now "we'll import the last working version in our custom APT repo". Let's see if it works with our recent kernel.

#3 Updated by intrigeri over 1 year ago

  • Feature Branch set to bugfix/15621-virtualbox
  • Type of work changed from Research to Code

#4 Updated by intrigeri over 1 year ago

  • Related to Bug #12048: Check what to do with VirtualBox on Stretch added

#5 Updated by intrigeri over 1 year ago

  • Status changed from Confirmed to In Progress
  • Assignee changed from intrigeri to lamby
  • % Done changed from 0 to 50
  • QA Check set to Ready for QA

lamby, can you please review this? The nature of the review is exactly the same as #15616 so 0.5 hour maximum should be enough as well so I'll only paste the info that differs here:

$ reprepro list bugfix-15621-virtualbox        
bugfix-15621-virtualbox|contrib|amd64: virtualbox 5.2.12-dfsg-1
bugfix-15621-virtualbox|contrib|amd64: virtualbox-dkms 5.2.12-dfsg-1
bugfix-15621-virtualbox|contrib|amd64: virtualbox-guest-dkms 5.2.12-dfsg-1
bugfix-15621-virtualbox|contrib|amd64: virtualbox-guest-source 5.2.12-dfsg-1
bugfix-15621-virtualbox|contrib|amd64: virtualbox-guest-utils 5.2.12-dfsg-1
bugfix-15621-virtualbox|contrib|amd64: virtualbox-guest-x11 5.2.12-dfsg-1
bugfix-15621-virtualbox|contrib|amd64: virtualbox-qt 5.2.12-dfsg-1
bugfix-15621-virtualbox|contrib|amd64: virtualbox-source 5.2.12-dfsg-1
bugfix-15621-virtualbox|contrib|i386: virtualbox-dkms 5.2.12-dfsg-1
bugfix-15621-virtualbox|contrib|i386: virtualbox-guest-dkms 5.2.12-dfsg-1
bugfix-15621-virtualbox|contrib|i386: virtualbox-guest-source 5.2.12-dfsg-1
bugfix-15621-virtualbox|contrib|i386: virtualbox-source 5.2.12-dfsg-1
bugfix-15621-virtualbox|contrib|source: virtualbox 5.2.12-dfsg-1

#6 Updated by lamby over 1 year ago

This ISO does not actually boot for me (see qemu screenshot attached).

However, I can confirm that the squashfs image does indeed contain 5.2.12-dfsg-1 which matches https://deb.tails.boum.org/dists/bugfix-15621-virtualbox/contrib/binary-amd64/Packages (see other screenshot)

(Leaving as "Ready for QA" due to boot - just in case there is another issue...)

#7 Updated by intrigeri over 1 year ago

  • Status changed from In Progress to 11
  • Assignee changed from intrigeri to lamby

This ISO does not actually boot for me (see qemu screenshot attached).

Interesting! Do other Tails ISO images usually boot for you in that environment?

However, I can confirm that the squashfs image does indeed contain 5.2.12-dfsg-1 which matches https://deb.tails.boum.org/dists/bugfix-15621-virtualbox/contrib/binary-amd64/Packages (see other screenshot)

Thanks! Merged the branch into devel to fix the FTBFS and then we'll see if it boots in our CI setup. If it does not I'll file another ticket about that other problem.

#8 Updated by intrigeri over 1 year ago

  • % Done changed from 50 to 90

#9 Updated by lamby over 1 year ago

  • Assignee changed from lamby to intrigeri

intrigeri wrote:

Interesting! Do other Tails ISO images usually boot for you in that environment?

Usually yes (!) but juuuust rechecking with the official 3.1 ISO it
also does not boot so I have some kind of regression in my ISO
testing setup.

(Seems I need to pass -machine accel=kvm here.. Weird.)

Sorry about that hiccup :) Re-assigning back, leaving at 90% (was that for the ISO issue?)

#10 Updated by intrigeri over 1 year ago

  • Assignee deleted (intrigeri)
  • % Done changed from 90 to 100
  • QA Check changed from Ready for QA to Pass

An ISO built from devel boots fine on our CI (libvirt/QEMU) so I'll call this a local problem with your virtualization setup.

#11 Updated by intrigeri over 1 year ago

  • Target version changed from Tails_3.8 to Tails_3.7.1

#12 Updated by intrigeri over 1 year ago

  • Assignee set to BitingBird

#13 Updated by intrigeri over 1 year ago

  • Assignee deleted (BitingBird)

#14 Updated by intrigeri over 1 year ago

  • Status changed from 11 to Resolved

Also available in: Atom PDF