Project

General

Profile

Feature #15612

Improve "Tails documentation" browser

Added by sajolida over 1 year ago. Updated about 1 year ago.

Status:
Rejected
Priority:
Normal
Assignee:
-
Category:
-
Target version:
-
Start date:
05/05/2018
Due date:
% Done:

100%

Feature Branch:
Type of work:
Code
Blueprint:
Starter:
Affected tool:

Description

Since 4fba04a332, people get either the online or offline documentation when opening the "Tails documentation" launcher from the desktop.

When people get the offline documentation, I think that it should look as much as possible to the online documentation to obey the "Consistency and standards" UX heuristics: https://www.nngroup.com/articles/ten-usability-heuristics/.

People are really used to navigate information from a browser and we should provide as much as the common navigation elements as the online documentation as possible.

Currently, the "Tails documentation" browser lacks the following navigation elements compared to the online documentation:

  • Sidebar: it is the only way we have for people to jump, for example, from /doc to /support.
  • Tabs: tabs are heavily used by millenials when exploring complex content: https://www.nngroup.com/articles/multi-tab-page-parking/.
  • Search: but this might be impossible to provide offline...
  • Banner which includes a link to our homepage: but we have another home link at the beginning of the breadcrumbs so it's probably not that bad. Including the banner would further increase the similiarity between the offline and online version. Removing the banner in the offline doc allows for more space before the fold, on the other hand, the space taken by the banner should be good enough for online doc anyway.

Having the sidebar and tabs would have prevented navigation errors in the user testing that I did of the Additional Software beta.


Subtasks

Feature #15576: Add back the sidebar on the offline documentation browserRejected

Feature #15577: Have tabs in the offline documentation browserRejected


Related issues

Related to Tails - Feature #15720: Use Tor Browser for offline documentation and drop the documentation browser Resolved 07/06/2018

History

#1 Updated by intrigeri over 1 year ago

It's not clear to me why this is a subtask of #14962: as you've explained on #14962#note-42, even if "Tails documentation" was perfect we would want to fix #14962 at some point, and improving "Tails documentation" is not part of that. So I'd rather drop the parent task if you don't mind. If you disagree, fine, whatever :)

#2 Updated by sajolida about 1 year ago

  • Parent task deleted (#14962)

#3 Updated by sajolida about 1 year ago

During the user testing of the VeraCrypt beta we hit two weird glitches in the documentation browser:

  • P2 had missing images on the VeraCrypt documentation. Restarting the browser solved the problem.
  • P4 had broken hyperlinks on the VeraCrypt documentation. Restarting the browser solved the problem.

I don't know how to reproduce these bugs but can provide screenshots or videoclips if needed.

#4 Updated by intrigeri about 1 year ago

FTR, now that #14962 is going to be fixed, it's not obvious to me that we should keep the "Tails documentation" browser and spend time on making it more usable.

#5 Updated by sajolida about 1 year ago

  • Status changed from Confirmed to Rejected

It's clear to me that we should switch back to using Tor Browser for offline documentation and drop the documentation browser.

#6 Updated by intrigeri about 1 year ago

  • Related to Feature #15720: Use Tor Browser for offline documentation and drop the documentation browser added

#7 Updated by intrigeri about 1 year ago

It's clear to me that we should switch back to using Tor Browser for offline documentation and drop the documentation browser.

Thanks! I've thus filed #15720 for that (#14962 is too messy so I'll leave it alone to track the root cause of the problem). I'll try to do it as part of #15023 in time for 3.9 but I can't promise I'll succeed.

Also available in: Atom PDF