Project

General

Profile

Bug #15600

Feature #15091: Upgrade to Thunderbird 60

Upgrade to Torbirdy 0.2.5

Added by u about 1 year ago. Updated 11 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
-
Target version:
Start date:
05/09/2018
Due date:
% Done:

100%

Feature Branch:
feature/15091-thunderbird-60
Type of work:
Code
Blueprint:
Starter:
Affected tool:
Email Client

Description

A user remarked that Tails uses Torbirdy from Stretch (0.2.1) while we should use TB from Unstable (0.2.5).
Tentatively assigning to FTeam.


Related issues

Related to Tails - Feature #15661: Check that Torbirdy does not enable Memory Hole Resolved 06/17/2018
Blocks Tails - Feature #15334: Core work 2018Q3: Foundations Team Resolved 02/20/2018

Associated revisions

Revision 3c84e995 (diff)
Added by Cyril Brulebois 11 months ago

Torbirdy: drop local patch following the bump to 0.2.5 (refs: #15091, #15600).

The chrome/content/preferences.js part is spotted as being already
applied, while the components/torbirdy.js part cannot be applied.
Upon inspection, the diff was applied upstream, the failure to apply
was triggered by a context change.

Revision c4c8d79b (diff)
Added by Cyril Brulebois 11 months ago

Torbirdy: update another local patch following the bump to 0.2.5 (refs: #15091, #15600).

Most of these changes were merged upstream, except the specific proxy
setting: default to socks5h://127.0.0.1:9050 proxy unless anonService is
set to “jondo”.

Revision 549301c7 (diff)
Added by Cyril Brulebois 11 months ago

Torbirdy: Enable the email wizard in the system configuration (refs: #15091, #15600).

There's:
/usr/share/xul-ext/torbirdy/defaults/preferences/000system.js → /etc/xul-ext/torbirdy.js

which is read after:
/usr/share/xul-ext/torbirdy/defaults/preferences/prefs.js

but setting extensions.torbirdy.emailwizard to true in the former
doesn't seem sufficient, even though strace confirms it's being read.

Revision fdcfa34e (diff)
Added by Cyril Brulebois 11 months ago

Torbirdy: Enable the gpg_already_torified setting in the system configuration (refs: #15091, #15600).

There's:
/usr/share/xul-ext/torbirdy/defaults/preferences/000system.js → /etc/xul-ext/torbirdy.js

which is read after:
/usr/share/xul-ext/torbirdy/defaults/preferences/prefs.js

but setting extensions.torbirdy.gpg_already_torified to true in the former
doesn't seem sufficient, even though strace confirms it's being read.

Without this setting, fetching key from a keyserver doesn't work out of the
box.

Revision d6e440b0 (diff)
Added by Cyril Brulebois 11 months ago

Torbirdy: Drop obsolete system configuration file (refs: #15091, #15600).

After the configuration handling changes implemented in TB 60, it seems
that this file is read but its contents seem ignored, so remove it
entirely and rely on manual patches (see previous commits) to set these:
- extensions.torbirdy.emailwizard: true
- extensions.torbirdy.gpg_already_torified: true

Revision 182dc799
Added by intrigeri 11 months ago

Merge remote-tracking branch 'origin/feature/15091-thunderbird-60' into devel (refs: #15091, #15600)

History

#1 Updated by intrigeri about 1 year ago

  • Assignee changed from intrigeri to u
  • QA Check set to Info Needed

[…] while we should use TB from Unstable (0.2.5).

Why? (It's not obvious to me.)

#2 Updated by intrigeri about 1 year ago

  • Target version changed from Tails_3.8 to Tails_3.9

#3 Updated by u 12 months ago

  • Assignee changed from u to intrigeri
  • QA Check deleted (Info Needed)

I've uploaded a backport today.

0.2.5:

- Add compatibility for Thunderbird 60.

0.2.4:

- Don't leak installed dictionary in TB52+.
- Disable fetching site icons.
- Correct invalid GPG keyserver options in Enigmail.
- Add support for TB 58 and 59.

0.2.3:

- Enable encrypted email headers for Enigmail (Memory Hole).
- Update Enigmail values for custom proxy settings.
- Update keyserver port to 9150 (Tor Browser default).

0.2.2:

- Enforce stronger ciphers in TorBirdy.
- Add support for already torified keyserver using modern GnuPG.
- Minimum supported Thunderbird version is 45.0, maximum is 52.*
- Update default keyserver to OnionBalance hidden service pool.

#4 Updated by u 12 months ago

#5 Updated by intrigeri 12 months ago

I've uploaded a backport today.

Awesome, thanks! kibi and I will test it soon on Thunderbird 60 as part of #15091.

#6 Updated by intrigeri 12 months ago

  • Subject changed from Use newer version of Torbirdy in Tails to Upgrade to Torbirdy 0.2.5
  • Assignee changed from intrigeri to CyrilBrulebois
  • Parent task set to #15091
  • Affected tool set to Email Client

#7 Updated by intrigeri 12 months ago

  • Feature Branch set to feature/15091-thunderbird-60

#8 Updated by intrigeri 12 months ago

#9 Updated by intrigeri 12 months ago

Meta: I've narrowed the origin scope of this ticket (suggestion to use Torbirdy from sid, without any justification so far) → upgrade to 0.2.5 (that we need for Thunderbird 60). If someone thinks we should track torbirdy/sid, please file a new ticket and explain why :)

#10 Updated by u 12 months ago

Nope. 0.2.5. is good!

#11 Updated by Anonymous 11 months ago

  • Status changed from Confirmed to In Progress

Applied in changeset commit:9108322922f66f863cdca193da48a35d5f8361da.

#12 Updated by intrigeri 11 months ago

  • Status changed from In Progress to Resolved
  • Assignee deleted (CyrilBrulebois)
  • % Done changed from 0 to 100

I think we're good here: since we can fetch email and OpenPGP keys, that must mean Torbirdy did its job.

#13 Updated by u 11 months ago

  • Related to Feature #15661: Check that Torbirdy does not enable Memory Hole added

Also available in: Atom PDF