Project

General

Profile

Feature #15599

Bug #15548: Tails can't establish a connection with obfs4 bridges and a hardware clock too far away from UTC

Improve known issues about clock going backwards

Added by sajolida about 1 year ago. Updated 5 months ago.

Status:
Resolved
Priority:
Elevated
Assignee:
-
Category:
Time synchronization
Target version:
-
Start date:
05/09/2018
Due date:
% Done:

0%

Feature Branch:
doc/15599-known-issue-clock-backwards
Type of work:
End-user documentation
Blueprint:
Starter:
Affected tool:

Description

We already have:

"Problems when the system clock goes backwards" in https://tails.boum.org/support/known_issues/#index21h2

We should improve it to:

  • Add an HTML anchor ('<a id="something-smart"></a>').
  • Add #15548 to the list of symptoms.

Related issues

Blocks Tails - Feature #15941: Core work 2018Q4 → 2019Q2: Technical writing Resolved 09/11/2018

History

#1 Updated by sajolida about 1 year ago

  • Blocks Feature #15411: Core work 2018Q2 → 2018Q3: Technical writing added

#2 Updated by intrigeri about 1 year ago

  • Target version changed from Tails_3.8 to Tails_3.9

#3 Updated by sajolida about 1 year ago

  • Description updated (diff)

#4 Updated by cbrownstein 12 months ago

  • Status changed from Confirmed to In Progress

#5 Updated by cbrownstein 12 months ago

  • Assignee changed from cbrownstein to sajolida
  • QA Check set to Info Needed

sajolida wrote:

We already have:

"Problems when the system clock goes backwards" in https://tails.boum.org/support/known_issues/#index21h2

At least:

  • Add an HTML anchor ('<a id="something-smart"></a>').
  • Build a list of symptoms and add #15548 to it.

Do you know of, or do you know where I can find a list of, symptoms other than obfs4 bridges not working (#15548)? Should I add just that for right now?

#6 Updated by sajolida 11 months ago

Do you know of, or do you know where I can find a list of, symptoms other than obfs4 bridges not working (#15548)? Should I add just that for right now?

Sorry but I don't :(

I'd make it so the list is easily expandable (bullet list?) and, for
now, only mention obfs4 bridges not working and the Applications menu
sometimes stops working (see /support/known_issues/#index21h2).

And ask intrigeri :)

#7 Updated by sajolida 11 months ago

  • Assignee changed from sajolida to cbrownstein
  • QA Check deleted (Info Needed)

#8 Updated by intrigeri 11 months ago

  • Target version changed from Tails_3.9 to Tails_3.10.1

#9 Updated by sajolida 10 months ago

  • Blocks Feature #15941: Core work 2018Q4 → 2019Q2: Technical writing added

#10 Updated by sajolida 10 months ago

  • Blocks deleted (Feature #15411: Core work 2018Q2 → 2018Q3: Technical writing)

#11 Updated by intrigeri 9 months ago

  • Target version changed from Tails_3.10.1 to Tails_3.11

#12 Updated by sajolida 8 months ago

  • Assignee changed from cbrownstein to intrigeri
  • QA Check set to Info Needed

intrigeri: Would you mind enlightening Cody on the possible symptoms and consequences of a system clock going backwards (on top of broken obfs4 bridges)?

#13 Updated by sajolida 8 months ago

  • Target version deleted (Tails_3.11)

#14 Updated by intrigeri 8 months ago

  • Assignee changed from intrigeri to cbrownstein
  • QA Check changed from Info Needed to Dev Needed

intrigeri: Would you mind enlightening Cody on the possible symptoms and consequences of a system clock going backwards (on top of broken obfs4 bridges)?

This is about a very generic class of problems: any software that relies on the system clock (as opposed to a monotonic time source) and makes decision based on time differences is potentially affected. This affects primarily time going backwards: much software is not prepared for this sort of events (granted, I'm not well prepared either :) and can simply crash. I'm afraid I have no specific example in mind except those referenced on this ticket and the one that made us add this to the list of known issues (#14250). It seems there are quite a few there: https://github.com/search?q=when+time+goes+backwards&type=Issues. So it's more of a generic "don't do that, unspecified bad things will happen" kind of thing. If that's not good enough, I can try to find a couple more specific examples that might speak to our intended audience, but it'll take me quite some time so I'm not sure it's worth it.

In passing, iime going forward can also be an issue in theory, but I expect that most software we run on a desktop these days expects sudden jumps into the future, simply because sleep & hibernation have become so common. So I don't think it's worth mentioning it.

#15 Updated by sajolida 7 months ago

  • Description updated (diff)

The problem here is that changing the clock backwards is not something that people decide to do. So we can't tell them "don't do that". Anyway, it seems like we won't be able to provide very helpful instructions anyway so I'd like to close this ticket as cheaply as possible.

Cody, I think you should do only what's described in the ticket description:

  • Add an HTML anchor ('<a id="something-smart"></a>').
  • Add #15548 to the list of symptoms.

Updating it accordingly...

#16 Updated by intrigeri 7 months ago

The problem here is that changing the clock backwards is not something that people decide to do. So we can't tell them "don't do that".

Clarification: I was not suggesting we should tell them to users ("people"). This was about "any software that relies on the system clock (as opposed to a monotonic time source) and makes decision based on time differences is potentially affected" i.e. software developers. I was asked about symptoms so please don't try to find solutions in my answer :)

Anyway, it seems like we won't be able to provide very helpful instructions anyway so I'd like to close this ticket as cheaply as possible.

Absolutely: we've already documented how to set the RTC to UTC (which solves the problem) and the next step is clear (#15168).

#17 Updated by sajolida 5 months ago

I'll send you a branch today! :)

#18 Updated by sajolida 5 months ago

  • QA Check changed from Dev Needed to Ready for QA
  • Feature Branch set to doc/15599-known-issue-clock-backwards

Here you go.

#19 Updated by cbrownstein 5 months ago

  • Assignee changed from cbrownstein to sajolida
  • QA Check changed from Ready for QA to Pass

Looks good!

#20 Updated by sajolida 5 months ago

  • Status changed from In Progress to Resolved
  • Assignee deleted (sajolida)

Merged

Also available in: Atom PDF