Project

General

Profile

Bug #15590

Installer reinstall option displays incorrect stick capacity

Added by cbrownstein 7 months ago. Updated 3 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
Installation
Target version:
Start date:
05/07/2018
Due date:
% Done:

100%

QA Check:
Pass
Feature Branch:
bugfix/15590-14849-14720-14810-installer-fixes-for-3.9, installer:bugfix/15590-14849-14720-14810-installer-fixes-for-3.9
Type of work:
Code
Blueprint:
Starter:
Affected tool:
Installer

Description

In Tails Installer, "Target USB stick" displays the capacity of the USB stick. However, the "Reinstall (delete all data)" option displays the size of the Tails partition, rather than the capacity of the USB stick. The inconsistency might suggest to the user that Tails Installer is detecting another USB stick or that there is some kind of error.

@emmapeel has confirmed this bug.

Screenshot from 2018-05-05 17-16-06.png View (35.5 KB) cbrownstein, 06/19/2018 11:54 PM

Screenshot from 2018-05-05 17-16-36.png View (13.4 KB) cbrownstein, 06/19/2018 11:54 PM


Related issues

Blocked by Tails - Bug #14810: Tails Installer allows buggy "Reinstall (delete all data)" on too small USB sticks Resolved 10/07/2017

Associated revisions

Revision 02fb15a7 (diff)
Added by intrigeri 5 months ago

Enable the bugfix-15590-14849-14720-14810-installer-fixes-for-3.9 APT overlay (refs: #15590).

Revision 48a05f21
Added by intrigeri 5 months ago

Merge branch 'bugfix/15590-14849-14720-14810-installer-fixes-for-3.9' into devel (Fix-committed: #15590, #14849, #14720, #14810)

Revision f5fbe30b (diff)
Added by intrigeri 5 months ago

Enable the bugfix-15590-14849-14720-14810-installer-fixes-for-3.9 APT overlay (refs: #15590).

History

#1 Updated by intrigeri 7 months ago

  • Assignee set to kurono

kurono, wanna take a look?

#2 Updated by kurono 6 months ago

  • Assignee changed from kurono to emmapeel
  • QA Check changed from Dev Needed to Info Needed

intrigeri wrote:

kurono, wanna take a look?

I cannot reproduce this. More info about it? Like a screenshot.

#3 Updated by cbrownstein 6 months ago

Hi!

kurono wrote:

I cannot reproduce this. More info about it? Like a screenshot.

I'm adding screenshots to this ticket. 128 GB is the correct capacity of the drive.

#4 Updated by kurono 6 months ago

  • Assignee deleted (kurono)
  • Target version set to Tails_3.8
  • QA Check changed from Info Needed to Ready for QA
  • Feature Branch set to bug/15590-incorrect-stick-capacity

#5 Updated by intrigeri 6 months ago

  • Assignee set to intrigeri
  • Target version changed from Tails_3.8 to Tails_3.9

#6 Updated by intrigeri 6 months ago

  • Status changed from Confirmed to In Progress
  • Assignee changed from intrigeri to kurono
  • QA Check changed from Ready for QA to Info Needed

Please rebase your work on top of the current upstream master branch, as opposed to the packaging (tails/master) branch.

#7 Updated by kurono 6 months ago

  • Assignee changed from kurono to intrigeri
  • QA Check changed from Info Needed to Ready for QA

intrigeri wrote:

Please rebase your work on top of the current upstream master branch, as opposed to the packaging (tails/master) branch.

Done.

#8 Updated by intrigeri 6 months ago

  • % Done changed from 0 to 60

Code review passes. I'll test in a batch with #14720 and #14810 once the latter is ready.

#9 Updated by intrigeri 6 months ago

  • Blocked by Bug #14810: Tails Installer allows buggy "Reinstall (delete all data)" on too small USB sticks added

#10 Updated by intrigeri 5 months ago

Merged into bugfix/15590-14849-14720-14810-installer-fixes-for-3.9 (both liveusb-creator.git and tails.git) except the logo change (quilt won't take binary stuff), built and uploaded a package.

#11 Updated by intrigeri 5 months ago

Test suite passes on Jenkins. Next step: test manually to confirm the bugs the branch is meant to fix are gone and that nothing else is broken.

#12 Updated by intrigeri 5 months ago

  • % Done changed from 60 to 90
  • QA Check changed from Ready for QA to Pass
  • Feature Branch changed from bug/15590-incorrect-stick-capacity to bugfix/15590-14849-14720-14810-installer-fixes-for-3.9, installer:bugfix/15590-14849-14720-14810-installer-fixes-for-3.9

I confirm this fixes the bug and the "Reinstall" feature still works.

#13 Updated by intrigeri 5 months ago

  • Status changed from In Progress to Fix committed
  • Assignee deleted (intrigeri)
  • % Done changed from 90 to 100

Merged into devel!

#14 Updated by intrigeri 4 months ago

  • Status changed from Fix committed to In Progress

#15 Updated by intrigeri 4 months ago

  • Status changed from In Progress to Fix committed

#16 Updated by intrigeri 3 months ago

  • Status changed from Fix committed to Resolved

Also available in: Atom PDF