Project

General

Profile

Feature #15585

Feature #14568: Additional Software Packages

Bug #15567: Fix bugs and UX issues in the Additional Software beta

Change "Add to Persistent Storage" into "Install Every Time"

Added by sajolida about 1 year ago. Updated about 1 year ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
-
Target version:
Start date:
05/05/2018
Due date:
% Done:

100%

Feature Branch:
feature/15585-install-every-time
Type of work:
User interface design
Blueprint:
Starter:
Affected tool:
Additional Software Packages

Description

This is not a clear finding from the user testing of the Additional Software beta but more a question that matured in my mind.

Why don't we have:

Add mumble to your additional software?

To install it automatically from your persistent storage when you start Tails.

[Install Only Once] [Install Every Time]

I think that the reasons why we put "Add to Persistent Storage" when doing the paper prototyping where:

  • To help people understand the relationship between additional software and the persistent storage.
  • To be a bit more consistent with the other notification when there is no persistent storage yet ("Configure Persistent Storage").

I'm not so sure anymore about these reasons:

  • While writing the documentation we found it hard to explain that even when you choose "Install Only Once", the packages are saved in persistent storage which is contrary what the button suggests when put in opposition to "Add to Persistent Storage".
  • Put out of context, "Install Only Once" vs "Install Every Time" looks like a simplier alternative to choose from.

History

#1 Updated by sajolida about 1 year ago

  • Assignee set to alant
  • QA Check set to Info Needed

Alan: What do you think?

#2 Updated by sajolida about 1 year ago

  • Assignee changed from alant to sajolida
  • Parent task changed from #14592 to #15567
  • QA Check deleted (Info Needed)

#3 Updated by sajolida about 1 year ago

  • Target version set to Tails_3.8

#4 Updated by sajolida about 1 year ago

  • Affected tool set to Additional Software Packages

#5 Updated by mercedes508 about 1 year ago

  • Status changed from New to Confirmed

#6 Updated by sajolida about 1 year ago

  • Target version changed from Tails_3.8 to Tails_3.9

#7 Updated by sajolida about 1 year ago

  • Assignee changed from sajolida to alant
  • QA Check set to Ready for QA
  • Feature Branch set to feature/15585-install-every-time

Please have a look!

#8 Updated by alant about 1 year ago

Great thanks!

#9 Updated by alant about 1 year ago

  • Status changed from Confirmed to Resolved
  • Assignee deleted (alant)
  • % Done changed from 0 to 100
  • QA Check changed from Ready for QA to Pass

Also available in: Atom PDF