Project

General

Profile

Feature #15582

Feature #14568: Additional Software Packages

Bug #15567: Fix bugs and UX issues in the Additional Software beta

Don't display a file:/// URL to user without administration password

Added by sajolida about 1 year ago. Updated 9 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
-
Target version:
Start date:
05/05/2018
Due date:
% Done:

80%

QA Check:
Feature Branch:
feature/15582-avoid-file-urls
Type of work:
Code
Blueprint:
Starter:
Affected tool:
Additional Software Packages

Description

During the user testing of the Additional Software beta, P1 failed to interpret the file:/// as something she could open in a browser. She said it looked like a path to a file.

The downside of pointing to https:// is that they won't work when offline.

I think we should:

  • Assume that people can get online either using Tails or with other means.
  • Treat more carefully the display of such links in case we can't assume that people can get online (eg. after disabling the network when doing an upgrade).

Also, these links can't be opened anymore anyway since #14962.

History

#1 Updated by sajolida 12 months ago

  • Assignee set to sajolida

We'll try to fix that but it's not a blocker to deliver SponsorW_2017.

#2 Updated by sajolida 12 months ago

  • Parent task changed from #14592 to #15567

#4 Updated by sajolida 12 months ago

  • Affected tool set to Additional Software Packages

#5 Updated by sajolida 10 months ago

  • Subject changed from Don't display file:/// URLs to user to Don't display a file:/// URL to user without administration password
  • Assignee changed from sajolida to alant
  • QA Check set to Ready for QA

I wrote two branches to fix that:

  • greeter.git:feature/15582-avoid-file-urls
  • tails.git:feature/15582-avoid-file-urls to be merged in master so I can test the result from the development versions

#6 Updated by sajolida 10 months ago

  • Target version set to Tails_3.9

I'd like to have this in the official release → targetting 3.9. But if you can't do it that's fine.

#7 Updated by alant 10 months ago

  • Assignee changed from alant to sajolida
  • % Done changed from 0 to 30
  • QA Check changed from Ready for QA to Info Needed

sajolida wrote:

I wrote two branches to fix that:

  • greeter.git:feature/15582-avoid-file-urls

I merged this one, thanks.

  • tails.git:feature/15582-avoid-file-urls to be merged in master so I can test the result from the development versions

I don't understand this one, the commits I see in this branch look unrelated. Please point le to the right commit number.

#8 Updated by alant 10 months ago

  • Status changed from Confirmed to In Progress

#9 Updated by sajolida 10 months ago

  • tails.git:feature/15582-avoid-file-urls to be merged in master so I can test the result from the development versions

I don't understand this one, the commits I see in this branch look unrelated. Please point le to the right commit number.

It's about 9b7344e311, see
https://git.tails.boum.org/tails/log/?h=feature/15582-avoid-file-urls.

#10 Updated by sajolida 10 months ago

  • Assignee changed from sajolida to alant
  • QA Check changed from Info Needed to Ready for QA
  • Feature Branch set to feature/15582-avoid-file-urls

#11 Updated by alant 10 months ago

  • Assignee changed from alant to segfault

sajolida wrote:

  • tails.git:feature/15582-avoid-file-urls to be merged in master so I can test the result from the development versions

I don't understand this one, the commits I see in this branch look unrelated. Please point le to the right commit number.

It's about 9b7344e311, see
https://git.tails.boum.org/tails/log/?h=feature/15582-avoid-file-urls.

I'm sorry I don't feel skilled to review this part.

#12 Updated by segfault 10 months ago

  • Assignee changed from segfault to sajolida
  • QA Check changed from Ready for QA to Info Needed

I also see a lot of unrelated commits on tails.git:feature/15582-avoid-file-urls.

The rewrite rule in 9b7344e311c9db5dcacd3452a7430f438feb92d0 looks good.

The new URL in 2f28b0c1f39c744cd0be5c8bd419f7ebe0dabca7 in the greeter also looks good. But
I wanted to check where the no-password-lecture.txt is used, and whether it would be an option to use markup to show a different link description than the actual URL. I couldn't find where the file content is being used for anything - could you point to that?

#13 Updated by sajolida 10 months ago

  • Assignee changed from sajolida to segfault
  • QA Check changed from Info Needed to Ready for QA

I also see a lot of unrelated commits on tails.git:feature/15582-avoid-file-urls.

When I do git log origin/master..origin/feature/15582-avoid-file-urls I only see 9b7344e311. It's based on master so I can test it before the release. See my original merge request in #15582#note-9.

The rewrite rule in 9b7344e311c9db5dcacd3452a7430f438feb92d0 looks good.

Cool!

The new URL in 2f28b0c1f39c744cd0be5c8bd419f7ebe0dabca7 in the greeter also looks good. But
I wanted to check where the no-password-lecture.txt is used, and whether it would be an option to use markup to show a different link description than the actual URL. I couldn't find where the file content is being used for anything - could you point to that?

The file no-password-lecture.txt is displayed in the terminal when people try to use sudo without configuring an administration password. So it's plain text, wrapped at 80 chars, etc.

#14 Updated by segfault 10 months ago

  • Assignee changed from segfault to sajolida
  • QA Check changed from Ready for QA to Pass

sajolida wrote:

I also see a lot of unrelated commits on tails.git:feature/15582-avoid-file-urls.

When I do git log origin/master..origin/feature/15582-avoid-file-urls I only see 9b7344e311. It's based on master so I can test it before the release. See my original merge request in #15582#note-9.

I think I was comparing with devel, because it's a feature/ branch. But I see that you wrote that you want to merge it in master, so my fault.

The new URL in 2f28b0c1f39c744cd0be5c8bd419f7ebe0dabca7 in the greeter also looks good. But
I wanted to check where the no-password-lecture.txt is used, and whether it would be an option to use markup to show a different link description than the actual URL. I couldn't find where the file content is being used for anything - could you point to that?

The file no-password-lecture.txt is displayed in the terminal when people try to use sudo without configuring an administration password. So it's plain text, wrapped at 80 chars, etc.

Ah, OK, thanks! Then I guess we can't do better than using the shorter URL with the redirect.

#15 Updated by u 10 months ago

Looks like this can be merged, sajolida.

#16 Updated by sajolida 9 months ago

  • Assignee changed from sajolida to alant
  • QA Check changed from Pass to Info Needed

So I merged the branch into tails.git:master and the redirection is working. Yeah!

But I couldn't find my commit (2f28b0c) in any branch of the greeter.git except feature/15582-avoid-file-urls.

Alan: where did you merge it?

#17 Updated by alant 9 months ago

  • Assignee changed from alant to sajolida
  • % Done changed from 30 to 80
  • QA Check changed from Info Needed to Ready for QA

Sorry I forgot to push. This is now done.

#18 Updated by sajolida 9 months ago

  • Status changed from In Progress to Fix committed
  • Assignee deleted (sajolida)
  • QA Check deleted (Ready for QA)

Now it's there, thanks!

#19 Updated by intrigeri 9 months ago

  • Status changed from Fix committed to Resolved

Also available in: Atom PDF