Project

General

Profile

Feature #15581

Feature #14568: Additional Software Packages

Bug #15567: Fix bugs and UX issues in the Additional Software beta

Remove and Cancel buttons don't work after escaping password prompt

Added by sajolida about 1 year ago. Updated 9 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
-
Target version:
Start date:
05/05/2018
Due date:
% Done:

100%

QA Check:
Feature Branch:
Type of work:
Code
Blueprint:
Starter:
Affected tool:
Additional Software Packages

Description

Stesp to reproduce:

  • Add Mumble to your additional software.
  • Open Additional Software.
  • Click the [X] button to remove Mumble.
  • Click Remove to confirm.
  • At the password prompt press Esc.
  • Click Cancel → the Cancel button is broken! (the Remove button as well).

This affected 2 participants during the user testing of the Additional Software beta.

Associated revisions

Revision a2568bb9 (diff)
Added by alant 11 months ago

ASP: factorize exception dialog in configuration window

Refs: #15581

Revision 90204929 (diff)
Added by alant 11 months ago

ASP: configuration catch exception in remove helper

Refs: #15581

History

#1 Updated by sajolida 12 months ago

  • Parent task changed from #14592 to #15567

We'll try to fix that but it's not a blocker to deliver SponsorW_2017.

#2 Updated by alant 11 months ago

  • Status changed from Confirmed to In Progress

#3 Updated by alant 11 months ago

  • % Done changed from 0 to 30
  • QA Check set to Ready for QA

#4 Updated by sajolida 10 months ago

  • Target version set to Tails_3.9

If it's Ready for QA, maybe you want to target 3.9 to have it in the official release?

#5 Updated by alant 10 months ago

  • Status changed from In Progress to Fix committed
  • Assignee deleted (alant)
  • % Done changed from 30 to 100
  • QA Check changed from Ready for QA to Pass

Tested OK in ISO built from e3327d7236fef3bba006a5cc8c55b49dfb77867b.

#6 Updated by alant 10 months ago

  • Status changed from Fix committed to Resolved

The error dialog is quite ugly (displays plain error message) but UI is responding again.

#7 Updated by sajolida 10 months ago

  • Status changed from Resolved to Fix committed
  • Assignee set to sajolida
  • QA Check changed from Pass to Ready for QA

I don't like it when error messages are ugly so I'll check the actual behavior in 3.9~rc1.

#8 Updated by u 10 months ago

Let us know once you've done that. Deadline to have this in 3.9 is August 15th.

#9 Updated by sajolida 9 months ago

  • Assignee changed from sajolida to alant
  • QA Check changed from Ready for QA to Info Needed

Alan: I can't find any reference to e3327d7236fef3bba006a5cc8c55b49dfb77867b in tails.git or any recent reference to #15581 in feature/14594-asp-gui. Where can I find your commit?

u: In my last note, I wrote "I'll check the actual behavior in 3.9~rc1" which is planned for after August 15. I said that on purpose because I want to test the whole thing once it's in RC to save me quite some time. I'm severly overclocked on this project and I think that this issue is small enough to be either be fixed after the RC or in a bugfix release.

#10 Updated by alant 9 months ago

  • Assignee changed from alant to sajolida
  • QA Check changed from Info Needed to Ready for QA

sajolida wrote:

Alan: I can't find any reference to e3327d7236fef3bba006a5cc8c55b49dfb77867b in tails.git or any recent reference to #15581 in feature/14594-asp-gui. Where can I find your commit?

90204929a1a0190d824c5c6a1ef933ded9ae036a (https://git.tails.boum.org/tails/commit/?h=feature/14594-asp-gui&id=90204929a1a0190d824c5c6a1ef933ded9ae036a)

#11 Updated by sajolida 9 months ago

Got it now! I'll test it live on the release candidate.

#12 Updated by sajolida 9 months ago

  • Assignee deleted (sajolida)
  • QA Check deleted (Ready for QA)

It seems to work fine now, congrats!

#13 Updated by intrigeri 9 months ago

  • Status changed from Fix committed to Resolved

Also available in: Atom PDF