Project

General

Profile

Bug #15575

Feature #14568: Additional Software Packages

Bug #15567: Fix bugs and UX issues in the Additional Software beta

Point to /doc instead of /getting_started from "Tails documentation" desktop launcher

Added by sajolida over 1 year ago. Updated over 1 year ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
-
Target version:
Start date:
05/05/2018
Due date:
% Done:

100%

Feature Branch:
feature/15575-open-doc-instead-of-getting-started
Type of work:
Code
Blueprint:
Starter:
Affected tool:
Additional Software Packages

Description

  • /getting_started is very old and would probably benefit from a serious lifting.
  • During the user testing of the Additional Software beta, 3 out of 5 participants ended up on this page. None of them read it. 2 used it to reach /doc which is what they were looking for. 1 got lost and ended up on /design.

I propose to point to /doc instead of /getting_started.

sun.png View (19.7 KB) sajolida, 06/03/2018 03:31 PM


Related issues

Related to Tails - Bug #14962: Tor Browser >= 7.0.8 fails to render local pages correctly Resolved 11/16/2017
Blocks Tails - Feature #15392: Core work 2018Q2 → 2018Q3: User experience Resolved 03/09/2018

Associated revisions

Revision de892614 (diff)
Added by sajolida over 1 year ago

Point to /doc instead of /getting_started (Will-fix: #15575)

- /getting_started is very old and needs a serious lifting.

- During the user testing of the Additional Software beta, 3 out of 5
participants ended up on this page. None of them read it. 2 used it to reach
/doc which is what they were looking for. 1 got lost and ended up on /design.

Revision def825b6 (diff)
Added by intrigeri over 1 year ago

Test suite: update expected heading when browsing the documentation offline (refs: #15575).

The "Getting started" page had a 'Found a bug?' heading but the "Documentation"
page has no such thing.

Revision 8df30a70
Added by intrigeri over 1 year ago

Merge branch 'feature/15575-open-doc-instead-of-getting-started' into stable (Fix-committed: #15575)

History

#1 Updated by xin over 1 year ago

  • Subject changed from Point to /dot instead of /getting_started from "Tails documentation" desktop launcher to Point to /doc instead of /getting_started from "Tails documentation" desktop launcher

#2 Updated by sajolida over 1 year ago

  • Related to Bug #14962: Tor Browser >= 7.0.8 fails to render local pages correctly added

#3 Updated by sajolida over 1 year ago

  • Blocks Feature #15392: Core work 2018Q2 → 2018Q3: User experience added

#4 Updated by sajolida over 1 year ago

  • Target version set to Tails_3.9
  • QA Check set to Ready for QA

Code is ready!

#5 Updated by intrigeri over 1 year ago

  • Assignee set to intrigeri

#6 Updated by sajolida over 1 year ago

  • Status changed from Confirmed to In Progress

Applied in changeset commit:0ae97cd336cf16d409317e70b84df2dd22b5bd8a.

#7 Updated by intrigeri over 1 year ago

  • Feature Branch set to feature/15575-open-doc-instead-of-getting-started

#8 Updated by intrigeri over 1 year ago

  • Assignee changed from intrigeri to sajolida
  • QA Check changed from Ready for QA to Dev Needed

I've not tested your proposed change but my understanding of the code is that it'll make the tails-documentation command open /doc instead of /getting_started when no argument is passed.

But the launchers (config/chroot_local-includes/usr/share/applications/tails-documentation.desktop.in and config/chroot_local-includes/etc/skel/Desktop/tails-documentation.desktop.in) explicitly run /usr/local/bin/tails-documentation getting_started so I doubt this commit is enough. I think you need to patch these launchers as well.

Sorry if you actually tested an ISO built from this branch and I'm guessing it all wrong!

Also, this change will require an update of features/documentation.feature. I can handle this part myself when I'll be merging your branch.

#9 Updated by intrigeri over 1 year ago

  • % Done changed from 0 to 10

Also, if you wish to rebase your branch on top of stable (nice side effect: it won't be affected anymore by devel currently failing to build) I'd gladly consider merging this for 3.8. The needed changes seem small, self-contained and not risky so we could as well fix that ASAP :)

#10 Updated by sajolida over 1 year ago

  • Target version changed from Tails_3.9 to Tails_3.8
  • QA Check changed from Dev Needed to Ready for QA

Cool if I can get that into stable!

I force-pushed a new branch based on stable and will monitor its build and its tests :)

#11 Updated by sajolida over 1 year ago

I tested the resulting ISO and it works:

  • Opening the "Tails documentation" launcher offline opens /doc in the documentation browser.
  • Opening the "Tails documentation" launcher online opens /doc in Tor Browser.

The automatic test suite seems to work as well: see the sun in attachment :)

#12 Updated by sajolida over 1 year ago

  • Assignee changed from sajolida to intrigeri

#13 Updated by intrigeri over 1 year ago

  • % Done changed from 10 to 60

sajolida wrote:

I tested the resulting ISO and it works:

  • Opening the "Tails documentation" launcher offline opens /doc in the documentation browser.
  • Opening the "Tails documentation" launcher online opens /doc in Tor Browser.

\o/

Code review passes.

The automatic test suite seems to work as well: see the sun in attachment :)

Wow, thanks for updating it yourself! Now, that sun is very nice (thanks) but sadly it does not mean anything: all those tests are tagged "fragile" which implies they're not run on our Jenkins by default. So I've pushed a copy of your branch to feature/15575-open-doc-instead-of-getting-started+force-all-tests and with that prefix, Jenkins will run the entire test suite.

#14 Updated by intrigeri over 1 year ago

These test cases are indeed too fragile to be very useful. Still, running them on Jenkins made me identify one part of the test suite that hadn't been updated yet; now done. I'll run the automated tests again FWIW.

#15 Updated by intrigeri over 1 year ago

  • % Done changed from 60 to 70

I've tested this manually and it works fine. I'll wait for the automatic test results before merging, that I should have in ~5 hours: if they fail due to usual fragility issues I'll ignore them and will merge anyway. If they fail due to changes introduced by this branch I'll fix that.

And FTR these automated test cases are fragile because the Desktop launchers are buggy, see #11717#note-13 for my last consistent set of thoughts on this topic, that I'll refresh soonish due to #11717#note-17.

#16 Updated by intrigeri over 1 year ago

  • Status changed from In Progress to Fix committed
  • Assignee deleted (intrigeri)
  • % Done changed from 70 to 100
  • QA Check changed from Ready for QA to Pass

Test suite results now look not worse than usual, merging!

#17 Updated by sajolida over 1 year ago

  • Parent task set to #15567

#18 Updated by sajolida over 1 year ago

  • Affected tool set to Additional Software Packages

#19 Updated by intrigeri over 1 year ago

  • Status changed from Fix committed to In Progress

#20 Updated by intrigeri over 1 year ago

  • Status changed from In Progress to Fix committed

#21 Updated by intrigeri over 1 year ago

  • Target version changed from Tails_3.8 to Tails_3.7.1

#22 Updated by intrigeri over 1 year ago

  • Assignee set to BitingBird

#23 Updated by intrigeri over 1 year ago

  • Assignee deleted (BitingBird)

#24 Updated by intrigeri over 1 year ago

  • Status changed from Fix committed to Resolved

Also available in: Atom PDF