Project

General

Profile

Feature #15571

Feature #14568: Additional Software Packages

Bug #15567: Fix bugs and UX issues in the Additional Software beta

Improve SEO when people search for the administration password

Added by sajolida over 1 year ago. Updated about 1 year ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
-
Target version:
Start date:
05/05/2018
Due date:
% Done:

100%

Feature Branch:
3e8d48209d + ecde9b5df4
Type of work:
End-user documentation
Blueprint:
Starter:
Affected tool:
Additional Software Packages

Description

  • During the Additional Software user testing, P5 searched for "how to be root on tails" which returned a YouTube video as first result instead of our doc.
  • On tails-bugs@ people are asking for what is the "user amnesia password".

password-prompt.png View (19.6 KB) sajolida, 06/28/2018 05:21 PM

History

#1 Updated by sajolida over 1 year ago

  • Subject changed from Improve SEO when people search for "root" instead of "administration" to Improve SEO when people search for the administration password
  • Description updated (diff)

#2 Updated by sajolida over 1 year ago

  • Assignee changed from sajolida to emmapeel
  • Parent task changed from #14592 to #15567

Emma: How would you solve that? Let's discuss a bit before implementing anything.

#3 Updated by sajolida over 1 year ago

  • Affected tool set to Additional Software Packages

#4 Updated by emmapeel over 1 year ago

  • Assignee changed from emmapeel to sajolida

sajolida wrote:

Emma: How would you solve that? Let's discuss a bit before implementing anything.

Not sure how to mess with headers in ikiwiki. I guess I would add the keywords to titles with root or admin, and <strong>, <em> stuff in keywords in paragraphs.

I think we have a deeper problem with the search box, though: #9900

#5 Updated by sajolida over 1 year ago

Improving SEO from external search engine will probably help with the internal search engine as well.

And also, it's actually a mess because the password prompt as for the "amnesia password", yet another name for the same password :(

So let's use these queries as reference:

I'm thinking about the following, though it's ugly. What about starting the page with "In Tails, an administration password (also called root password or amnesia password) [...]"?

That should probably be enough to fix the queries that don't work yet.

We should do this changes on master and test them a few weeks after merging.

I also prepared a screenshot that might help understanding the terminology mess. See attachment. We could add stuff to its alt tag as well (and add a note that the alt tab is useful for SEO because otherwise xin will rightfully propose to remove it).

#6 Updated by emmapeel over 1 year ago

Yeah I think that would help. Do you want me to prepare a branch?

#7 Updated by emmapeel over 1 year ago

  • Assignee changed from emmapeel to sajolida

#8 Updated by sajolida over 1 year ago

  • Assignee changed from sajolida to emmapeel

Yes, but please do it in doc/14589-additional-software directly.

#9 Updated by u over 1 year ago

Ping?

#10 Updated by sajolida over 1 year ago

  • Status changed from Confirmed to Resolved
  • Assignee changed from emmapeel to u
  • QA Check changed from Dev Needed to Pass
  • Feature Branch set to 3e8d48209d + ecde9b5df4

Despite me literally spelling out a solution, emmapeel didn't submit patches in time for the freeze, so I did that myself in master (so we can test the result before the release). That's 3e8d48209d + ecde9b5df4.

#11 Updated by sajolida over 1 year ago

  • Status changed from Resolved to In Progress

Oops, actually, I want to keep this ticket open to check the improvements in search engines in a few weeks.

Ulrike: Reassign it to me once you had a quick look. The same as #15574#note-1 applies: do whatever you want with this info as a manager but don't review this work in depth.

#12 Updated by u over 1 year ago

  • Status changed from In Progress to 11
  • Assignee changed from u to sajolida
  • % Done changed from 0 to 100

Thanks! Reassigning back to you for review in a few weeks.

#13 Updated by intrigeri over 1 year ago

  • Status changed from 11 to In Progress

(Otherwise this will be closed when we release 3.9, which apparently would be incorrect.)

#14 Updated by sajolida over 1 year ago

  • Target version changed from Tails_3.9 to Tails_3.10.1

I think it's ok to do this after 3.9 because until then I'll be super busy...

#15 Updated by sajolida over 1 year ago

I don't think DuckDuckGo crawled our website since we did the change.

#16 Updated by sajolida about 1 year ago

Now DuckDuckGo crawled again. Going back to the original URLs:

#17 Updated by u about 1 year ago

I've checked DDG again and it all looks good. The code wa merged afaics, so let's close this ticket?

#18 Updated by sajolida about 1 year ago

  • Status changed from In Progress to Resolved
  • QA Check deleted (Pass)

Yeah... I'm not 100% happy with the results but it definitely got improved and I'm not sure whatelse we could do → closing this ticket.

Also available in: Atom PDF