Project

General

Profile

Bug #15567

Feature #14568: Additional Software Packages

Fix bugs and UX issues in the Additional Software beta

Added by alant about 1 year ago. Updated 7 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
-
Target version:
Start date:
01/27/2016
Due date:
% Done:

100%

QA Check:
Feature Branch:
Type of work:
Code
Blueprint:
Starter:
Affected tool:
Additional Software Packages

Subtasks

Bug #11013: Consider removing applications that require administration password from menu if no password is setResolvedsajolida

Feature #14592: Fix bugs and UX issues identified by User testing session for Additional Software GUIDuplicate

Feature #15267: Investigate what happens on debconf critical questionsRejected

Bug #15381: Notification for adding 2+ newly installed packages to persistence is poorly phrasedResolved

Bug #15566: Additional Software on newly created partition are not shown in configuration windowResolved

Feature #15571: Improve SEO when people search for the administration passwordResolvedsajolida

Feature #15574: Improve scanability of instructions to configuration administration passwordResolved

Bug #15575: Point to /doc instead of /getting_started from "Tails documentation" desktop launcherResolved

Feature #15578: Explain better what removing a package meansResolved

Feature #15580: Explain when "unlock your persistent storage" should happenResolved

Feature #15581: Remove and Cancel buttons don't work after escaping password promptResolved

Feature #15582: Don't display a file:/// URL to user without administration passwordResolved

Feature #15585: Change "Add to Persistent Storage" into "Install Every Time"Resolved

Feature #15587: Have two versions of install_label GtkLabelResolved

Bug #15822: Install notification of Additional Software is not handling target releaseResolved

Bug #15879: ASP installation notification is shown twiceResolved

Bug #15892: Notifications are displayed twice when packages are upgradedDuplicate


Related issues

Blocked by Tails - Feature #14591: Conduct User Testing of Additional Software packages GUI Resolved 09/04/2017 06/01/2018

History

#1 Updated by alant about 1 year ago

  • Parent task set to #14568

#2 Updated by sajolida 12 months ago

  • Subject changed from Fix bugs in ASP beta release to Fix bugs and UX issues in the Additional Software beta

#3 Updated by sajolida 12 months ago

  • Blocked by Feature #14591: Conduct User Testing of Additional Software packages GUI added

#4 Updated by sajolida 12 months ago

  • Affected tool set to Additional Software Packages

#5 Updated by sajolida 12 months ago

  • Target version set to Tails_3.9

#6 Updated by alant 10 months ago

  • Assignee deleted (alant)

#7 Updated by u 9 months ago

  • Assignee set to intrigeri

intrigeri, both remaining subtickets are for you to see but they are marked as Pass.
The ticket about SEO will be done for 3.10 it seems.

#8 Updated by intrigeri 9 months ago

  • Assignee changed from intrigeri to sajolida

These two tickets are for me to merge only, which will be done tomorrow morning for 3.9. The other remaining task (#15571) is on sajolida's plate.

#9 Updated by intrigeri 9 months ago

  • Target version changed from Tails_3.9 to Tails_3.10.1

#10 Updated by sajolida 9 months ago

  • Assignee changed from sajolida to alant

#11 Updated by u 7 months ago

  • Assignee changed from alant to sajolida

Assigning to sajolida because the only remaining subticket is assigned to him.

#12 Updated by u 7 months ago

  • Assignee changed from sajolida to alant

Oh actually, let's say that Alan is the owner of the last remaining non-"Pass" marked subtask. Once #15911 is done, you can close this placeholder ticket.

#13 Updated by intrigeri 7 months ago

  • Target version changed from Tails_3.10.1 to Tails_3.11

#14 Updated by u 7 months ago

  • Status changed from Confirmed to Resolved

All subtickets have been resolved, yay!

Also available in: Atom PDF