Project

General

Profile

Bug #15555

Feature #11834: Migrate our infrastructure to Puppet 4

PuppetDB is regularly unavailable

Added by intrigeri over 1 year ago. Updated over 1 year ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Infrastructure
Target version:
Start date:
04/28/2018
Due date:
% Done:

100%

Feature Branch:
Type of work:
Sysadmin
Blueprint:
Starter:
Affected tool:


Related issues

Blocks Tails - Feature #13284: Core work: Sysadmin (Adapt our infrastructure) Confirmed 06/30/2017

History

#1 Updated by intrigeri over 1 year ago

  • Blocks Feature #13284: Core work: Sysadmin (Adapt our infrastructure) added

#2 Updated by intrigeri over 1 year ago

  • Status changed from Confirmed to In Progress
  • % Done changed from 0 to 10
  • QA Check set to Ready for QA

The OOM killer sometimes kills PuppetDB. Last time it happened icinga2 triggered it, an APT regular job + apt-show-versions + (check_upgradeable) were running and the PuppetDB java process took total-vm:2777752kB, anon-rss:501188kB, file-rss:0kB, shmem-rss:0kB.

I think this VM simply needs a bit more RAM since we now run PuppetDB on top of everything we used to run before the upgrade to Puppet 4 (and MySQL was replaced with PostgreSQL but I doubt that makes a big difference). So I gave it ~256MiB more RAM (rounding it so it's a multiple of 2048 KiB, our huge pages size). Let's see if it helps.

#3 Updated by intrigeri over 1 year ago

  • Assignee changed from intrigeri to groente
  • % Done changed from 10 to 50

No such problem in the last 4 days so I think we're good.

#4 Updated by groente over 1 year ago

  • Status changed from In Progress to Resolved
  • % Done changed from 50 to 100
  • QA Check changed from Ready for QA to Pass

ok, let's re-open if/when we notice oom-killings again

Also available in: Atom PDF