Project

General

Profile

Feature #15546

Feedback needed when clicking on Persistence wizard → configure ASP gear button

Added by emmapeel over 1 year ago. Updated 6 months ago.

Status:
Rejected
Priority:
Low
Assignee:
-
Category:
-
Target version:
-
Start date:
04/18/2018
Due date:
% Done:

0%

Feature Branch:
Type of work:
Code
Blueprint:
Starter:
Affected tool:
Additional Software Packages

Description

When clicking on the configuration button on the Additional software section of the Persistence wizard, nothing happens for a while.

I clicked several times on it, and the menu opened several times too.

While fixing #15528 could also make this experience a little better, I think it would be good to have also a 'spinner' while you wait for the configuration window to open.


Related issues

Related to Tails - Bug #15528: Additional Software gets opened multiple times Confirmed 04/12/2018
Related to Tails - Bug #15101: Add feedback when opening desktop launchers Resolved 12/25/2017
Related to Tails - Feature #15827: Give feedback while the persistence setup is starting Confirmed 08/21/2018

Associated revisions

Revision 63b325b8 (diff)
Added by alant about 1 year ago

ASP: add WM class to fix startup notification of configuration window

Will-fix: #15546

History

#1 Updated by emmapeel over 1 year ago

  • Status changed from New to Confirmed

#2 Updated by intrigeri over 1 year ago

If there's correct feedback when starting the same app via other means (e.g. apps menu) then it's a tps bug. Otherwise it's a bug in the ASP config .desktop file (see #15101 for details).

#3 Updated by sajolida over 1 year ago

We'll try to fix that but it's not a blocker to deliver SponsorW_2017.

#4 Updated by sajolida over 1 year ago

  • Parent task changed from #14592 to #15567

#5 Updated by alant about 1 year ago

  • Status changed from Confirmed to In Progress
  • % Done changed from 0 to 10
  • QA Check changed from Dev Needed to Ready for QA

I added WMClass to .desktop file, to be tested in next ISO.

#6 Updated by alant about 1 year ago

  • Assignee changed from alant to intrigeri
  • QA Check changed from Ready for QA to Dev Needed

intrigeri wrote:

If there's correct feedback when starting the same app via other means (e.g. apps menu) then it's a tps bug.

I fixed the .desktop file, there is now good feedback from the Applications menu, but not from Persistence Setup.

#7 Updated by intrigeri about 1 year ago

  • % Done changed from 10 to 0

I'll give it a try but we've decided this was not a blocker we're supposed to submit the entire branch for review in a few days, and I was not supposed to be available for this work right now. So to be clear, don't count on this being fixed in 3.9 (or ever).

#8 Updated by u about 1 year ago

  • Related to Bug #11528: Tails DVD Labeled "Windows" When Booted added

#9 Updated by u about 1 year ago

  • Related to deleted (Bug #11528: Tails DVD Labeled "Windows" When Booted)

#10 Updated by u about 1 year ago

  • Related to Bug #15528: Additional Software gets opened multiple times added

#11 Updated by u about 1 year ago

  • Related to Bug #15101: Add feedback when opening desktop launchers added

#12 Updated by u about 1 year ago

Ack. Let's see if you find time, otherwise postpone and/or reassign to Alan?

#13 Updated by intrigeri about 1 year ago

u wrote:

Ack. Let's see if you find time,

Yep! I'm taking a look as we speak.

otherwise postpone and/or reassign to Alan?

I'd rather say: otherwise forget it (possibly low prio / starter ticket, more realistically reject). This is not a sponsor deliverable. And I doubt Alan will want to touch Perl code.

#14 Updated by intrigeri about 1 year ago

  • Subject changed from Feedback needed when clicking on Persistence wizard - gears button to Feedback needed when clicking on Persistence wizard → configure ASP gear button
  • Assignee deleted (intrigeri)
  • Target version deleted (Tails_3.9)

I think this problem comes from running t-p-s as a dedicated user with sudo. So first of all I wanted to check whether t-p-s itself was able to signal its startup / GNOME Shell was able to notice it: if that does not work, there's little chance that it'll work for another app started from t-p-s. I've added these lines:

StartupNotify=true
StartupWMClass=tails-persistence-setup

… to /usr/share/applications/tails-persistence-setup.desktop and I see a spinner but the mouse cursor is not restored when t-p-s has started (it is restored only after a timeout), which is why — I think — I've set StartupNotify=false in that file in the first place.

I can reproduce this when starting the Unsafe Browser, which is started in a similar manner as t-p-s.

I think this will be fixed for free when we port all our apps run via sudo to run as the amnesia user (with a privileged backend if needed) which we'll need to do for Wayland. So I'll mark this as blocked by the move to Wayland and will put this on the back burner for now.

#15 Updated by intrigeri about 1 year ago

#16 Updated by intrigeri about 1 year ago

  • Blocked by Feature #15142: Make tails-persistence-setup compatible with Wayland added

#17 Updated by intrigeri about 1 year ago

  • Blocked by deleted (Feature #12213: Wayland in Tails 5.0 (Bullseye))

#18 Updated by intrigeri about 1 year ago

  • Parent task deleted (#15567)

#19 Updated by intrigeri about 1 year ago

  • Related to Feature #15827: Give feedback while the persistence setup is starting added

#20 Updated by u 7 months ago

  • Status changed from In Progress to Confirmed

#21 Updated by alant 6 months ago

  • Priority changed from Normal to Low

Do we really want to spend time on this ? It seems to me to have low improvment/time needed.

#22 Updated by intrigeri 6 months ago

  • Blocked by deleted (Feature #15142: Make tails-persistence-setup compatible with Wayland)

#23 Updated by intrigeri 6 months ago

  • Status changed from Confirmed to Rejected

Also available in: Atom PDF