Project

General

Profile

Feature #15543

Give a list of examples of nice software to install each time

Added by emmapeel over 1 year ago. Updated 8 months ago.

Status:
Confirmed
Priority:
Normal
Assignee:
-
Category:
-
Target version:
-
Start date:
04/17/2018
Due date:
% Done:

0%

Feature Branch:
Type of work:
End-user documentation
Blueprint:
Starter:
Affected tool:
Additional Software Packages

Description

Now that more users can install additional software, it would be nice to mention software that maybe because of space cannot be shipped in tails.

- Pitivi
- Dictionaries for different languages


Related issues

Related to Tails - Feature #11551: Install the mumble VoIP client Confirmed 06/29/2016
Related to Tails - Feature #9021: Consider including more dictionaries Rejected 03/06/2015
Related to Tails - Feature #8253: Consider shipping a tool to easily edit a batch of pictures Rejected 11/12/2014
Related to Tails - Feature #15807: Define & apply clear criteria for including dictionaries, fonts and language packs Resolved 08/18/2018
Related to Tails - Feature #5626: Include audio and video streaming software Confirmed
Related to Tails - Bug #16611: Propose users to add relevant internationalization Debian packages Confirmed

History

#1 Updated by emmapeel over 1 year ago

  • Target version set to Tails_3.7

#2 Updated by emmapeel over 1 year ago

  • Description updated (diff)

#3 Updated by emmapeel over 1 year ago

Suggested by huertanix:

maim/stable 3.3.41-1+b1 amd64
takes screenshts of your desktop

keepassxc/unstable 2.3.1+dfsg.1-1 amd64 / not sure as this one replaces a tool we already ship, etc...

gajim/stable 0.16.6-1.1 all
GTK+-based Jabber client

cheese/stable 3.22.1-1+b1 amd64

libtesseract3/stable 3.04.01-5 amd64
Tesseract OCR library with language files

ffmpeg for video edition and transcoding

youtube-dl: usually the version available from the repos is a bit old to work, as they need to change the parser all the time

tool to take pictures and videos from your webcam

#4 Updated by bertagaz over 1 year ago

  • Target version changed from Tails_3.7 to Tails_3.8

#5 Updated by sajolida over 1 year ago

If that's the best list of software that we could come up with, then I'm not sure it's worth documenting...

  • ffmpeg and youtube-dl: these command line tools. I'd like easier tools to use in this list.
  • maim: it's already possible to take screenshots with 2 different tools in Tails: GNOME Screenshot and GIMP.
  • keepassxc: We already have KeePassX and should work to migrating to that instead.
  • gajim: I'm not sure it's worth documenting another XMPP client. Users of XMPP are probably advanced enough to know for themselves which client they can use.
  • libtesseract3: Does this have an GUI?

Emma: What do you think?

#6 Updated by intrigeri over 1 year ago

If that's the best list of software that we could come up with, then I'm not sure it's worth documenting...

IIRC we've provided examples in our grant proposal: there's a reason why we're doing all this work on ASP, right? :)

This put aside: IM clients, video/audio editing software, full-text search software (see the discussion about tracker) may be good candidates.

Also, we often reject requests to add software using the ASP catch-all argument, so searching Redmine for "Additional Software Packages" might yield a few interesting results (and lots of noise).

#7 Updated by blue9 over 1 year ago

When providing examples, it seems like it might be a good idea to stick with software that works "as expected" without additional customization of dotfiles or persistence.conf. Here are a few tools that seem to work well for me:

1. pandoc - For document conversion
2. hunspell-en-gb (depends on hunspell) - LibreOffice spelling dictionary for British English
3. xournal - For annotating PDFs
4. git-remote-gcrypt - For collaborative, GPG encrypted git
5. gimp-ufraw - For importing raw digital photographs into Gimp
6. xinput - For a script to disable my trackpad
7. keepassxc - Depending on how soon you plan to migrate from keepassx...

The following work reasonably well but are likely impractical for various reasons:

- Atom (text editor and its apm package manager) works fine but the .deb is not in Debian
- Emacs (text editor) might be frustrating for most users without adding .emacs to dotfiles
- Darktable (for managing and touching up raw digital photographs) depends on `dotfiles` even for basic use

#8 Updated by intrigeri over 1 year ago

  • Target version changed from Tails_3.8 to Tails_3.9

#9 Updated by sajolida over 1 year ago

  • Priority changed from Normal to Elevated

#10 Updated by u over 1 year ago

intrigeri wrote:

If that's the best list of software that we could come up with, then I'm not sure it's worth documenting...

IIRC we've provided examples in our grant proposal: there's a reason why we're doing all this work on ASP, right? :)

There don't seems to be specific software listed in the proposal. Can you point me to the correct paragraph?

This put aside: IM clients, video/audio editing software, full-text search software (see the discussion about tracker) may be good candidates.

Ack.

Also, we often reject requests to add software using the ASP catch-all argument, so searching Redmine for "Additional Software Packages" might yield a few interesting results (and lots of noise).

Ack.

#11 Updated by intrigeri over 1 year ago

IIRC we've provided examples in our grant proposal: there's a reason why we're doing all this work on ASP, right? :)

There don't seems to be specific software listed in the proposal. Can you point me to the correct paragraph?

I wrote "IIRC" and apparently you've checked the actual proposal and noticed I remembered wrongly. I trust you and won't double-check :)
Sorry for the false lead.

#12 Updated by u over 1 year ago

So here is a very small list based on things we've talked about in the past, I would suggest to start with this and then we can improve from there.

- mumble (audio conferencing)
- darktable (professional image editing)
- tracker (full-text search)

#13 Updated by u over 1 year ago

Let's please not add CLI applications to that list.

#14 Updated by emmapeel over 1 year ago

More options:

- I would add libreoffice-l10n-es for example if I were a Spanish speaking journalist.
- Investigative journalists sometimes install scantailor and tesseract. Tesseract, an ocr library, also has huge language files for OCR recognition.

#15 Updated by sajolida over 1 year ago

  • Status changed from Confirmed to Rejected
  • Assignee deleted (emmapeel)
  • QA Check deleted (Dev Needed)

This was not done in time for the freeze and I think we can skip it.

#16 Updated by u over 1 year ago

  • Subject changed from Give examples of nice software to install each time to Give a list of examples of nice software to install each time

#17 Updated by u over 1 year ago

  • Related to Feature #15291: Remove less popular packages that users could install themselves added

#18 Updated by u over 1 year ago

  • Status changed from Rejected to Confirmed
  • Priority changed from Elevated to Normal
  • Target version changed from Tails_3.9 to Tails_3.10.1

As said on #15291 I believe it is important to have such a list in the documentation. It's not urgent though and I'm open to debate.

#19 Updated by u over 1 year ago

  • Assignee set to sajolida

#20 Updated by sajolida over 1 year ago

  • Assignee changed from sajolida to u
  • QA Check set to Info Needed

I agree it will become important as we remove more stuff from Tails.

But given that the freeze for 3.9 is now over and that I'm overclocked by +42% on my mentoring job on this, do you think that we should still do this as part of SponsorW_2017?

I added this tag myself 2 days ago but I think it's a mistake :)

If we don't do that as part of SponsorW_2017, we could maybe reparent this to #15291.

It's also not super clear to me how we should do this. I mean, if we merely dump a list of packages in /doc/first_steps/additional_packages I'm not sure it's where people will be looking for it.

Instead of, let's say /doc/sensitive_documents/graphics/ for packages of graphics software or integrate this somehow in /doc/about/features.

This might need a bit more thought...

#21 Updated by u over 1 year ago

  • Assignee changed from u to sajolida
  • Parent task changed from #14589 to #15291
  • QA Check deleted (Info Needed)

But given that the freeze for 3.9 is now over and that I'm overclocked by +42% on my mentoring job on this, do you think that we should still do this as part of SponsorW_2017?
I added this tag myself 2 days ago but I think it's a mistake :)

Ack :)

If we don't do that as part of SponsorW_2017, we could maybe reparent this to #15291.

Good idea.

It's also not super clear to me how we should do this. I mean, if we merely dump a list of packages in /doc/first_steps/additional_packages I'm not sure it's where people will be looking for it.

Instead of, let's say /doc/sensitive_documents/graphics/ for packages of graphics software or integrate this somehow in /doc/about/features.

This might need a bit more thought...

Indeed.

I also thought about displaying this information to them the first time they use ASP in Tails. But I'm not sure if this is possible.

#22 Updated by u over 1 year ago

#23 Updated by u over 1 year ago

  • Related to Feature #9021: Consider including more dictionaries added

#24 Updated by u over 1 year ago

  • Related to Feature #8253: Consider shipping a tool to easily edit a batch of pictures added

#25 Updated by intrigeri over 1 year ago

  • Related to Feature #15807: Define & apply clear criteria for including dictionaries, fonts and language packs added

#26 Updated by u over 1 year ago

  • Related to Feature #5626: Include audio and video streaming software added

#27 Updated by sajolida over 1 year ago

  • Assignee deleted (sajolida)
  • Target version deleted (Tails_3.10.1)

#28 Updated by intrigeri 8 months ago

  • Related to Bug #16611: Propose users to add relevant internationalization Debian packages added

#29 Updated by intrigeri 8 months ago

  • Parent task deleted (#15291)

I don't think #15291 should be blocked by this ticket.

Also available in: Atom PDF