Project

General

Profile

Bug #15533

Clarify the status of Tails Installer for Jessie

Added by intrigeri over 1 year ago. Updated about 1 year ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Installation
Target version:
Start date:
04/14/2018
Due date:
% Done:

100%

Feature Branch:
feature/15533-tails-installer-not-in-jessie
Type of work:
End-user documentation
Blueprint:
Starter:
Affected tool:
Installation Assistant

Description

Our end-user doc says we support Tails Installer on Jessie but we're shipping a very old version in jessie-backports (which won't change as one cannot upload to jessie-backports a package that's not in Stretch) and none in jessie-backports-sloppy. Our installation assistant was updated for Tails Installer 5.x already (#14677) so currently, even if 4.4.6+dfsg-1~bpo8+1 still works, it does not match our doc.

I think we should either stop supporting Jessie that is:

… or make it so Jessie users can install Tails Installer 5.x (probably via jessie-backports-sloppy).

Almost a year after the Stretch release, I recommend the former approach.


Related issues

Related to Tails - Bug #14650: Package new upstream version of tails-installer -> bpo Resolved 09/13/2017
Related to Tails - Feature #14677: Update doc to new Tails Installer without splash screen (in Debian) Resolved 09/17/2017
Related to Tails - Bug #12152: Update tails-installer release process Resolved 01/17/2017
Blocks Tails - Bug #14646: Core work 2018Q1 → 2018Q2: Debian Resolved 01/17/2018
Blocks Tails - Feature #15411: Core work 2018Q2 → 2018Q3: Technical writing Resolved 03/14/2018
Blocks Tails - Feature #15392: Core work 2018Q2 → 2018Q3: User experience Resolved 03/09/2018

Associated revisions

Revision 192e6090 (diff)
Added by sajolida over 1 year ago

Don't instruct Tails Installer for Jessie anymore (Will-fix: #15533)

History

#1 Updated by intrigeri over 1 year ago

  • Blocks Bug #14646: Core work 2018Q1 → 2018Q2: Debian added

#2 Updated by intrigeri over 1 year ago

  • Related to Bug #14650: Package new upstream version of tails-installer -> bpo added

#3 Updated by intrigeri over 1 year ago

  • Related to Feature #14677: Update doc to new Tails Installer without splash screen (in Debian) added

#4 Updated by intrigeri over 1 year ago

  • Blocks Feature #15411: Core work 2018Q2 → 2018Q3: Technical writing added

#5 Updated by intrigeri over 1 year ago

sajolida and u, I guess you should talk to each other, decide something and then each implement your part of the decision :)

#6 Updated by intrigeri over 1 year ago

  • Related to Bug #12152: Update tails-installer release process added

#7 Updated by sajolida over 1 year ago

  • Blocks Feature #15392: Core work 2018Q2 → 2018Q3: User experience added

#8 Updated by u over 1 year ago

I think we should indeed stop supporting Jessie that is:

#9 Updated by sajolida over 1 year ago

  • Assignee changed from sajolida to u
  • QA Check set to Ready for QA
  • Feature Branch set to feature/15533-tails-installer-not-in-jessie

I have a branch for the documentation.

Reassigning to Ulrike for the Debian part.

update https://tails.boum.org/contribute/release_process/tails-installer/ accordingly [sajolida]

I prefer leaving that to Ulrike!

#10 Updated by sajolida over 1 year ago

  • Status changed from Confirmed to In Progress

#11 Updated by u about 1 year ago

sajolida wrote:

I have a branch for the documentation.

The branch looks good. I've merged recent master into it and pushed.

#12 Updated by u about 1 year ago

sajolida wrote:

update https://tails.boum.org/contribute/release_process/tails-installer/ accordingly [sajolida]

I prefer leaving that to Ulrike!

Right, I don't know why I thought you should do that, that was a mistake..
Done in 7bc09dd14d in "your" branch.

#13 Updated by u about 1 year ago

Requested removal of the package from jessie-backports by following the procedure on https://wiki.debian.org/ftpmaster_Removals#Removals_from_backports

#14 Updated by u about 1 year ago

As soon as I receive news about the removal, we can merge this.

#15 Updated by u about 1 year ago

No news yet.

#16 Updated by intrigeri about 1 year ago

I think we should merge this branch right now (I see no reason to wait for the removal from jessie-backports). I've had a look and it seems good to me!

#17 Updated by u about 1 year ago

Agreed, this was maybe not necessary to wait. Nevertheless, the package has been removed today and I finally found out why I was not able to upload to backports - there was a permission problem I was not aware of. I am not able to upload there - and have uploaded 5.0.6 to stretch-backports - because this version is already in Debian testing. I will upload 5.0.7 at a later point in time.

#18 Updated by u about 1 year ago

Merging the documentation branch into master and pushing.

#19 Updated by u about 1 year ago

tails-installer is now in stretch-backports :)

#20 Updated by u about 1 year ago

  • Status changed from In Progress to Resolved
  • QA Check deleted (Ready for QA)

#21 Updated by intrigeri about 1 year ago

  • % Done changed from 0 to 100

Woohoo!

Also available in: Atom PDF