Project

General

Profile

Feature #15527

Feature #14568: Additional Software Packages

Feature #14594: Code & integration into Tails: Additional Software Packages GUI

Adjust the UI strings of Additional Software to the ones designed in the wireframes

Added by sajolida about 1 year ago. Updated 10 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
-
Target version:
Start date:
04/12/2018
Due date:
% Done:

80%

QA Check:
Feature Branch:
bugfix/15527-additional-software-strings
Type of work:
User interface design
Blueprint:
Starter:
Affected tool:
Additional Software Packages

Description

I see many unconsistencies (and typos) between the wireframes that we agreed upon with Alan during the UX sprint and the actual code.

Associated revisions

Revision 20e3b46f (diff)
Added by alant about 1 year ago

ASP: use specific error notification when the check for upgrade fails

Since the strings review, the error notification on "apt update" failure was
the same than when "apt upgrade" fails. This commit changes the title.

Refs: #15527

History

#1 Updated by sajolida about 1 year ago

  • Description updated (diff)

#2 Updated by sajolida about 1 year ago

  • Assignee changed from sajolida to alant
  • QA Check set to Ready for QA
  • Feature Branch set to bugfix/15527-additional-software-strings

Alan, please have a look at my branch.

I did a few more commits on top of adjusting the strings to the wireframe, but I took care of splitting them in atomic commits to make your review easier.

#3 Updated by sajolida about 1 year ago

  • Subject changed from Correct the displayed message of Additional Software as designed in the wireframes to Adjust the UI strings of Additional Software to the ones designed in the wireframes

#4 Updated by alant about 1 year ago

  • Assignee changed from alant to sajolida
  • % Done changed from 0 to 50
  • QA Check changed from Ready for QA to Info Needed

Thanks for the review. I merged the branch.

However, since the strings review, the error notification on "apt update" failure was
the same than when "apt upgrade" fails. I think it's worth making a diffrence in the error message.
When APT update fails, I propose "The check for upgrades of your additional software failed" instead of "The upgrade of your additional software failed".

#5 Updated by alant about 1 year ago

  • Status changed from Confirmed to In Progress

#6 Updated by sajolida about 1 year ago

  • Assignee changed from sajolida to alant
  • QA Check changed from Info Needed to Dev Needed

I saw that and wondered why we had two different messages :) Now I understand that the difference is "update" vs "upgrade". But I'm fine with your string :)

#7 Updated by alant about 1 year ago

  • Status changed from In Progress to Resolved
  • Assignee deleted (alant)

#8 Updated by alant about 1 year ago

  • % Done changed from 50 to 100

#9 Updated by sajolida 11 months ago

  • Status changed from Resolved to In Progress
  • Assignee set to alant
  • Target version changed from Tails_3.7 to Tails_3.9
  • QA Check changed from Dev Needed to Ready for QA

I pushed more fixes to this branch since Alan did the first merge. Please have a look again.

git log -p origin/feature/14594-asp-gui..origin/bugfix/15527-additional-software-strings

#11 Updated by alant 11 months ago

  • Assignee changed from alant to sajolida
  • % Done changed from 100 to 80
  • QA Check changed from Ready for QA to Info Needed

There is lots of merge conflicts when trying to merge this branch, but going through them I don't see the string changes that are still missing, so I'm afraid that merging it again may break things without benefit. Could you please point me to the commits that are not yet merged?

#12 Updated by alant 11 months ago

The last commit I have is c3be53d, which is merged.

#13 Updated by sajolida 10 months ago

  • Status changed from In Progress to Resolved
  • QA Check deleted (Info Needed)

Ok. I'm not sure what happened but I merged again my branch into doc/14589-additional-software just in case.

Also available in: Atom PDF