Project

General

Profile

Feature #15516

Add MAT as an option for opening files with context menu

Added by huertanix about 1 year ago. Updated 9 months ago.

Status:
Confirmed
Priority:
Normal
Assignee:
Category:
-
Target version:
-
Start date:
04/09/2018
Due date:
% Done:

0%

QA Check:
Feature Branch:
Type of work:
Code
Blueprint:
Starter:
Affected tool:

Description

During a training on how to look at / clean up image metadata, a participant tried to open an image using MAT by right-clicking on the file and looking for MAT under "Open with" but only found GIMP available. It would be great if users could open files in MAT (or whatever replaces it) via the GNOME context menu.

History

#1 Updated by intrigeri about 1 year ago

Hint for help desk when triaging this: there's supposed to be a context menu item to clean a file with MAT (without opening it in there).

#2 Updated by huertanix about 1 year ago

Thanks for the protip. In this case though, the participant wanted to look at the image's metadata before wiping it.

#3 Updated by goupille about 1 year ago

  • Status changed from New to Rejected

I'm rejecting this ticket, since there is a "Clean metadata" item in the context menu.
Regarding huertanix remark, I may be wrong, but I think Gnome Image Viewer shows most of the metadata of a file in "properties".

#4 Updated by huertanix about 1 year ago

goupille wrote:

I'm rejecting this ticket, since there is a "Clean metadata" item in the context menu.
Regarding huertanix remark, I may be wrong, but I think Gnome Image Viewer shows most of the metadata of a file in "properties".

The Gnome/Nautilus tools unfortunately do not display the serial number for the camera a photo was taken with. This is a critical bit of metadata, not only for its removal to protect sources but for the investigative work journalists do to figure out where an image came from. It would be great if a journalist could see it without digging out some command line tool that a journalist will not be sufficiently trained to know how to use.

#5 Updated by sajolida about 1 year ago

  • Status changed from Rejected to Confirmed
  • Assignee set to jvoisin
  • QA Check set to Info Needed

I fully agree with huertanix.

It's not because there is already a shortcut to MAT from Nautilus that there's shouldn't be another one. Especially since "Open with..." is already there and adding MAT to the list would only be useful to people who already chose this option. These people chose it either because:

  • They missed the "Clean metadata" item in the context menu. If it's cheap to be helpful to them anyway, why not do it and punish them for not finding the right menu entry? Note that we wouldn't really be polluting the interface if we did that.
  • They need (or prefer) to open the MAT GUI and huertanix gave a good rational for that.

The next questions are:

  • How hard would it be to have MAT appears in "Open with..." for images?
  • Is this something that's worth doing in MAT v1 upstream (who's not actively developed anymore) or is it something that's reasonable to code in Tails itself?

Assigning to jvoisin to get his opinion.

#6 Updated by jvoisin about 1 year ago

Iirc, the arguments are passed to the invoked program upon "right-clic + send to", so there is nothing to modify on MAT's side. To add MAT to the "send to" menu, this shouldn't be hard, but I know nothing about Nautilus :/

#7 Updated by sajolida about 1 year ago

  • Assignee deleted (jvoisin)
  • QA Check deleted (Info Needed)

Thanks jvoisin!

Next step: Research how to add MAT to the list of "Open With Other Application". But I don't dare assigning this to anybody anymore.

#8 Updated by u 9 months ago

  • Assignee set to intrigeri

Anybody up for working on this? Could FT look into it eventually? Assigning tentatively.

#9 Updated by intrigeri 9 months ago

  • Assignee changed from intrigeri to jvoisin

Anybody up for working on this? Could FT look into it eventually? Assigning tentatively.

This should be fixed upstream in MAT (2.x) itself and FYI it has nothing to do with the FT.

jvoisin, please ensure this is tracked in the upstream issue tracker. To add a file association I believe dropping a file into /usr/share/mime/packages/ is enough and you probably have quite a few examples on your system :)

#10 Updated by jvoisin 9 months ago

It's already done in MAT2 via a Nautilus extension
Now we only need to get MAT2 into Debian ;)

Also available in: Atom PDF