Project

General

Profile

Bug #15514

Bug #10288: Fix newly identified issues to make our test suite more robust and faster

The "The Tails documentation launcher on the desktop works…" scenarios are fragile

Added by intrigeri over 1 year ago. Updated 20 days ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
Test suite
Target version:
-
Start date:
04/09/2018
Due date:
% Done:

100%

Feature Branch:
Type of work:
Code
Blueprint:
Starter:
Affected tool:

Description

It breaks very often on Jenkins:

The Dogtail script raised: SearchError: child of [desktop frame | main]: "tails-documentation" application (RuntimeError)
./features/support/helpers/dogtail.rb:81:in `run'
./features/support/helpers/dogtail.rb:70:in `initialize'
./features/step_definitions/checks.rb:113:in `/^the documentation viewer opens the "(Support|Getting started)" page$/'
features/documentation.feature:7:in `Then the documentation viewer opens the "Getting started" page'

The screenshot shows that the doc desktop icon is selected but the documentation viewer is nowhere to be seen.


Related issues

Related to Tails - Bug #15321: "The Report an Error launcher will…" test suite step is fragile Resolved 02/17/2018
Related to Tails - Feature #11717: Drop launchers from the Desktop Rejected 08/25/2016
Related to Tails - Bug #16283: No more icons on desktop in buster Resolved 01/05/2019

Associated revisions

Revision dbda5cb5 (diff)
Added by intrigeri over 1 year ago

Mark test as fragile (refs: #15514)

Revision d3968cb3 (diff)
Added by intrigeri over 1 year ago

Mark test as fragile (refs: #15514)

Revision 8c193b10 (diff)
Added by intrigeri 20 days ago

Test suite: remove fragile tags that were due to #15514.

I can't recall seeing the lost double-click problem on Buster, so I'm going to
assume that this was a problem only caused by managing the desktop icons with
Nautilus in Stretch and older.

Closes: #15514

History

#1 Updated by intrigeri over 1 year ago

  • Description updated (diff)

#2 Updated by intrigeri over 1 year ago

  • Status changed from Confirmed to In Progress

#3 Updated by intrigeri over 1 year ago

  • Status changed from In Progress to Confirmed

Marked as fragile so the notifications we get on tails-rm@ are more useful :)

#4 Updated by intrigeri over 1 year ago

  • Related to Bug #15321: "The Report an Error launcher will…" test suite step is fragile added

#5 Updated by intrigeri over 1 year ago

  • Subject changed from The "The Tails documentation launcher on the desktop works when offline" scenario is fragile to The "The Tails documentation launcher on the desktop works…" scenarios are fragile

Actually the "when online" flavour often fails as well. Looks like everything that's about double-clicking icons on the desktop is affected: #15321.

#6 Updated by intrigeri over 1 year ago

  • Status changed from Confirmed to In Progress

#7 Updated by intrigeri over 1 year ago

  • Status changed from In Progress to Confirmed

#8 Updated by intrigeri over 1 year ago

#9 Updated by intrigeri 9 months ago

  • Related to Bug #16283: No more icons on desktop in buster added

#10 Updated by intrigeri 20 days ago

  • Status changed from Confirmed to Resolved
  • % Done changed from 0 to 100

Also available in: Atom PDF