Project

General

Profile

Feature #15486

Ask users to send smaller images to frontdesk

Added by emmapeel about 1 year ago. Updated 11 months ago.

Status:
Rejected
Priority:
Normal
Assignee:
Category:
-
Target version:
Start date:
04/02/2018
Due date:
% Done:

0%

QA Check:
Pass
Feature Branch:
Type of work:
End-user documentation
Blueprint:
Starter:
Affected tool:

Description

Users are sending us 4 or 5 Mb screenshots when mailing support.

It takes ages to load them and decrypt them, Enigmail crashes, etc.

Can we ask them to resize them?

Assigning to sajolida to see if it is pertinent.


Related issues

Related to Tails - Bug #15602: Fix EFAIL Resolved 05/14/2018
Related to Tails - Feature #8660: Add an option to attach screenshots to WhisperBack reports In Progress

History

#1 Updated by goupille about 1 year ago

I also hate those big attachments (and the enigmail nightmare that goes with them), but maybe pointing them to a host like https://share.riseup.net would be more effective than ask the users to learn how to resize pictures.

#2 Updated by intrigeri about 1 year ago

I also hate those big attachments (and the enigmail nightmare that goes with them),

Is there an upstream bug report for this Enigmail problem?

but maybe pointing them to a host like https://share.riseup.net would be more effective than ask the users to learn how to resize pictures.

Agreed.

#3 Updated by emmapeel about 1 year ago

goupille wrote:

I also hate those big attachments (and the enigmail nightmare that goes with them), but maybe pointing them to a host like https://share.riseup.net would be more effective than ask the users to learn how to resize pictures.

Yes, I like the idea. We should suggest them to pass the images through MAT before uploading though.

#4 Updated by goupille about 1 year ago

intrigeri wrote:

I also hate those big attachments (and the enigmail nightmare that goes with them),

Is there an upstream bug report for this Enigmail problem?

I'd say it was https://sourceforge.net/p/enigmail/bugs/738/ or 714. both are fixed in 2.0 anyway.

#5 Updated by sajolida about 1 year ago

  • Status changed from New to Confirmed
  • Assignee deleted (sajolida)
  • QA Check deleted (Dev Needed)

That would be something to add to /support/talk.

Unfortunately, I don't think we can rely on people knowing how to resize an image and I don't want them to have to learn that before writing us. So yes, I would prefer asking them to upload them somewhere but uploads on https://share.riseup.net expire after one week.

I don't think we should ask them to use MAT because it's one more hoop to jump through:

  • If they know MAT already, they could think about that themselves.
  • If they don't know MAT, I don't want them to have to learn about metadata and MAT before writing us.

Let's try to add a note to instruct people to upload images to share.riseup.net and see if the expiration after one week works for you.

#6 Updated by intrigeri 11 months ago

#7 Updated by intrigeri 11 months ago

  • Assignee set to emmapeel
  • Target version set to Tails_3.9
  • QA Check set to Info Needed

goupille wrote:

intrigeri wrote:

Is there an upstream bug report for this Enigmail problem?

I'd say it was https://sourceforge.net/p/enigmail/bugs/738/ or 714. both are fixed in 2.0 anyway.

Once #15602 gives us Enigmail 2.x and Tails 3.8 is out, please test again and tell me if the problem is still here.

#8 Updated by emmapeel 11 months ago

Schleuder also can be configured to have a maximum size for attachments:

https://0xacab.org/schleuder/schleuder/blob/master/etc/list-defaults.yml#L106

#9 Updated by sajolida 11 months ago

https://0xacab.org/schleuder/schleuder/blob/master/etc/list-defaults.yml#L106

Uhh! That's super interesting!

I would also check how understandable is the error message people get
when they send something bigger than allowed.

#10 Updated by intrigeri 11 months ago

  • Assignee changed from emmapeel to goupille

intrigeri wrote:

goupille wrote:

intrigeri wrote:

Is there an upstream bug report for this Enigmail problem?

I'd say it was https://sourceforge.net/p/enigmail/bugs/738/ or 714. both are fixed in 2.0 anyway.

Once #15602 gives us Enigmail 2.x and Tails 3.8 is out, please test again and tell me if the problem is still here.

There you go :)

#11 Updated by goupille 11 months ago

  • Assignee changed from goupille to intrigeri

well, opening emails with big attachements seems to work a lot faster than before. I don't think the issue i still there...

#12 Updated by emmapeel 11 months ago

Yeah it opens/saves the attachments quicker, and you can see big images quicker with 3.8

#13 Updated by intrigeri 11 months ago

  • Assignee changed from intrigeri to emmapeel

I don't understand why this ticket was reassigned to me. My understanding is that:

  1. you folks report this ticket to propose a workaround for an Enigmail bug
  2. I ensure the Enigmail bug is fixed in Tails 3.8
  3. you confirm the original problem is fixed

So, what is left to do here? Is there still a problem to solve? If yes, what is it?

#14 Updated by emmapeel 11 months ago

  • Status changed from Confirmed to Rejected
  • QA Check changed from Info Needed to Pass

I agree, thus I close.

(I close as 'rejected' because we have decided not to ask users for smaller images, although it feels not right because we worked a bit on this ticket)

#15 Updated by sajolida 10 months ago

  • Related to Feature #8660: Add an option to attach screenshots to WhisperBack reports added

Also available in: Atom PDF