Project

General

Profile

Bug #15476

news/report_2018_01 contains images hosted in github

Added by geb almost 2 years ago. Updated over 1 year ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
-
Target version:
Start date:
03/29/2018
Due date:
% Done:

0%

Feature Branch:
Type of work:
Sysadmin
Blueprint:
Starter:
Affected tool:

Description

One user on xmmp was reporting that news/report_2018_01 (actually displayed in the frontpage) contains image hosted on github.

Maybe would it be possible to host them on boum.org ?

Feel free to reject if not relevant.


Related issues

Blocks Tails - Feature #15392: Core work 2018Q2 → 2018Q3: User experience Resolved 03/09/2018

Associated revisions

Revision 8697f38a (diff)
Added by sajolida over 1 year ago

Replace github.com by git.tails.boum.org (Closes: #15476)

History

#1 Updated by geb almost 2 years ago

Adding a bit of informations on request :

On a first hand, it may be seen a bit problematic for some people to load content from remote server(s) when browsing the Tails website. It would in fact inform the remote server(s) that a given user (IP address, browser fingerprint...) is browsing the Tails website, which page, etc with the HTTP referrer field.

While i tend to agree on this, the Tails spec make it clear that Tails do not try to strongly hide that somebody is using Tails, nor to hide that somebody is visiting the Tails Website if done using a classical Web Browser instead of Tor. However if possible, it may be relevant to try to not export this information to other third party(ies) than the Networks involved when a user visit the Tails Website.

On a another hand, I understand that it may be not practical and counterproductive for those using remote Git repository(ies) to work, to copy every images they want to put in news in the Tails website. It would increase the amount of work needed, not only by the new writer itself but for the infrastructure and the ones who maintain it.

While I don't have any strong opinion about it, and don't want to add more work to other people, I tend to think that it would be relevant to try to reduce the hosting of content in third party servers when it is possible.

#2 Updated by emmapeel almost 2 years ago

  • Blocks Feature #15411: Core work 2018Q2 → 2018Q3: Technical writing added

#3 Updated by sajolida almost 2 years ago

  • Blocks deleted (Feature #15411: Core work 2018Q2 → 2018Q3: Technical writing)

#4 Updated by sajolida almost 2 years ago

I created this GitHub account for myself because:

  • I need version control and HTTP publication of my UX work (images and other big files).
  • Git repositories on git.tails.boum.org can't be browsed using HTTP.
  • /blueprint can't be used to store big files.

I'm happy to use something else as our sysadmin see fit but I'm not ready to make my work more painful than pushing stuff to Git (eg. I won't use Redmine for that).

NB: That's not Technical writing.

#5 Updated by intrigeri almost 2 years ago

  • Git repositories on git.tails.boum.org can't be browsed using HTTP.

I believe the problem we've had about this in the last couple years was fixed in December.

#6 Updated by goupille almost 2 years ago

  • Status changed from New to Confirmed
  • Assignee set to sajolida

I changed the status to confirmed and reassigned to sajolida since one of his concern was answered by intrigeri.

#7 Updated by sajolida almost 2 years ago

  • Target version set to Tails_3.8
  • Type of work changed from Website to Sysadmin

Cool! I'll migrate to git.tails.boum.org then.

#8 Updated by sajolida almost 2 years ago

  • Assignee changed from sajolida to groente

groente: Could you please create a Git repo called 'ux' on git.tails.boum.org and give me push rights?

#9 Updated by groente over 1 year ago

  • Assignee changed from groente to sajolida

done, can you check if it works?

#10 Updated by sajolida over 1 year ago

  • Blocks Feature #15392: Core work 2018Q2 → 2018Q3: User experience added

#11 Updated by sajolida over 1 year ago

  • Status changed from Confirmed to Resolved
  • Assignee deleted (sajolida)

It works, thanks!

So I replaced all the links to GitHub to links to git.tails.boum.org in 8697f38a4d.

#12 Updated by intrigeri over 1 year ago

So I replaced all the links to GitHub to links to git.tails.boum.org in 8697f38a4d.

Excellent!

Also available in: Atom PDF