Project

General

Profile

Bug #15456

Upgrade Linux to 4.15.0-2

Added by intrigeri almost 2 years ago. Updated almost 2 years ago.

Status:
Resolved
Priority:
High
Assignee:
-
Category:
-
Target version:
Start date:
03/27/2018
Due date:
% Done:

100%

Feature Branch:
Type of work:
Code
Blueprint:
Starter:
Affected tool:

Description

Our devel branch FTBFS since Linux 4.15.0-1 was removed from sid. Let's fix this on devel first and this will give us data points wrt. #15435.


Related issues

Blocks Tails - Feature #13245: Core work 2018Q1: Foundations Team Resolved 06/29/2017
Blocked by Tails - Bug #15457: Upgrade Linux in Tails 3.6.2 Resolved 03/22/2018

Associated revisions

Revision 453ccf71 (diff)
Added by intrigeri almost 2 years ago

Upgrade Linux to 4.15.0-2 (refs: #15456)

… currently at version 4.15.11-1.

Revision c8ad11b7 (diff)
Added by intrigeri almost 2 years ago

Upgrade Linux to 4.15.0-2 (refs: #15456)

… currently at version 4.15.11-1.

History

#1 Updated by intrigeri almost 2 years ago

  • Subject changed from Upgrade to Linux 4.15.0-2 to Upgrade Linux to 4.15.0-2
  • % Done changed from 0 to 10
  • Feature Branch set to bugfix/15456-Linux-4.15.0-2

#2 Updated by intrigeri almost 2 years ago

  • Blocks Bug #15435: Consider upgrading Linux in Tails 3.7 added

#3 Updated by intrigeri almost 2 years ago

#4 Updated by intrigeri almost 2 years ago

  • Blocks Bug #15457: Upgrade Linux in Tails 3.6.2 added

#5 Updated by intrigeri almost 2 years ago

  • % Done changed from 10 to 50

Full test suite locally passes except:

  • "Scenario: Upgrading Tails with Tails Upgrader through an incremental upgrade": passed on Jenkins
  • "Scenario: Additional software packages are installed even without network": never seen it pass locally, passed on Jenkins

#6 Updated by intrigeri almost 2 years ago

  • Blocks deleted (Bug #15457: Upgrade Linux in Tails 3.6.2)

#7 Updated by intrigeri almost 2 years ago

  • Blocked by Bug #15457: Upgrade Linux in Tails 3.6.2 added

#8 Updated by intrigeri almost 2 years ago

  • Assignee changed from intrigeri to anonym
  • QA Check set to Ready for QA
  • Feature Branch deleted (bugfix/15456-Linux-4.15.0-2)

#9 Updated by bertagaz almost 2 years ago

intrigeri wrote:

  • "Scenario: Additional software packages are installed even without network": never seen it pass locally, passed on Jenkins

Never seen a bug report either. It works locally here and in Jenkins, and the only failures I've seen were Tor bootstrap problems. If there's somethin' else, I'd have been curious, but #14596 rewrites this scenario anyway.

#10 Updated by intrigeri almost 2 years ago

Never seen a bug report either.

Yeah, sorry about this, I can only blame myself: I want to first investigate it a bit on my side because it seems I am the only one experiencing this problem, and reporting a bug you cannot reproduce would not be terribly useful (it would land back on my plate as "Info Needed" anyway :)

It works locally here and in Jenkins, and the only failures I've seen were Tor bootstrap problems.
If there's somethin' else, I'd have been curious, but #14596 rewrites this scenario anyway.

IIRC it's not anything else, it's Tor bootstrapping problems. So I'll wait for #14596.

#11 Updated by bertagaz almost 2 years ago

intrigeri wrote:

Never seen a bug report either.

Yeah, sorry about this, I can only blame myself: I want to first investigate it a bit on my side because it seems I am the only one experiencing this problem, and reporting a bug you cannot reproduce would not be terribly useful (it would land back on my plate as "Info Needed" anyway :)

Hint: I see more of this kind of failure with the usual Chutney network used in the test suite. Lately, when setting V3AuthVotingInterval to something like 14400 in submodules/chutney/torrc_templates/authority.i I get close to none of this bootstrap errors. That makes sense: the consensus is not renewed very 10 seconds anymore which gives a much more stable tor network. The Tails VM Tor process gets a valid consensus at the first download attempt and bootstrap very much faster. I wanted to add a note on that on #13541 and/or #15160. It could even help for #15211 a bit (reduce crypto operations).

#12 Updated by anonym almost 2 years ago

  • Status changed from In Progress to 11
  • Assignee deleted (anonym)
  • % Done changed from 50 to 100
  • QA Check changed from Ready for QA to Pass

#13 Updated by intrigeri almost 2 years ago

Hint: I see more of this kind of failure with the usual Chutney network used in the test suite. Lately, when setting V3AuthVotingInterval to something like 14400 in submodules/chutney/torrc_templates/authority.i I get close to none of this bootstrap errors.

Thanks, I've reported this on #13541.

#14 Updated by intrigeri almost 2 years ago

  • Blocks deleted (Bug #15435: Consider upgrading Linux in Tails 3.7)

#15 Updated by intrigeri almost 2 years ago

  • Status changed from 11 to Resolved
  • Target version changed from Tails_3.9 to Tails_3.7

Done in 3.6.2.

Also available in: Atom PDF