Project

General

Profile

Bug #15437

IBus input of Japanese and Korean characters is broken in Tor Browser

Added by emmapeel over 1 year ago. Updated over 1 year ago.

Status:
Resolved
Priority:
Elevated
Assignee:
-
Category:
Internationalization
Target version:
Start date:
03/22/2018
Due date:
% Done:

100%

Feature Branch:
bugfix/15437-IBus-in-Tor-Browser, torbrowser-launcher.git:bugfix/15437-IBus-in-Tor-Browser
Type of work:
Code
Blueprint:
Starter:
Affected tool:
Browser

Description

Reported by several users. Still needs to be tested on Debian:

Since Tails 3.6rc1 users cannot input Japanese text in Tor Browser. It works in other programs in Tails, such as the Text Editor, but it does not work on TBB nor the Unsafe Browser.

To reproduce:

  • Start Tails in Japanese with Japanese keyboard
  • Write things in Text editor and Tor browser.

Corresponding bug reports: 43c31f44a97dda68c59989049f0d9c59, bfee9b4c138c78ae1c809794588f861f


Related issues

Blocks Tails - Feature #13245: Core work 2018Q1: Foundations Team Resolved 06/29/2017

Associated revisions

Revision b1b96041 (diff)
Added by intrigeri over 1 year ago

Tor Browser AppArmor profiles: update our custom patch (refs: #15437).

Taken from 39c51bb95093241c8bc6ed4f6a90af64a592b207 in our
torbrowser-launcher.git.

Changes:

- Grant the main Firefox process access to machine-id: needed for IBus support

Revision eef6a8c7
Added by anonym over 1 year ago

Merge remote-tracking branch 'origin/bugfix/15437-IBus-in-Tor-Browser' into stable

Fix-committed: #15437

History

#1 Updated by intrigeri over 1 year ago

  • Description updated (diff)

#2 Updated by intrigeri over 1 year ago

  • Subject changed from Tor Browser cannot input Japanese or Korean ibus characters to IBus input of Japanese and Korean characters is broken in Tor Browser

#3 Updated by intrigeri over 1 year ago

  • Status changed from New to Confirmed
  • Assignee set to intrigeri
  • Priority changed from Normal to Elevated
  • Target version set to Tails_3.7
  • QA Check deleted (Info Needed)

That's another regression caused by #12679.

#4 Updated by intrigeri over 1 year ago

#5 Updated by intrigeri over 1 year ago

  • Status changed from Confirmed to In Progress
  • % Done changed from 0 to 10
  • Feature Branch set to bugfix/15437-IBus-in-Tor-Browser, torbrowser-launcher.git:bugfix/15437-IBus-in-Tor-Browser

#6 Updated by intrigeri over 1 year ago

  • Assignee changed from intrigeri to anonym
  • % Done changed from 10 to 50
  • QA Check set to Ready for QA

#7 Updated by intrigeri over 1 year ago

  • Target version changed from Tails_3.7 to Tails_3.6.2

#8 Updated by anonym over 1 year ago

  • Status changed from In Progress to Fix committed
  • Assignee deleted (anonym)
  • % Done changed from 50 to 100
  • QA Check changed from Ready for QA to Pass

#9 Updated by anonym over 1 year ago

  • Status changed from Fix committed to Resolved

Also available in: Atom PDF