Project

General

Profile

Bug #15435

Consider upgrading Linux in Tails 3.7

Added by intrigeri almost 2 years ago. Updated over 1 year ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
-
Target version:
Start date:
03/22/2018
Due date:
% Done:

100%

Feature Branch:
Type of work:
Research
Blueprint:
Starter:
Affected tool:

Related issues

Related to Tails - Bug #15457: Upgrade Linux in Tails 3.6.2 Resolved 03/22/2018
Related to Tails - Bug #15554: Upgrade Linux to 4.15.0-3 Resolved 04/26/2018
Related to Tails - Bug #15436: Consider upgrading Linux in Tails 3.8 Resolved 03/22/2018
Blocks Tails - Feature #15139: Core work 2018Q2: Foundations Team Resolved 01/01/2018

History

#1 Updated by intrigeri almost 2 years ago

#2 Updated by intrigeri almost 2 years ago

  • Blocked by Bug #15456: Upgrade Linux to 4.15.0-2 added

#3 Updated by intrigeri almost 2 years ago

  • Related to Bug #15457: Upgrade Linux in Tails 3.6.2 added

#4 Updated by intrigeri almost 2 years ago

  • Blocked by deleted (Bug #15456: Upgrade Linux to 4.15.0-2)

#5 Updated by intrigeri over 1 year ago

  • Related to Bug #15554: Upgrade Linux to 4.15.0-3 added

#6 Updated by intrigeri over 1 year ago

  • Related to Bug #15436: Consider upgrading Linux in Tails 3.8 added

#7 Updated by intrigeri over 1 year ago

  • Status changed from Confirmed to Resolved
  • % Done changed from 0 to 100

linux 4.15.17-1 made it into sid: https://tracker.debian.org/news/950579/accepted-linux-41517-1-all-source-into-unstable-unstable/. It brings lots of bugfixes but security-wise, the only relevant fixes are about the ext4 issues, and even with those it's deemed unsafe to feed the ext4 driver with attacker-controlled filesystems so it's not high priority IMO.

It's likely that 4.16 makes it into sid soon but that's a much more involved upgrade and I won't be able to work on it in time for Tails 3.7 after the end of this week.

So let's skip this one and focus on #15436 instead.

Also available in: Atom PDF