Project

General

Profile

Bug #15433

Cannot open GNOME Settings menu on some computers since Tails 3.6

Added by emmapeel over 1 year ago. Updated over 1 year ago.

Status:
Resolved
Priority:
Elevated
Assignee:
-
Category:
Hardware support
Target version:
Start date:
03/21/2018
Due date:
% Done:

100%

Feature Branch:
bugfix/15433-GNOME-settings-vs-VA-API
Type of work:
Code
Blueprint:
Starter:
Affected tool:

Description

Some users with NVIDIA cards are reporting they are unable to open the Applications - System Tools - Settings menu since Tails 3.6.

I cannot reproduce.

Cards:

  • 01:00.0 VGA compatible controller: NVIDIA Corporation GP104 [GeForce GTX 1080] (rev a1)

Related issues

Related to Tails - Feature #14580: Support Video Acceleration API (VA-API) Confirmed 08/31/2017
Blocks Tails - Feature #13245: Core work 2018Q1: Foundations Team Resolved 06/29/2017
Blocks Tails - Bug #15449: Intel VAAPI: Playing video with Totem freezes the system Resolved 03/22/2018

Associated revisions

Revision 17e45929 (diff)
Added by intrigeri over 1 year ago

Document GNOME Settings bug + workaround (refs: #15433)

Revision 5860b50a (diff)
Added by intrigeri over 1 year ago

Remove packages needed to support Video Acceleration API (VA-API) (refs: #15433)

This reverts commit de15ff9b0de0c9daff11ce4ec3a6712a31ca847e because this breaks
opening GNOME Settings in Tails 3.6 on some computers (only NVIDIA for now but
perhaps other hardware is affected). I'll come back to #14580 during the Tails
4.0~beta time.

Revision 9ca66a43 (diff)
Added by intrigeri over 1 year ago

Revert "Document GNOME Settings bug + workaround (refs: #15433)"

This reverts commit 17e45929e53fc7028869dbccf4adfa23050dcc97.

Revision 9050109a
Added by anonym over 1 year ago

Merge remote-tracking branch 'origin/bugfix/15433-GNOME-settings-vs-VA-API' into stable

Fix-committed: #15433, #15449

History

#1 Updated by intrigeri over 1 year ago

Some users with NVIDIA cards are reporting they are unable to open the Applications - System Tools - Settings menu since Tails 3.6.

Could you please write down in the description of this ticket the corresponding WhisperBack report IDs, so I can take a look at the logs without having to hunt through my copious backlog? Thanks!

#2 Updated by intrigeri over 1 year ago

Here's one: b88235ff80e38c431c8c319d692203ba. I see no obvious attempt to start the Settings menu in this forwarded bug report though. Only potentially relevant error in the logs: gnome-settings-[4958]: failed to set screen _ICC_PROFILE: Failed to open file '/home/amnesia/.local/share/icc/edid-e96d9f46bb7b9c0cced8b4b66692e737.icc': Permission denied

#3 Updated by intrigeri over 1 year ago

Another one: 87d41ce19266d364e7b06397ff4c493c.

To reproduce: open the system menu (top right of the screen), click Settings icon.

Symptoms: "screen goes completely black for 1 second, then comes back blue, with a white toolbar in top of the screen; Mouse is round loading icon; Can click in top right of toolbar. Toolbar then shows volume control and a round ' pause' button (2 stripes). Clicking 'pause' button gives screensaver. Clicking screensaver gets me back to blue screen.; No shutdown button on toolbar."

It looks exactly as if the screen locker had been triggered. I suspect that user clicked the lock screen icon instead of the settings one.

#4 Updated by intrigeri over 1 year ago

  • Subject changed from Cannot open GNOME Settings menu to Cannot open GNOME Settings menu on some computers since Tails 3.6
  • Status changed from New to Confirmed
  • Assignee deleted (emmapeel)

intrigeri wrote:

Another one: 87d41ce19266d364e7b06397ff4c493c.
[…]
It looks exactly as if the screen locker had been triggered. I suspect that user clicked the lock screen icon instead of the settings one.

… except the user can reproduce this with Applications -> System Tools -> Settings. So I think the GNOME session crashed and they're back in the GDM session. I've asked the OP to do some debugging steps.

#5 Updated by intrigeri over 1 year ago

  • Assignee set to intrigeri
  • Priority changed from Normal to Elevated
  • Target version set to Tails_3.7
  • QA Check changed from Info Needed to Dev Needed
  • Type of work changed from Research to Code
Mar 22 15:51:07 amnesia gnome-control-center.desktop[9338]: libva info: VA-API version 0.39.4
Mar 22 15:51:07 amnesia gnome-control-center.desktop[9338]: libva info: va_getDriverName() returns -1
Mar 22 15:51:07 amnesia gnome-control-center.desktop[9338]: libva error: va_getDriverName() failed with unknown libva error,driver_name=(null)

Mar 22 15:51:08 amnesia gnome-control-center.desktop[9338]: libva info: VA-API version 0.39.4
Mar 22 15:51:08 amnesia gnome-control-center.desktop[9338]: libva info: va_getDriverName() returns -1
Mar 22 15:51:08 amnesia gnome-control-center.desktop[9338]: libva error: va_getDriverName() failed with unknown libva error,driver_name=(null)
Mar 22 15:51:08 amnesia gnome-control-center.desktop[9338]: libva info: VA-API version 0.39.4
Mar 22 15:51:08 amnesia gnome-control-center.desktop[9338]: libva info: va_getDriverName() returns 0
Mar 22 15:51:08 amnesia gnome-control-center.desktop[9338]: libva info: Trying to open /usr/lib/x86_64-linux-gnu/dri/gallium_drv_video.so
Mar 22 15:51:08 amnesia gnome-control-center.desktop[9338]: libva info: va_openDriver() returns -1
Mar 22 15:51:08 amnesia gnome-control-center.desktop[9338]: libva info: VA-API version 0.39.4
Mar 22 15:51:08 amnesia /usr/lib/gdm3/gdm-x-session[5300]: Xorg: ../../../../../../include/privates.h:122: dixGetPrivateAddr: Assertion `key->initialized' failed.
Mar 22 15:51:08 amnesia gnome-control-center.desktop[9338]: XIO:  fatal IO error 11 (Resource temporarily unavailable) on X server ":1" 
Mar 22 15:51:08 amnesia gnome-control-center.desktop[9338]:       after 11 requests (11 known processed) with 0 events remaining.

The OP cannot reprodocue this after deinstalling va-driver-all i965-va-driver mesa-va-drivers gstreamer1.0-vaapi so I think that's a regression caused by #14580. Too bad nobody noticed that in 3.6~rc1 :/

#6 Updated by intrigeri over 1 year ago

#7 Updated by intrigeri over 1 year ago

  • Related to Feature #14580: Support Video Acceleration API (VA-API) added

#8 Updated by intrigeri over 1 year ago

  • Status changed from Confirmed to In Progress
  • Assignee changed from intrigeri to anonym
  • % Done changed from 0 to 50
  • QA Check changed from Dev Needed to Ready for QA
  • Feature Branch set to bugfix/15433-GNOME-settings-vs-VA-API

Documented the known issue + workaround on master, reverted that on the topic branch.

#9 Updated by intrigeri over 1 year ago

  • Blocks Bug #15449: Intel VAAPI: Playing video with Totem freezes the system added

#10 Updated by intrigeri over 1 year ago

  • Target version changed from Tails_3.7 to Tails_3.6.2

#11 Updated by anonym over 1 year ago

  • Status changed from In Progress to 11
  • Assignee deleted (anonym)
  • % Done changed from 50 to 100
  • QA Check changed from Ready for QA to Pass

#12 Updated by anonym over 1 year ago

  • Status changed from 11 to Resolved

Also available in: Atom PDF