Project

General

Profile

Bug #15432

Tails Installer sometimes fails when setting partition type during (since Tails 3.6?)

Added by emmapeel over 1 year ago. Updated over 1 year ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
Hardware support
Target version:
Start date:
03/21/2018
Due date:
% Done:

100%

Feature Branch:
installer:bugfix/15432-installer-robustness, bugfix/15432-installer-robustness
Type of work:
Research
Blueprint:
Starter:
Affected tool:
Installer

Description

Some users are reporting errors when trying to install or upgrade with Tails Installer. I still don't have much information but the errors can be:

When installing to a new USB:

Partitionnement du périphérique /dev/sdd
g-dbus-error-quark: GDBus.Error:org.freedesktop.DBus.Error.UnknownMethod: No such interface 'org.freedesktop.UDisks2.Partition' on object at path /org/freedesktop/UDisks2/block_devices/sdd1 (19)
L'installation de Tails a échoué !
g-dbus-error-quark: GDBus.Error:org.freedesktop.DBus.Error.UnknownMethod: No such interface 'org.freedesktop.UDisks2.Partition' on object at path /org/freedesktop/UDisks2/block_devices/sdd1 (19)

Another log about a similar issue (note that /dev/sdb had no partition nor FS initially):

2018-04-01 11:13:11,060 [creator.py:856 (partition_device)] INFO: Speichermedium /dev/sdb wird partitioniert
2018-04-01 11:13:11,060 [creator.py:859 (partition_device)] DEBUG: Creating partition table
2018-04-01 11:13:13,565 [creator.py:879 (partition_device)] DEBUG: Creating partition
2018-04-01 11:13:14,169 [creator.py:279 (popen)] DEBUG: sync
2018-04-01 11:13:19,230 [creator.py:279 (popen)] DEBUG: sync
2018-04-01 11:13:25,426 [gui.py:264 (run)] ERROR: g-dbus-error-quark: GDBus.Error:org.freedesktop.DBus.Error.UnknownMethod: No such interface 'org.freedesktop.UDisks2.Partition' on object at path /org/freedesktop/UDisks2/block_devices/sdb1 (19)
Traceback (most recent call last):
  File "/usr/lib/python2.7/dist-packages/tails_installer/gui.py", line 203, in run
    self.live.partition_device()
  File "/usr/lib/python2.7/dist-packages/tails_installer/creator.py", line 924, in partition_device
    system_partition.call_set_type_sync(ESP_GUID, GLib.Variant('a{sv}', None))
Error: g-dbus-error-quark: GDBus.Error:org.freedesktop.DBus.Error.UnknownMethod: No such interface 'org.freedesktop.UDisks2.Partition' on object at path /org/freedesktop/UDisks2/block_devices/sdb1 (19)
2018-04-01 11:13:25,428 [gui.py:265 (run)] DEBUG: Traceback (most recent call last):
  File "/usr/lib/python2.7/dist-packages/tails_installer/gui.py", line 203, in run
    self.live.partition_device()
  File "/usr/lib/python2.7/dist-packages/tails_installer/creator.py", line 924, in partition_device
    system_partition.call_set_type_sync(ESP_GUID, GLib.Variant('a{sv}', None))
Error: g-dbus-error-quark: GDBus.Error:org.freedesktop.DBus.Error.UnknownMethod: No such interface 'org.freedesktop.UDisks2.Partition' on object at path /org/freedesktop/UDisks2/block_devices/sdb1 (19)

Related issues

Blocks Tails - Feature #15139: Core work 2018Q2: Foundations Team Resolved 01/01/2018

Associated revisions

Revision 10a7927e (diff)
Added by intrigeri over 1 year ago

Import Tails Installer branch bugfix/15432-installer-robustness as a patch (refs: #15432)

Revision 2accfa45
Added by anonym over 1 year ago

Merge remote-tracking branch 'origin/bugfix/15432-installer-robustness' into stable

Fix-committed: #15432

Revision d96004b4 (diff)
Added by bertagaz over 1 year ago

Revert "Import Tails Installer branch bugfix/15432-installer-robustness as a patch (refs: #15432)"

This reverts commit 10a7927efad4fe57e099ef9af3b08efbbe31c2ec.

History

#1 Updated by emmapeel over 1 year ago

  • Status changed from New to Rejected

One of the users that reported this ticket reformatted the USB stick and the issue dissapeared....

#2 Updated by emmapeel over 1 year ago

Users with this problem can help to solve it:

Please send us the output of running

tails-installer --verbose

from a Terminal.

#3 Updated by emmapeel over 1 year ago

  • Status changed from Rejected to Confirmed

#4 Updated by emmapeel over 1 year ago

  • Assignee changed from emmapeel to intrigeri

I sent you some bug reports about this error...

#5 Updated by intrigeri over 1 year ago

  • Target version set to Tails_3.7
  • QA Check deleted (Info Needed)

I sent you some bug reports about this error...

Thanks! FTR I have one single email with this ticket number in my INBOX so if you meant to send more than one, either they got lost along the way or they're not appropriately tagged.

I'll have a first look to triage this during this dev cycle :)

#6 Updated by intrigeri over 1 year ago

  • Description updated (diff)

#7 Updated by intrigeri over 1 year ago

  • Status changed from Confirmed to In Progress
  • % Done changed from 0 to 10
  • Feature Branch set to installer:bugfix/15432-installer-robustness, bugfix/15432-installer-robustness

I've looked at these bug reports, added relevant info in the description, and asked the submitters to provide more relevant info.

I'm not overly convinced by the "since Tails 3.6" part because the tiny diff between the versions of Tails Installer shipped in Tails 3.5 and 3.6 (tails/5.0.4+dfsg-0tails1..tails/5.0.5+dfsg-0tails1) seems entirely unrelated to the problem at hand. I think I've found the root cause of the problem and I believe it's been introduced in Tails 3.3. I'll try a tentative fix and if it does not break our automated test suite, let's ship it in Tails 3.7 and then we'll see how it fares for users (I cannot reproduce the bug myself so I cannot really tell if I've fixed it).

#8 Updated by intrigeri over 1 year ago

  • Subject changed from Tails Installer failure since Tails 3.6 to Tails Installer sometimes fails when setting partition type during (since Tails 3.6?)

#9 Updated by intrigeri over 1 year ago

#10 Updated by intrigeri over 1 year ago

  • Assignee changed from intrigeri to anonym
  • QA Check set to Ready for QA

#11 Updated by anonym over 1 year ago

  • Status changed from In Progress to Fix committed
  • Assignee changed from anonym to bertagaz
  • % Done changed from 10 to 90
  • QA Check changed from Ready for QA to Pass

Review passes, tests look good both on Jenkins and locally. Merged!

bert, I'll leave this ticket for you to remember to make a tails-installer release and revert 10a7927efad4fe57e099ef9af3b08efbbe31c2ec for Tails 3.7.

#12 Updated by intrigeri over 1 year ago

  • Status changed from Fix committed to In Progress

bert, I'll leave this ticket for you to remember to make a tails-installer release and revert 10a7927efad4fe57e099ef9af3b08efbbe31c2ec for Tails 3.7.

(Trying to increase the chances bertagaz sees this :)

#13 Updated by anonym over 1 year ago

  • Status changed from In Progress to Fix committed
  • % Done changed from 90 to 100

#14 Updated by intrigeri over 1 year ago

  • Status changed from Fix committed to In Progress

anonym wrote:

Applied in changeset 2accfa459653e1410540d703cfa6859382688c2a.

(This is what I get for repairing the push to Redmine's Git mirror.)

#15 Updated by bertagaz over 1 year ago

  • Status changed from In Progress to Resolved
  • Assignee deleted (bertagaz)

anonym wrote:

Review passes, tests look good both on Jenkins and locally. Merged!

bert, I'll leave this ticket for you to remember to make a tails-installer release and revert 10a7927efad4fe57e099ef9af3b08efbbe31c2ec for Tails 3.7.

It's been released!

Also available in: Atom PDF