Project

General

Profile

Bug #15431

Feature #14568: Additional Software Packages

Feature #14594: Code & integration into Tails: Additional Software Packages GUI

tails-synchronize-data-to-new-persistent-volume-on-shutdown.service does not save APT cache at the right place

Added by bertagaz over 1 year ago. Updated over 1 year ago.

Status:
Resolved
Priority:
Elevated
Assignee:
-
Category:
-
Target version:
Start date:
03/21/2018
Due date:
% Done:

100%

Feature Branch:
Type of work:
Code
Blueprint:
Starter:
Affected tool:
Additional Software Packages

Description

In t-p-s, the /live/persistence/TailsData_unlocked/apt/cache/ is used to store the APT cache, to be mounted on /var/cache/apt/archives/.

But at tails-synchronize-data-to-new-persistent-volume.service copy the APT cache into /live/persistence/TailsData_unlocked/apt/archives/, so the ASP offline feature is broken.

Associated revisions

Revision e84e14e0 (diff)
Added by alant over 1 year ago

ASP: fix apt archive path in persistence

Will-fix: #15431

Revision eed7364e (diff)
Added by alant over 1 year ago

ASP: use && instead of ; between the two cp commands

Refs: #15431

History

#1 Updated by intrigeri over 1 year ago

  • Priority changed from Normal to Elevated
  • Parent task changed from #14594 to #14568

(This has nothing to do with #14595 but is a bug in #14570 that we failed to detect for some reason. Not worth reopening #14570 IMO but still, raising priority.)

#2 Updated by alant over 1 year ago

  • Parent task changed from #14568 to #14594

intrigeri wrote:

(This has nothing to do with #14595 but is a bug in #14570 that we failed to detect for some reason. Not worth reopening #14570 IMO but still, raising priority.)

That is wrong, is not about #14570. This issue happens in a new code path we introduced when implementing the UX designed for ASP GUI, so it's a subtask of #14594 or #14595.

#3 Updated by alant over 1 year ago

  • Status changed from Confirmed to In Progress
  • % Done changed from 0 to 30

#4 Updated by intrigeri over 1 year ago

alant wrote:

That is wrong, is not about #14570. This issue happens in a new code path we introduced when implementing the UX designed for ASP GUI

Right! Sorry for the confusion.

so it's a subtask of #14594 or #14595.

I doubt t-p-s is involved so I think you've correctly set the parent task to #14594 :)

#5 Updated by bertagaz over 1 year ago

intrigeri wrote:

I doubt t-p-s is involved so I think you've correctly set the parent task to #14594 :)

Yes, my bad sorry, that's what I intended to do, but I don't know why I parented it to another ticket.

#6 Updated by alant over 1 year ago

  • QA Check set to Ready for QA

#7 Updated by intrigeri over 1 year ago

  • Subject changed from tails-synchronize-data-to-new-persistent-volume.service does not save APT cache at the right place to tails-synchronize-data-to-new-persistent-volume-on-shutdown.service does not save APT cache at the right place

(This service was renamed.)

#8 Updated by intrigeri over 1 year ago

  • QA Check changed from Ready for QA to Dev Needed

Please use && instead of ; between the two cp commands.

#9 Updated by alant over 1 year ago

  • % Done changed from 30 to 50
  • QA Check changed from Dev Needed to Ready for QA

#10 Updated by alant over 1 year ago

  • Status changed from In Progress to Resolved
  • Assignee deleted (alant)
  • % Done changed from 50 to 100
  • QA Check changed from Ready for QA to Pass

Also available in: Atom PDF