Project

General

Profile

Bug #15428

Rename our HTP pools

Added by intrigeri over 1 year ago. Updated 8 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
Time synchronization
Target version:
Start date:
03/19/2018
Due date:
% Done:

100%

Spent time:
Feature Branch:
feature/15428-rename-htp-pools, htp:feature/15428-rename-htp-pools
Type of work:
Code
Blueprint:
Starter:
Affected tool:

Description

People get confused by the use of pal/neutral/foe. We should rename these variables and update https://tails.boum.org/contribute/design/Time_syncing/ to clarify that we don't really need to trust even the "pal" pool, what we need is low chances of members of different pools conspiring against our users.


Related issues

Blocked by Tails - Bug #16134: devel branch FTBFS since torbrowser-launcher 0.3.1-2 was uploaded to sid Resolved 11/17/2018

Associated revisions

Revision 78d9bdff (diff)
Added by intrigeri 10 months ago

Rename pools to avoid confusion (refs: #15428)

People get confused by the use of pal/neutral/foe: they think we need
to particularly trust members of the "pal" pool, which is incorrect
and can lead to useless controversy.

So let's fix this by renaming the pools and clarifying our design doc.

Revision 9ffe2e69 (diff)
Added by intrigeri 8 months ago

Improve wording and fix "the the" typo (refs: #15428).

Revision ec9b2469
Added by intrigeri 8 months ago

Merge remote-tracking branch 'origin/feature/15428-rename-htp-pools' into devel

Fix-committed: #15428

History

#1 Updated by intrigeri over 1 year ago

  • Target version changed from Tails_3.9 to Tails_3.11

#2 Updated by intrigeri 11 months ago

  • Target version changed from Tails_3.11 to Tails_3.12

Let's do this in a major release.

#3 Updated by intrigeri 10 months ago

  • Status changed from Confirmed to In Progress
  • % Done changed from 0 to 10
  • Feature Branch set to feature/15428-rename-htp-pools, htp:feature/15428-rename-htp-pools

#4 Updated by intrigeri 10 months ago

  • Blocked by Bug #16134: devel branch FTBFS since torbrowser-launcher 0.3.1-2 was uploaded to sid added

#5 Updated by intrigeri 10 months ago

  • Assignee changed from intrigeri to segfault
  • % Done changed from 10 to 50
  • QA Check set to Ready for QA

#6 Updated by intrigeri 8 months ago

  • Assignee deleted (segfault)

#7 Updated by hefee 8 months ago

  • Assignee set to hefee

#8 Updated by hefee 8 months ago

  • QA Check changed from Ready for QA to Info Needed

I'm fine with the changes:

 config/chroot_local-includes/etc/default/htpdate.pools          |  6 +++---
 config/chroot_local-includes/lib/systemd/system/htpdate.service | 14 +++++++-------
 config/chroot_local-includes/usr/local/sbin/htpdate             | 10 +++++-----

wording issues in wiki/src/contribute/design/Time_syncing.mdwn:

"The first pool are run are run by groups that are likely to take great care of their visitors' privacy." 
"The first pool list websites, that are likely to take care of their visitors' privacy."

--

"The third pool are managed by adversaries of the first pool." 
"The third pool members are adversaries of the first pool members."

and there is also a typo at line 157 (just in top of the changed paragraph):

send fake time information, with a member from
the the other pools. The pools are as follows:

#9 Updated by hefee 8 months ago

  • Assignee changed from hefee to intrigeri
  • QA Check changed from Info Needed to Pass

htp:feature/15428-rename-htp-pools - properly not a branch name ;D

#10 Updated by intrigeri 8 months ago

htp:feature/15428-rename-htp-pools - properly not a branch name ;D

Our convention for branches on other repos than the official tails.git is: $REPO:$BRANCH. So in this case, that means https://git.tails.boum.org/htp/log/?h=feature/15428-rename-htp-pools, which is exactly what I mean :) And for example, if you submit a branch that's in your own Tails forked repo, you would write hefee:$BRANCH.

#11 Updated by intrigeri 8 months ago

  • Assignee changed from intrigeri to hefee
  • QA Check changed from Pass to Ready for QA

Thanks! Fixed the typos and phrasing bugs, please review again.

Note that these issues were not introduced by my branch, so technically not a blocker for merging it, but it was a good opportunity to polish these other things in the same area :)

#12 Updated by hefee 8 months ago

  • Assignee changed from hefee to intrigeri
  • QA Check changed from Ready for QA to Pass

intrigeri wrote:

Thanks! Fixed the typos and phrasing bugs, please review again.

looks fine for me now.

Note that these issues were not introduced by my branch, so technically not a blocker for merging it, but it was a good opportunity to polish these other things in the same area :)

yes, I know. It was just as fully reading the page anyways.

intrigeri wrote:

htp:feature/15428-rename-htp-pools - properly not a branch name ;D

Our convention for branches on other repos than the official tails.git is: $REPO:$BRANCH. So in this case, that means https://git.tails.boum.org/htp/log/?h=feature/15428-rename-htp-pools, which is exactly what I mean :) And for example, if you submit a branch that's in your own Tails forked repo, you would write hefee:$BRANCH.

checked the htp diffs too. Fine with them.

#13 Updated by intrigeri 8 months ago

  • Status changed from In Progress to Fix committed
  • % Done changed from 50 to 100

#14 Updated by intrigeri 8 months ago

  • Assignee deleted (intrigeri)

#15 Updated by anonym 8 months ago

  • Status changed from Fix committed to Resolved

Also available in: Atom PDF