Project

General

Profile

Bug #15390

TREZOR hardware wallet support is gone since Electrum was updated to 3.x

Added by intrigeri over 1 year ago. Updated about 1 month ago.

Status:
Resolved
Priority:
Elevated
Assignee:
Category:
-
Target version:
-
Start date:
03/09/2018
Due date:
% Done:

0%

Feature Branch:
Type of work:
Code
Blueprint:
Starter:
Affected tool:
Electrum

Description

Regression introduced by #15022: we're still installig python-trezor but it's useless as the new Electrum is Python 3. python3-trezor is in sid.


Related issues

Related to Tails - Feature #15022: Electrum package update to version 3.0.6 Resolved 12/07/2017
Related to Tails - Bug #15189: Figure out what to do with optional Electrum dependencies on Buster Resolved 01/17/2018

Associated revisions

Revision da2910ba (diff)
Added by intrigeri over 1 year ago

Stop installing python-qt4 and python-trezor (refs: #15391).

Electrum 3.x instead uses python3-trezor (refs: #15390) and python3-qt5.

History

#1 Updated by intrigeri over 1 year ago

  • Related to Feature #15022: Electrum package update to version 3.0.6 added

#2 Updated by intrigeri over 1 year ago

  • Related to Bug #15189: Figure out what to do with optional Electrum dependencies on Buster added

#3 Updated by HuberF over 1 year ago

intrigeri wrote:

Regression introduced by #15022: we're still installig python-trezor but it's useless as the new Electrum is Python 3. python3-trezor is in sid.

Just want to advise that python3-trezor is meanwhile available in buster.

#4 Updated by s7r over 1 year ago

python3-trezor will be in stable-backports in few days, so TREZOR hardware wallet support will remain functional.

#5 Updated by intrigeri over 1 year ago

  • Type of work changed from Debian to Discuss

python3-trezor will be in stable-backports in few days,

Great! So users who need it can install it themselves :)

so TREZOR hardware wallet support will remain functional.

… once someone does the Tails part of the work that is one of:

  • either wait for our next major release (3.9), that will use newer snapshots of the Debian archive which include python3-trezor; and then one "just" needs to add that package to the list of packages we install in the ISO;
  • or speed this up using our freeze exception mechanism (requires upload rights to our custom APT repo so that would be for anonym);
  • or forget it because in 3.9 we'll have a much improved "Additional Software Packages" feature: if we stop including python3-trezor by default, the few users who need it will be able to install it easily. We could document this in wiki/src/doc/anonymous_internet/electrum.mdwn and be done with it.

AFAIK nobody complained about this regression so I'm in favour of the last option.
What do you think?

#6 Updated by goupille over 1 year ago

a user reported to the help desk that python-trezor-0.9.x is not working with electrum 3.0.6 :

https://github.com/spesmilo/electrum/issues/3928#issuecomment-366846324

he also reported that using python-trezor-0.7.6-1 is working with electrum 3.0.6 if one also install pyhton3-hid (from buster) and python3-mnemonic (also in buster)

#7 Updated by s7r over 1 year ago

intrigeri wrote:

  • either wait for our next major release (3.9), that will use newer snapshots of the Debian archive which include python3-trezor; and then one "just" needs to add that package to the list of packages we install in the ISO;
  • or speed this up using our freeze exception mechanism (requires upload rights to our custom APT repo so that would be for anonym);
  • or forget it because in 3.9 we'll have a much improved "Additional Software Packages" feature: if we stop including python3-trezor by default, the few users who need it will be able to install it easily. We could document this in wiki/src/doc/anonymous_internet/electrum.mdwn and be done with it.

AFAIK nobody complained about this regression so I'm in favour of the last option.
What do you think?

I agree. I am in favour of the last option as well. python3-trezor and other lower level dependencies like python-mnemonic and python-hidapi need to be fixed at Debian package level as proper dependencies. I don't see it as a Tails related issue.

#8 Updated by intrigeri over 1 year ago

  • Type of work changed from Discuss to Debian
  • or forget it because in 3.9 we'll have a much improved "Additional Software Packages" feature: if we stop including python3-trezor by default, the few users who need it will be able to install it easily. We could document this in wiki/src/doc/anonymous_internet/electrum.mdwn and be done with it.

AFAIK nobody complained about this regression so I'm in favour of the last option.

For the record: goupille forwarded us one such complain and that's not enough to make me change my mind.

What do you think?

I agree. I am in favour of the last option as well.

OK. So, next steps to fix this regression are:

  1. ensure python3-trezor and its dependencies are available in stretch-backports by August 10
  2. tell sajolida what he should document (presumably it will boil down to "install python3-trezor and agree to make it persistent"), reassign to him and set "Type of work: End-user documentation"

Technically we should set "Target version: Tails_3.9" now. Please do so unless having it on your 3.7 radar helps you keep track of the first step that's on your plate.

python3-trezor and other lower level dependencies like python-mnemonic and python-hidapi need to be fixed at Debian package level as proper dependencies. I don't see it as a Tails related issue.

python3-trezor depends on python3-mnemonic and python3-hid already so we're good.

#9 Updated by intrigeri over 1 year ago

  • Status changed from Confirmed to In Progress

#10 Updated by intrigeri over 1 year ago

  • Status changed from In Progress to Confirmed

#11 Updated by bertagaz over 1 year ago

  • Target version changed from Tails_3.7 to Tails_3.8

#12 Updated by intrigeri over 1 year ago

  • Target version changed from Tails_3.8 to Tails_3.9

#13 Updated by u about 1 year ago

  • Assignee changed from s7r to intrigeri
  • QA Check set to Info Needed
  • Type of work changed from Debian to End-user documentation

Please tell sajolida what he should document (presumably it will boil down to "install python3-trezor and agree to make it persistent"), reassign to him and set "Type of work: End-user documentation".

#14 Updated by intrigeri about 1 year ago

  • Assignee changed from intrigeri to s7r

Please tell sajolida what he should document (presumably it will boil down to "install python3-trezor and agree to make it persistent"), reassign to him and set "Type of work: End-user documentation".

Yes, s7r, please do so.

u: we've kept Electrum in Tails only because s7r volunteered to do this kind of work. I never committed to do it myself.

#15 Updated by s7r about 1 year ago

I can get python3-trezor and its dependencies in strectch-backports, but is this our plan? What I mean is, there are many hardware wallets out there and it's best for Tails to just support Electrum and document that hardware wallets need additional packages that need to be in stable-backports, otherwise we can't do anything about it.

intrigeri, what do you think we should do here, considering I can politely ask our Debian package maintainer to add / keep maintained some packages we are interested in for Tails, but the longer this list becomes the harder for everyone.

#16 Updated by intrigeri about 1 year ago

  • Target version changed from Tails_3.9 to Tails_3.10.1
  • QA Check changed from Info Needed to Dev Needed
  • Type of work changed from End-user documentation to Debian

I can get python3-trezor and its dependencies in strectch-backports, but is this our plan?

My understanding of the past discussion here is that this has been the plan since #15390#note-4.

What I mean is, there are many hardware wallets out there and it's best for Tails to just support Electrum and document that hardware wallets need additional packages that need to be in stable-backports, otherwise we can't do anything about it.

I agree. I'm in favor of not reincluding TREZOR support in Tails and instead fix this regression by having the necessary packages in stretch-backports + document how to add it via Additional Software Packages, as I proposed 5 months ago. That is, what we agreed on 5 months ago already. Next step is still the same: get python3-trezor in stretch-backports.

intrigeri, what do you think we should do here, considering I can politely ask our Debian package maintainer to add / keep maintained some packages we are interested in for Tails, but the longer this list becomes the harder for everyone.

Sure. Thankfully we won't need this backport anymore once Tails 4.0 (based on Buster) is out, presumably mid-2019. And then I'll be much more careful when someone suggests we track Electrum from backports: given how it went so far in Tails 3.x (regression introduced 5 months ago, deadlines made clear months in advance, no progress so far and the deadline is now behind us), for Tails 4.x I'm inclined to stick to whatever version is included in Debian Buster, and whatever needs to be fixed in order to keep it working will have to be done via Debian stable updates. And if nothing else works smoothly enough, we can stop including Electrum, ship a working config + persistence settings, and document how to install it with Additional Software Packages.

#17 Updated by sajolida about 1 year ago

So far python3-trezor is only available in unstable. It seems like I could install it on Tails 3.9 (apt install -t unstable python-trezor) but that would pull many other packages.

So I'll wait until it's in backports to document it.

#18 Updated by intrigeri 12 months ago

  • Target version changed from Tails_3.10.1 to Tails_3.11

#19 Updated by CyrilBrulebois 10 months ago

  • Target version changed from Tails_3.11 to Tails_3.12

#20 Updated by anonym 9 months ago

  • Target version changed from Tails_3.12 to Tails_3.13

#21 Updated by s7r 7 months ago

This can be fixed if we decide to ship Electrum tool as an AppImage as per #16564.
We may not depend of what libraries are in Debian for this particular tool. We only have to set the udev rules.

#22 Updated by CyrilBrulebois 7 months ago

  • Target version changed from Tails_3.13 to Tails_3.14

#23 Updated by CyrilBrulebois 5 months ago

  • Target version changed from Tails_3.14 to Tails_3.15

#24 Updated by CyrilBrulebois 3 months ago

  • Target version changed from Tails_3.15 to Tails_3.16

#25 Updated by intrigeri about 2 months ago

  • Target version deleted (Tails_3.16)

Hi!

We've set up an automated process to ask our fellow contributors to update some tickets of theirs, in order to:

  • better reflect your plans;
  • bring down your amount of work-in-progress to a sustainable level;
  • encourage team work and increase the chances that someone finishes the work;
  • avoid a human doing ticket triaging and asking you the same questions on each such ticket.

In particular, this process identifies:

  • Stalled work-in-progress
  • Reviews waiting for a long time

However, in the current state of things, this process is not able to notice those tickets when their Target version has been repeatedly postponed by our Release Managers. Therefore, the ticket triaging team decided on #16545 to remove the Target version whenever in such cases, when it does not feel realistic. This is what I'm doing on this ticket.

You now have a few options, such as:

  • Deassign yourself. That's fine. If it really matters, someone else, possibly you, may pick it up later. Then, if this ticket is relevant for a Tails team, bring it to their attention; else, forget it and take care of yourself :)
  • If you think you can realistically come back to it and finish the work in the next 6 months, say so on this ticket, for example by setting a suitable "Target version". This will communicate your plans to the rest of the project and ensure the task pops up on your radar at a suitable time. Of course, you can still realize later that it is not going to work as planned, and revisit today's choice.

Cheers!

#26 Updated by intrigeri about 1 month ago

  • Status changed from Confirmed to Resolved
  • Type of work changed from Debian to Code

python3-trezor is included in Tails 4.0~beta2 so this should now be fixed.

Also available in: Atom PDF