Project

General

Profile

Bug #15387

The Mozilla auto_config database requires an unusable CAPTCHA for Torified requests

Added by anonym over 1 year ago. Updated 5 months ago.

Status:
Rejected
Priority:
Normal
Assignee:
-
Category:
-
Target version:
-
Start date:
03/07/2018
Due date:
% Done:

0%

Feature Branch:
Type of work:
Code
Blueprint:
Starter:
Affected tool:
Email Client

Description

I've noticed that the Mozilla configuration database (https://live.mozillamessaging.com/autoconfig/v1.1/) often presents a CAPTCHA when the request originates from Tor so the fetchFromISO method fails. We should ask if Mozilla can be more Tor-friendly.

That CAPTCHA is not displayed in the GUI so the user cannot do anything about it.


Related issues

Related to Tails - Bug #15788: Rethink our patches with Thunderbird 60 Resolved 08/14/2018
Related to Tails - Feature #6156: Upstream secure Thunderbird autoconfig wizard In Progress 05/19/2016

History

#1 Updated by anonym over 1 year ago

  • Description updated (diff)

#2 Updated by anonym over 1 year ago

  • Subject changed from The Mozilla auto_config database blocks Tor to The Mozilla auto_config database presents CAPTCHA for Torified requests

#3 Updated by anonym over 1 year ago

  • Status changed from Confirmed to In Progress
  • % Done changed from 0 to 40

Good news! I managed to solve it by making said HTTP fetch respect general.useragent.override. Presumably this is just Cloudflare's (which is the cause of this CAPTCHA (surprise!)) usual scrutiny of everything originating from the Tor network.

What remains is to make TorBirdy set the pref accordingly (currently it sets it to the empty string, which actually is part of causing this problem).

#4 Updated by intrigeri over 1 year ago

  • Subject changed from The Mozilla auto_config database presents CAPTCHA for Torified requests to The Mozilla auto_config database requires an unusable CAPTCHA for Torified requests
  • Description updated (diff)

#5 Updated by anonym over 1 year ago

  • Type of work changed from Communicate to Code

#6 Updated by intrigeri over 1 year ago

  • Target version deleted (Tails_3.7)

Feel free to de-assign yourself (and ideally: improve the description + flag as Easy, but don't block on this) if you want.

#7 Updated by intrigeri over 1 year ago

(According to Help Desk, users don't suffer from this enough to complain about it.)

#8 Updated by u 11 months ago

  • Related to Bug #11619: Torbirdy patches need updating added

#9 Updated by u 11 months ago

  • Related to deleted (Bug #11619: Torbirdy patches need updating)

#10 Updated by u 11 months ago

  • Related to Bug #15788: Rethink our patches with Thunderbird 60 added

#11 Updated by u 11 months ago

  • Related to Feature #6156: Upstream secure Thunderbird autoconfig wizard added

#12 Updated by anonym 5 months ago

  • Status changed from In Progress to Rejected
  • Assignee deleted (anonym)
  • % Done changed from 40 to 0

anonym wrote:

Good news! I managed to solve it by making said HTTP fetch respect general.useragent.override.

Turns out I was wrong; "said HTTP fetch" already respected that pref (my fix would only insist on it an extra time :)). This casts doubt over all my conclusions for this issue, which I think was temporary for whatever reason. I cannot reproduce, no matter the useragent string or whatever. Rejecting.

Also available in: Atom PDF