Project

General

Profile

Feature #15379

Feature #11198: Port complex shell scripts into Python

Adjust test suite to Python tails-upgrade-frontend-wrapper

Added by intrigeri over 1 year ago. Updated about 1 year ago.

Status:
Resolved
Priority:
Elevated
Assignee:
-
Category:
Test suite
Target version:
Start date:
03/05/2018
Due date:
% Done:

100%

Feature Branch:
test/15379-adjust-to-python-upgrade-wrapper
Type of work:
Code
Blueprint:
Starter:
Affected tool:
Upgrader

Description

Our test suite makes assumptions about tails-u-f-w that don't hold anymore since #11753 was merged:

  • at least sed -i "/^sleep 30$/d" does not work anymore
  • it might be that the process name we want to kill in the recovery function has changed (python? killall -f?)

On my system this causes the "Upgrading Tails with Tails Upgrader through an incremental upgrade" scenario to take ages failing before I get bored and CTRL-C it. IIRC I've seen similar problems on Jenkins but I'm not 100% sure.


Related issues

Blocks Tails - Feature #13241: Core work: Test suite maintenance Rejected 06/29/2017

Associated revisions

Revision 959bcaa3 (diff)
Added by intrigeri over 1 year ago

Test suite: use new --no-wait option when retrying tails-upgrade-frontend-wrapper (refs: #15379)

… instead of trying to patch shell code that does not exist anymore.

Revision b022eb5b (diff)
Added by intrigeri over 1 year ago

Test suite: kill current process name when retrying tails-upgrade-frontend-wrapper (refs: #15379)

… instead of trying to kill a tails-upgrade-frontend-wrapper that killall
won't find anymore since this script was rewritten in Python.

Revision 18b65bf2
Added by intrigeri about 1 year ago

Merge branch 'test/15379-adjust-to-python-upgrade-wrapper' into devel (Fix-committed: #15379)

History

#1 Updated by intrigeri over 1 year ago

It might be that this bug is only exposed when recover_from_upgrader_failure is called, i.e. when the first attempt to I am proposed to install an incremental upgrade to […] fails. Which might explain why I see it a lot locally but lizard, with its better Internet connection, does not expose it.

#2 Updated by intrigeri over 1 year ago

Oh, and BTW: tails-upgrade-frontend-wrapper now has a --no-wait option. This should be better than sed -i "/^sleep 30$/d.

#3 Updated by intrigeri over 1 year ago

  • Blocks Feature #14595: Code for Additional Software Packages GUI: Persistence Setup added

#4 Updated by bertagaz over 1 year ago

  • Target version changed from Tails_3.6 to Tails_3.7

#5 Updated by intrigeri over 1 year ago

#6 Updated by intrigeri over 1 year ago

  • Assignee deleted (anonym)

#7 Updated by intrigeri over 1 year ago

  • Status changed from Confirmed to In Progress
  • Assignee set to intrigeri
  • % Done changed from 0 to 10
  • Feature Branch set to test/15379-adjust-to-python-upgrade-wrapper

#8 Updated by intrigeri over 1 year ago

  • Assignee changed from intrigeri to anonym
  • QA Check set to Ready for QA

#9 Updated by intrigeri over 1 year ago

  • Blocks deleted (Feature #14595: Code for Additional Software Packages GUI: Persistence Setup)

#10 Updated by bertagaz over 1 year ago

  • Target version changed from Tails_3.7 to Tails_3.8

#11 Updated by intrigeri about 1 year ago

  • Target version changed from Tails_3.8 to Tails_3.9

#12 Updated by intrigeri about 1 year ago

  • Target version changed from Tails_3.9 to Tails_3.10.1

#13 Updated by segfault about 1 year ago

  • Assignee changed from anonym to intrigeri
  • QA Check changed from Ready for QA to Dev Needed

Code review passes, except for one thing:

It's not regression, but we can either drop the killall tails-upgrade-frontend, or replace it with pkill --full tails-upgrade-frontend, because it's a perl script and killall won't ever find a process with tails-upgrade-frontend as the executable name.

#14 Updated by segfault about 1 year ago

segfault wrote:

It's not regression, but we can either drop the killall tails-upgrade-frontend, or replace it with pkill --full tails-upgrade-frontend, because it's a perl script and killall won't ever find a process with tails-upgrade-frontend as the executable name.

A quick test indicates that I'm wrong here, but I don't know why

#15 Updated by segfault about 1 year ago

  • QA Check changed from Dev Needed to Pass

#16 Updated by intrigeri about 1 year ago

  • Status changed from In Progress to Fix committed
  • Assignee deleted (intrigeri)
  • Target version changed from Tails_3.10.1 to Tails_3.9
  • % Done changed from 10 to 100

Merged, thanks!

#17 Updated by intrigeri about 1 year ago

  • Status changed from Fix committed to Resolved

Also available in: Atom PDF