Project

General

Profile

Bug #15371

Tails documentation is not translated when browsing online

Added by bertagaz over 1 year ago. Updated over 1 year ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
-
Target version:
Start date:
03/02/2018
Due date:
% Done:

100%

Feature Branch:
feature/15332-prefer-online-docs
Type of work:
Code
Blueprint:
Starter:
Affected tool:

Description

Reported while testing 3.6~rc1: when the Tails documentation desktop icon is clicked on in a Tails connected to a network, the Tor Browser does not open the Tails documentation in the language configured for the session. It always opens it in english.


Related issues

Related to Tails - Feature #15332: tails-documentation should prefer online docs Resolved 02/20/2018

Associated revisions

Revision 4fba04a3 (diff)
Added by intrigeri over 1 year ago

tails-documentation: open translated documentation page in Tor Browser when online (refs: #15371).

Our website has language negotiation enabled but our Tor Browser pretends
the user prefers English.

Revision 1d21bc73
Added by anonym over 1 year ago

Merge branch 'feature/15332-prefer-online-docs' into stable

Fix-committed: #15332, #15371

History

#1 Updated by bertagaz over 1 year ago

  • Related to Feature #15332: tails-documentation should prefer online docs added

#2 Updated by bertagaz over 1 year ago

Assigning to anonym to see if he wants to handle that.

#3 Updated by bertagaz over 1 year ago

  • Target version changed from Tails_3.6 to Tails_3.7

#4 Updated by intrigeri over 1 year ago

  • Assignee changed from anonym to intrigeri

#5 Updated by intrigeri over 1 year ago

  • % Done changed from 0 to 50
  • QA Check set to Ready for QA
  • Feature Branch set to feature/15332-prefer-online-docs

#6 Updated by intrigeri over 1 year ago

  • Status changed from Confirmed to In Progress

#7 Updated by intrigeri over 1 year ago

  • Assignee changed from intrigeri to anonym

#8 Updated by intrigeri over 1 year ago

  • Target version changed from Tails_3.7 to Tails_3.6.2

#9 Updated by emmapeel over 1 year ago

Just wanted to add that the TBB from the menu works well (not the documentation).

I mean that if I select Spanish in the Tails Greeter, when I open TBB it lands in https://tails.boum.org/home/index.es.html)

#10 Updated by anonym over 1 year ago

emmapeel wrote:

Just wanted to add that the TBB from the menu works well (not the documentation).

I mean that if I select Spanish in the Tails Greeter, when I open TBB it lands in https://tails.boum.org/home/index.es.html)

This is because we set the start page depending on which locale was picked, not because Tor Browser tells the server which locale it runs so the server can pick a translated site. FWIW, the feature branch implements the same behavior for tails-documentation.

#11 Updated by anonym over 1 year ago

  • Status changed from In Progress to Fix committed
  • % Done changed from 50 to 100
  • QA Check changed from Ready for QA to Pass

#12 Updated by anonym over 1 year ago

  • Assignee deleted (anonym)

#13 Updated by anonym over 1 year ago

  • Status changed from Fix committed to Resolved

Also available in: Atom PDF