Project

General

Profile

Bug #15361

Feature #10034: Translation web platform

Feature #11759: Install & configure a fresh weblate on the VM

Implement automatic checking & correction of inconsistent strings in Weblate

Added by u over 1 year ago. Updated 5 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
-
Target version:
-
Start date:
03/02/2018
Due date:
% Done:

20%

Feature Branch:
emmapeel:bug/15361-checks
Type of work:
Sysadmin
Blueprint:
Starter:
Affected tool:

Description

I think we should enable some of these checks by default in Weblate:
https://docs.weblate.org/en/latest/user/checks.html
https://docs.weblate.org/en/latest/admin/config.html#std:setting-CHECK_LIST

I know that some of these inconsistencies are actually coming from manual translations over Git, and I want to fix this site of the story too, so that people cannot commit inconsistent strings when not using Weblate, but we shouldo fix this in Weblate too.


Related issues

Related to Tails - Bug #15362: Pre-commit hook/Run check_po whenever we try to commit a po file in all Git repositories Resolved 03/02/2018
Related to Tails - Bug #15365: Check if voting mechanism in Weblate WRT validity of strings Resolved 03/02/2018
Related to Tails - Feature #16122: More checks for weblate Resolved 11/13/2018

History

#1 Updated by u over 1 year ago

  • Parent task set to #11759

#2 Updated by u over 1 year ago

  • Related to Bug #15362: Pre-commit hook/Run check_po whenever we try to commit a po file in all Git repositories added

#3 Updated by emmapeel over 1 year ago

  • Status changed from Confirmed to Resolved

They are implemented

#4 Updated by u over 1 year ago

  • Status changed from Resolved to Confirmed

Hi emmapeel! great. Can you document briefly where/how this is implemented? Imagine we need to set up the platform anew, how can we get these configuration settings to the new platform? Is there a possibility to export / backup our setup configuration?

#5 Updated by u over 1 year ago

For now I can only see that there are checks, https://translate.tails.boum.org/checks/ but they are not corrected. What we want is that users who do not respect the file consistency cannot save their suggestion altogether.

#6 Updated by u over 1 year ago

  • Status changed from Confirmed to In Progress
  • % Done changed from 0 to 20

#7 Updated by u over 1 year ago

  • Subject changed from Implement automatic checking of inconsistent strings in Weblate to Implement automatic checking & correction of inconsistent strings in Weblate

If this is not yet possible, please report a bug upstream.
With our Git hooks, it will become impossible to commit broken or inconsistent files and somebody will have to make corrections manually.

#9 Updated by u over 1 year ago

  • Related to Bug #15365: Check if voting mechanism in Weblate WRT validity of strings added

#10 Updated by emmapeel over 1 year ago

u wrote:

Hi emmapeel! great. Can you document briefly where/how this is implemented? Imagine we need to set up the platform anew, how can we get these configuration settings to the new platform? Is there a possibility to export / backup our setup configuration?

It will be easy because they are on the weblate/settings.py file

#11 Updated by emmapeel over 1 year ago

  • Status changed from In Progress to Resolved

#12 Updated by emmapeel about 1 year ago

  • Status changed from Resolved to In Progress
  • Assignee changed from emmapeel to groente
  • QA Check set to Ready for QA
  • Feature Branch set to emmapeel:bug/15361-checks

As now the settings.py file has also been taken over by puppet, i reopen this ticket to submit the merge request.

please review https://git-tails.immerda.ch/emmapeel/puppet-tails

branch bug/15361-checks

two commits to add new checks and autofixes

https://git-tails.immerda.ch/emmapeel/puppet-tails/commit/?h=bug/15361-checks&id=71105d07ddc025bdf702f3609449eaa3dfdfa229

#13 Updated by groente about 1 year ago

  • Status changed from In Progress to Resolved

changes have been added to the template file on production branch

#14 Updated by emmapeel about 1 year ago

#15 Updated by intrigeri 12 months ago

  • QA Check deleted (Ready for QA)

#16 Updated by intrigeri 5 months ago

  • Assignee deleted (groente)

Also available in: Atom PDF