Project

General

Profile

Bug #15351

Add Riseup Labs' postal address to our donation page

Added by sajolida almost 2 years ago. Updated almost 2 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
Category:
Fundraising
Target version:
-
Start date:
02/27/2018
Due date:
% Done:

0%

Feature Branch:
Type of work:
Website
Blueprint:
Starter:
Affected tool:

Description

For US checks for example.

Riseup Labs
PO Box 4282
Seattle, WA 98194


Related issues

Duplicates Tails - Feature #12075: Add Riseup Labs's postal addresses on the donation page for US checks Resolved 12/23/2016

History

#1 Updated by sajolida almost 2 years ago

  • Assignee set to u

u: I had this in my mailbox but I don't see the information on /donate.

Do you want to do it? Otherwise I can do it.

#2 Updated by u almost 2 years ago

  • Status changed from Confirmed to Duplicate

sajolida wrote:

u: I had this in my mailbox but I don't see the information on /donate.

That's because you missed #12075 :)

#3 Updated by sajolida almost 2 years ago

  • Duplicates Feature #12075: Add Riseup Labs's postal addresses on the donation page for US checks added

#4 Updated by sajolida almost 2 years ago

  • Assignee deleted (u)

I search for "Riseup Labs" and didn't find it :)

Also available in: Atom PDF