Project

General

Profile

Bug #15320

Have the aufs regression since Linux 4.14 fixed upstream

Added by intrigeri almost 2 years ago. Updated almost 2 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
-
Target version:
Start date:
02/17/2018
Due date:
% Done:

100%

Feature Branch:
Type of work:
Communicate
Blueprint:
Starter:
Affected tool:

Description

On https://bugs.debian.org/886329 we're asked to provide more info so the bug can be forwarded upstream.

Our workaround is ugly, makes UX poor, and confused users overload our help desk.


Related issues

Blocks Tails - Feature #13245: Core work 2018Q1: Foundations Team Resolved 06/29/2017
Blocks Tails - Feature #15339: Consider switching back to Debian sid's aufs-dkms Resolved 02/21/2018

History

#1 Updated by intrigeri almost 2 years ago

#2 Updated by intrigeri almost 2 years ago

  • Status changed from Confirmed to In Progress
  • % Done changed from 0 to 20

I've provided the info the Debian maintainer needed to forward this upstream. Stay tuned!

#3 Updated by intrigeri almost 2 years ago

  • Target version changed from Tails_3.6 to Tails_3.7

Next proactive step for me: ping during next release cycle if the process is stalled. Of course I'll reply any additional request for info I receive but I don't need a 3.6 ticket for that => postponing.

#4 Updated by intrigeri almost 2 years ago

So actually, that bug happens only when CONFIG_AUFS_DEBUG = 1, which is the default upstream and in Debian but we disable it when we build the out-of-tree module ourselves. See today's discussion on https://bugs.debian.org/886329 for details. I'll wait for upstream input and then may ask the Debian maintainer to disable that option.

#5 Updated by intrigeri almost 2 years ago

  • Related to Feature #15339: Consider switching back to Debian sid's aufs-dkms added

#6 Updated by intrigeri almost 2 years ago

  • Subject changed from Report the aufs regression since Linux 4.14 upstream to Have the aufs regression since Linux 4.14 fixed upstream

#7 Updated by intrigeri almost 2 years ago

  • Related to deleted (Feature #15339: Consider switching back to Debian sid's aufs-dkms)

#8 Updated by intrigeri almost 2 years ago

  • Blocks Feature #15339: Consider switching back to Debian sid's aufs-dkms added

#9 Updated by intrigeri almost 2 years ago

  • Status changed from In Progress to Resolved
  • % Done changed from 20 to 100

It's "fixed" in Debian (by disabling CONFIG_AUFS_DEBUG): https://tracker.debian.org/news/935683. Our own build script from the upstream source disables it as well. So in any case we're not affected anymore; I've provided all the info upstream requested so I don't think we should track this on our side anymore :)

Also available in: Atom PDF