Project

General

Profile

Feature #15317

Feature #15292: Distribute a USB image

Feature #15293: Creating & preparing the disk image

Randomize disk GUID of USB image during boot

Added by segfault about 2 years ago. Updated over 1 year ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
-
Target version:
Start date:
02/17/2018
Due date:
% Done:

100%

Feature Branch:
segfault:feature/15292-usb-image
Type of work:
Code
Blueprint:
Starter:
Affected tool:

Description

All devices that the USB image is copied to have the same GUID, which can cause problems if multiple Tails devices are plugged in at the same time. The plan is to prevent this by setting a random disk GUID during the first boot of the device.


Related issues

Related to Tails - Bug #15681: Check getrandom() status and potential problems Resolved 06/23/2018

History

#1 Updated by segfault about 2 years ago

  • Assignee deleted (segfault)
  • QA Check set to Ready for QA

Should be fixed by 689d98876ef00d1c359eb9baf146bf1f38a00a58.

#2 Updated by intrigeri over 1 year ago

  • Related to Bug #15681: Check getrandom() status and potential problems added

#3 Updated by Anonymous over 1 year ago

segfault: if this is ready for QA, do you want to assign this to a potential reviewer?

#4 Updated by intrigeri over 1 year ago

segfault: if this is ready for QA, do you want to assign this to a potential reviewer?

I'd rather hold on until the USB image project is started, or at least until we know who'll be segfault's reviewer on this project…

#5 Updated by Anonymous over 1 year ago

  • Assignee set to intrigeri
  • Target version set to Tails_3.10.1

Seems like intrigeri is the reviewer for this. Assigning accordingly.

#7 Updated by Anonymous over 1 year ago

  • Parent task changed from #15292 to #15293

#8 Updated by intrigeri over 1 year ago

  • Assignee changed from intrigeri to segfault
  • Target version changed from Tails_3.10.1 to Tails_3.11
  • QA Check changed from Ready for QA to Info Needed

Please reassign to me once you think it's ready for a review & tell me how I can test this.
Postponing to 3.11 as you've requested on XMPP :)

#9 Updated by intrigeri over 1 year ago

  • Assignee changed from segfault to intrigeri
  • Target version changed from Tails_3.11 to Tails_3.10.1
  • QA Check changed from Info Needed to Ready for QA

Update by segfault: this is probably ready to be reviewed and https://gitlab.com/segfault3/tails-usb-image-from-iso explains how to test it.

#10 Updated by intrigeri over 1 year ago

  • Status changed from Confirmed to Resolved
  • Assignee deleted (intrigeri)
  • % Done changed from 0 to 100
  • QA Check changed from Ready for QA to Pass

The randomization part looks good and works for me!

Also available in: Atom PDF