Project

General

Profile

Feature #15308

Feature #10034: Translation web platform

Feature #11759: Install & configure a fresh weblate on the VM

Cannot update database schemes in translate.lizard

Added by emmapeel almost 2 years ago. Updated 5 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
-
Target version:
Start date:
02/13/2018
Due date:
% Done:

0%

Feature Branch:
Type of work:
Sysadmin
Blueprint:
Starter:
Affected tool:

Description

We need to allow the user weblate to write new migration fixtures to

/usr/local/share/weblate/weblate/trans/migrations/

In order to create such fixtures and allow the updating of the database.

This is needed before the SponsorL work starts.

History

#1 Updated by emmapeel over 1 year ago

  • Target version changed from Tails_3.6 to Tails_3.7

#2 Updated by u over 1 year ago

  • Assignee set to emmapeel
  • QA Check set to Info Needed

emmapeel, can you please confirm that this is needed only to update the current weblate version to a newer one? It's not needed for pulling and adding components, correct?

#3 Updated by emmapeel over 1 year ago

  • Assignee changed from emmapeel to groente
  • QA Check changed from Info Needed to Dev Needed

This is needed even to finish the installation we have atm.

It will not prevent components to work but it generates problems with for example the glossary and the statistics.

#4 Updated by groente over 1 year ago

  • Assignee changed from groente to emmapeel
  • QA Check changed from Dev Needed to Info Needed

to what degree does it specifically need to be user weblate who has write permission here? i can chown the directory, but i'm a bit uncomfortable with giving a web-application write access to its own code. can you think of a solution to create these fixtures as a different user?

#5 Updated by emmapeel over 1 year ago

  • Assignee changed from emmapeel to groente
  • QA Check changed from Info Needed to Dev Needed

It will only be needed to update the database scheme because of changes on the code.

It can be taken out after finishing the update.

It will create some xml files and add/rm some columns on the database.

It would be good to do it first to finish current install, and then after we upgrade again.

The commands we need to run from /usr/local/share/weblate/ are:

- sudo -u weblate ./manage.py makemigrations /* this one creates the needed features
- sudo -u weblate ./manage.py migrate        /* this one actually alters the database

Then we can remove the permission again.

#6 Updated by groente over 1 year ago

  • Assignee changed from groente to emmapeel

ok, the directory and its contents have been chown'ed, please let me know when the install/updates are done and i'll revert this.

#7 Updated by emmapeel over 1 year ago

  • Assignee changed from emmapeel to groente

OK, I did one migration (the trans app), but now it wants to write to:

/usr/local/share/weblate/weblate/accounts/migrations/

also (the accounts app, to: "- Alter field language on profile")

#8 Updated by groente over 1 year ago

  • Assignee changed from groente to emmapeel

ok, that directory has also been chown'ed, let me know when you're done with it!

#9 Updated by emmapeel over 1 year ago

  • Assignee changed from emmapeel to groente

Great! So, the migration for 2.10 is complete, we will need to do it again for 2.19. But you can remove the permissions for now.

#10 Updated by bertagaz over 1 year ago

  • Target version changed from Tails_3.7 to Tails_3.8

#11 Updated by intrigeri over 1 year ago

  • Target version changed from Tails_3.8 to Tails_3.9

#12 Updated by groente over 1 year ago

  • Status changed from Confirmed to Resolved
  • Assignee changed from groente to emmapeel

since the coming upgrade will be a project on its own anyway and these steps should then be handled by puppet, i'm going to close this ticket.

#13 Updated by intrigeri 5 months ago

  • Assignee deleted (emmapeel)

Also available in: Atom PDF