Project

General

Profile

Bug #15306

Feature #14877: Donation campaign 2018

Propose donation possibility in other cryptocurrencies than Bitcoin

Added by u over 1 year ago. Updated 10 months ago.

Status:
Resolved
Priority:
Elevated
Assignee:
-
Category:
Fundraising
Target version:
Start date:
02/11/2018
Due date:
% Done:

0%

Feature Branch:
web/15306-more-cryptocurrencies
Type of work:
Research
Blueprint:
Starter:
Affected tool:

Description

  1. research which other possibility/ies to propose (which are the ones used by Tails users?)
  2. check what is need to create accounts on our side in order to retrieve these donations
  3. implement this in the donation page

0001-blogpost-cryptocurrencies-review.patch View (1.42 KB) moire, 12/05/2018 06:11 PM


Related issues

Duplicated by Tails - Feature #7314: Evaluate accepting donations in other cryptocurrencies than Bitcoin Duplicate 12/23/2016

History

#1 Updated by u over 1 year ago

#2 Updated by intrigeri over 1 year ago

check what is need to create accounts on our side in order to retrieve these donations

Last time I checked, the client software needed to support all these new fancy cryptocurrencies people want to send to us was not in Debian. So it seems that our only realistic option is to have donors send coins directly to our account on a coinbase-like platform, that would either automatically sell the received coins and send us the money regularly, or would allow us to trigger such operations in a painless manner. It would be nice if we had good reasons to trust that platform somewhat; even better if one single platform would support more than one popular cryptocurrency so we don't have to learn too much about each of them ourselves :)

#3 Updated by intrigeri over 1 year ago

  • Subject changed from Propose donation possibility in other cryptocurrency than btc to Propose donation possibility in other cryptocurrencies than Bitcoin

#4 Updated by u 11 months ago

  • Assignee changed from u to sajolida

I believe you started tackling this :)

#5 Updated by sajolida 11 months ago

  • Target version changed from Tails_3.10.1 to Tails_3.11

I asked RiseupLabs but I won't have time to follow up on that before 3.10.

#6 Updated by sajolida 11 months ago

  • Assignee changed from sajolida to moire
  • Parent task set to #14877

It's already possible to send the following cryptocurrencies to the Coinbase account that we have at RiseupLabs:

  • Bitcoin Cash
  • Ethereum
  • Ethereum Classic
  • Litecoin

The addresses are in Message-ID: <> on tails-fundraising.

moire: Do you think you can try to add them to /donate before mid-November?

I would start with:

  • Moving "US check" below "Bank transfer"
  • Stacking all the different cryptocurrencies under Bitcoin

As always, don't hesitate to ask for tons of info instead of getting stuck on a problem for too long.

#7 Updated by sajolida 11 months ago

  • Duplicated by Feature #7314: Evaluate accepting donations in other cryptocurrencies than Bitcoin added

#8 Updated by sajolida 11 months ago

moire: When do you think you'll have time to try this out? We should do #15931 and #15306 but I'd like to release this one shortly after that.

If you're too busy with other things I can also do it myself but I thought it was a good ticket to get your hands dirty with some ikiwiki code :)

#9 Updated by sajolida 10 months ago

  • Assignee changed from moire to sajolida

I'll work on this now.

#10 Updated by sajolida 10 months ago

  • Assignee changed from sajolida to moire
  • Feature Branch set to web/15306-more-cryptocurrencies

Please have a look if you can, otherwise reassign to intrigeri.

I would like to merge and announce this after November 18 maybe.

#11 Updated by sajolida 10 months ago

We received the list of addressed in a mail from RiseupLabs on 2018-10-23 ("Accepting donations in other cryptcurrencies").

#12 Updated by sajolida 10 months ago

  • QA Check set to Ready for QA

#13 Updated by sajolida 10 months ago

moire: Since I saw you working on other tickets recently, may I ping you on this one?

If you didn't review it yet because it's not in your comfort zone, I could ask intrigeri instead and it'll probably take him 10 minutes to do the review.

We only have 1 blog post for the rest of the campaign and it might be a good time to post about this before 3.11 is out (December 11) so we can postpone the blog post on plans for around December 14-18.

#14 Updated by moire 10 months ago

  • Assignee changed from moire to sajolida

- Line 426 is missing a final "4"

The donate page looks fine but:
- I don't think I have access to the initial email
- I don't know how check that the different new addresses are valid

I should have asked for that earlier. Asking intrigeri is a better option to have a faster answer.

Ok with postponing the publication of the third campaign blogpost.

#15 Updated by sajolida 10 months ago

- Line 426 is missing a final "4"

Oh god! This would have been a critical typo. Good catch!

The donate page looks fine but:

Thanks!

- I don't think I have access to the initial email

Oops, indeed. It was on tails-accounting@. I triple-checked the
addresses myself then.

- I don't know how check that the different new addresses are valid

Me neither and I think that we can only trust RiseupLabs on this one.

Ok with postponing the publication of the third campaign blogpost.

I'll write you about this later on this week.

#16 Updated by sajolida 10 months ago

  • QA Check deleted (Ready for QA)

I merged this branch.

I should still:

  • Let RiseupLabs know.
  • Tweet about it.
  • Consider writing a short blog post about it.

#17 Updated by sajolida 10 months ago

  • Priority changed from Normal to Elevated

#18 Updated by sajolida 10 months ago

  • Assignee changed from sajolida to moire
  • QA Check set to Ready for QA

Here you go! To be published between today and Friday.

#19 Updated by moire 10 months ago

I removed some duplication of terms and concluded with a direct invitation to donate, but the initial version was fine as well!

#20 Updated by sajolida 10 months ago

  • Status changed from Confirmed to Resolved
  • Assignee deleted (sajolida)
  • QA Check deleted (Pass)

Done all this!

Also available in: Atom PDF