Project

General

Profile

Feature #15292

Distribute a USB image

Added by intrigeri over 1 year ago. Updated 2 months ago.

Status:
Resolved
Priority:
High
Assignee:
Category:
Installation
Target version:
Start date:
04/14/2016
Due date:
01/29/2019
% Done:

95%

Estimated time:
(Total: 178.00 h)
Spent time:
(Total: 27.90 h)
Feature Branch:
feature/15292-usb-image
Type of work:
Code
Starter:
Affected tool:

Description

This will fix a number of UX issues about our installation process. See the blueprint and https://tails.boum.org/blueprint/usb_install_and_upgrade/ for details.


Subtasks

Feature #12439: Unify the syslinux directory & config file name between ISO and installed USB stickRejected

Feature #15293: Creating & preparing the disk imageResolved

Feature #15316: Fix GPT backup header of the USB image during bootResolved

Feature #15317: Randomize disk GUID of USB image during bootResolved

Feature #15319: Grow system partition during boot when started from USBResolved

Bug #15984: Review & polish disk image generationResolved

Bug #15985: Make the disk image reproducible / Make the image creation deterministicResolved

Bug #15986: Grow the system partition at first bootDuplicate

Bug #15988: Set unique UUID on first boot & adapt bootloaderResolved

Bug #15990: Integrate disk image in build processResolved

Bug #15991: Code review & rubber-duck for USB ImageRejected

Bug #15992: Post-release bugfixing for creating & preparing the disk imageRejectedsegfault

Feature #16057: Test partitioning script in various scenariosResolved

Bug #16149: USB image is not bootable anymoreResolved

Bug #16153: System partition is not an EFI System PartitionResolved

Feature #16154: Merge USB image generation into masterResolved

Bug #16168: USB image creation sometimes fails with: GLib.Error: udisks-error-quark: GDBus.Error:org.freedesktop.UDisks2.Error.NotSupported: No support for modifying a partition a table of type `PMBR' (11)Resolved

Bug #16176: create-usb-image-from-iso does not work anymore as non-rootResolved

Bug #16178: partitioning script strips read-only, hidden, no-automount attributesResolved

Bug #15993: Adjust infrastructure and CI for USB imagesResolvedgroente

Bug #16155: increase jenkins and iso-archive diskspaceResolved

Bug #16157: Re-enable USE_LAST_RELEASE_AS_OLD_ISO=yes on JenkinsResolved

Bug #16158: Ensure that old Jenkins artifacts are cleaned upResolved

Bug #16159: reproducibly_build_Tails_ISO_* jobs are brokenResolved

Bug #16160: test_Tails_ISO_* fail on Jenkins due to lack of disk spaceRejected

Bug #16162: Test reproducibility of USB images for all branchesResolvedgroente

Bug #16174: reproducibly_build_Tails_ISO_* jobs leave *.img around even when successfulResolved

Bug #16377: bittorrent.lizard lacks space for uploading both .img and .isoResolvedgroente

Bug #16395: rsync.lizard lacks space for uploading both .img and .iso + IUKsResolvedgroente

Bug #15994: Update Tails Verification extension to handle USB imagesRejectedu

Bug #15995: Have Tails Verification handle IDFs with several Tails installation paths (ISO/IMG)Resolvedu

Bug #15996: Code review, rubber-duck & review design docRejected

Bug #15997: Test and release new Tails VerificationResolved

Bug #15998: Update design doc for Tails VerificationResolved

Bug #15999: Integrate USB image in the release processResolved

Bug #16164: Adjust release process for new build artifacts naming schemeResolved

Bug #16171: Get our master branch ready for IDF v2 and new Tails Verification extensionResolved

Bug #16002: Adjust our test suite for USB imagesRejected

Bug #16003: Write automated tests for growing system partitionResolved

Bug #16005: Code review & rubber-duckRejected

Bug #16006: USB image: adjust documentationResolvedsajolida

Feature #15660: Adapt our installation instructions to have 2 different downloadsResolved

Feature #15810: Adjust overviews to USB imagesResolved

Feature #15812: Remove /mac/dvd installation scenarioDuplicate

Feature #15813: Adjust /expert/usbResolved

Feature #15814: Adjust routers to USB imagesResolved

Feature #15809: Rewrite macOS routerResolved

Feature #15823: Download ISO or USB images depending on the installation scenarioResolved

Feature #15825: Remove mac-dvd installation scenarioResolved

Feature #15826: Change "ISO" to "IMG" on infographyResolved

Bug #16007: Document the usage of graphical dd toolsResolvedsajolida

Bug #11347: Test Etcher, a multiplatform USB drive burnerResolved

Feature #11682: Document Etcher to install Tails from macOSResolved

Feature #15659: Document GNOME Disks for Debian, Linux, and manual upgradesResolved

Feature #15808: Document Etcher to install Tails from WindowsResolved

Bug #16163: Clarify updated release process requirements for USB imageResolved

Bug #16205: Fix PO files on the USB image doc branchResolved

Bug #16008: Adjust check-mirrors for USB imageResolved

Bug #16010: Have metrics on the hits on https://tails.boum.org/install/win/usb/#backResolved

Bug #16011: Get ready for removing tails-installer from DebianResolvedu

Bug #16012: Ensure Tails installer is removed from Debian & Ubuntu by the end of 2019Confirmedu

Feature #16130: Add rewrite rules for the pages removed because of the distributions of USB imagesResolvedbertagaz

Bug #16198: Bootstrap an integration branch for the USB image projectResolved

Feature #16199: Publish a beta for USB imagesResolved

Bug #16318: GNOME Disks asks for sudo password before copying USB image from DebianResolved

Bug #16325: Clarify the relationship between USB images and upgradeResolved

Bug #16354: Missing s/ISO/USB/ update?Resolved


Related issues

Related to Tails - Feature #5929: Consider creating a persistence by default for plausible deniability Confirmed 08/20/2016
Related to Tails - Feature #14624: Document how to migrate persistence to a new USB stick or update the system partitions of an existing device Duplicate 09/12/2017
Related to Tails - Feature #15123: Rethink the "ISO image" terminology Resolved 12/27/2017
Related to Tails - Bug #15178: Install syslinux.exe in the ISO filesystem on Buster Rejected 01/17/2018
Related to Tails - Bug #14907: UUI should preselect "Format in FAT32" when Tails is selected Rejected 10/29/2017
Related to Tails - Feature #10984: Test Rufus Rejected 01/22/2016
Related to Tails - Feature #6319: Restructure the documentation on Mac support Confirmed 09/28/2013
Related to Tails - Bug #12445: tails-installer should validate file integrity after unpacking the ISO on the sd-card Duplicate 04/13/2017
Related to Tails - Feature #11681: Decide if/how we want plausible deniability for the persistent volume Rejected 08/20/2016
Related to Tails - Feature #10731: Tails Installer should not allow installing on non-removable USB sticks In Progress 12/09/2015
Related to Tails - Bug #7654: Tails Installer crashes if any UUID includes Unicode character Confirmed
Related to Tails - Feature #7422: Do not duplicate syslinux on the ISO root filesystem Rejected 06/19/2014
Related to Tails - Feature #15806: Use GRUB for USB boot on EFI 64-bit Confirmed 08/18/2018
Related to Tails - Feature #6878: Pressing Enter in Tails Installer should start the installation Confirmed 03/07/2014
Related to Tails - Feature #8861: Be able to launch Tails Installer from the command line Rejected 02/04/2015
Related to Tails - Feature #8836: Add splash screen when booting intermediary Tails Rejected 02/02/2015
Related to Tails - Bug #16364: Consider updating Virtualization doc WRT USB images Confirmed 01/16/2019
Related to Tails - Bug #15989: Update our plans to remove removable flag requirement Confirmed 09/28/2018
Blocks Tails - Feature #6560: UEFI Secure boot Confirmed 01/02/2014
Blocks Tails - Feature #7496: Make it possible to verify the integrity of a Tails USB device In Progress 07/06/2014

Associated revisions

Revision d50830f2
Added by intrigeri 6 months ago

Merge branch 'feature/15292-usb-image' into devel

We do need this branch merged in time before the 3.12 freeze.
There are still a few things to fix here and there but their
ETA is either after the freeze, or unknown.

refs: #15292

History

#1 Updated by intrigeri over 1 year ago

  • Related to Feature #5929: Consider creating a persistence by default for plausible deniability added

#2 Updated by intrigeri over 1 year ago

  • Related to Feature #14624: Document how to migrate persistence to a new USB stick or update the system partitions of an existing device added

#3 Updated by intrigeri over 1 year ago

  • Related to Feature #15123: Rethink the "ISO image" terminology added

#4 Updated by intrigeri over 1 year ago

  • Blocks Bug #13206: Install by cloning sometimes silently fails from a stick installed with UUI added

#5 Updated by intrigeri over 1 year ago

#6 Updated by intrigeri over 1 year ago

  • Blocks Bug #12146: Tails installed using dd is not seen as a bootable device on MacBook Pro added

#7 Updated by intrigeri over 1 year ago

  • Subject changed from Distribute bootable USB disk image to Distribute a USB image

#8 Updated by intrigeri over 1 year ago

segfault, doing #12439 first might ease your job here.

#9 Updated by intrigeri over 1 year ago

  • Related to Feature #12439: Unify the syslinux directory & config file name between ISO and installed USB stick added

#10 Updated by intrigeri over 1 year ago

  • Related to Bug #15178: Install syslinux.exe in the ISO filesystem on Buster added

#11 Updated by sajolida about 1 year ago

  • Related to Bug #14907: UUI should preselect "Format in FAT32" when Tails is selected added

#12 Updated by sajolida about 1 year ago

#13 Updated by sajolida about 1 year ago

  • Related to Feature #6319: Restructure the documentation on Mac support added

#14 Updated by u about 1 year ago

  • Assignee changed from segfault to u
  • Target version set to Tails_3.12

#15 Updated by u 11 months ago

  • Related to Bug #15778: Make the Tails Installer upstream tarball DFSG-free added

#16 Updated by u 11 months ago

  • Related to Bug #12445: tails-installer should validate file integrity after unpacking the ISO on the sd-card added

#17 Updated by u 11 months ago

  • Related to Feature #11681: Decide if/how we want plausible deniability for the persistent volume added

#18 Updated by u 11 months ago

  • Related to Feature #10731: Tails Installer should not allow installing on non-removable USB sticks added

#19 Updated by u 11 months ago

  • Related to Bug #10114: Tails Installer should display accurate progress information instead for freezing on "Synchronizing data on disk..." added

#20 Updated by u 11 months ago

#21 Updated by u 11 months ago

  • Related to Bug #7654: Tails Installer crashes if any UUID includes Unicode character added

#22 Updated by u 11 months ago

  • Related to Feature #7422: Do not duplicate syslinux on the ISO root filesystem added

#23 Updated by intrigeri 11 months ago

  • Related to deleted (Feature #10085: Port Tails Installer to Python 3)

#24 Updated by intrigeri 11 months ago

  • Related to Feature #15806: Use GRUB for USB boot on EFI 64-bit added

#25 Updated by intrigeri 11 months ago

  • Related to deleted (Feature #12439: Unify the syslinux directory & config file name between ISO and installed USB stick)

#26 Updated by intrigeri 11 months ago

  • Related to deleted (Bug #15778: Make the Tails Installer upstream tarball DFSG-free)

#27 Updated by intrigeri 11 months ago

  • Related to deleted (Bug #10114: Tails Installer should display accurate progress information instead for freezing on "Synchronizing data on disk...")

#28 Updated by u 11 months ago

  • Related to Feature #6878: Pressing Enter in Tails Installer should start the installation added

#29 Updated by sajolida 11 months ago

  • Related to Feature #8861: Be able to launch Tails Installer from the command line added

#30 Updated by sajolida 11 months ago

  • Related to Feature #8836: Add splash screen when booting intermediary Tails added

#31 Updated by sajolida 10 months ago

  • Blocks deleted (Bug #13206: Install by cloning sometimes silently fails from a stick installed with UUI)

#33 Updated by intrigeri 8 months ago

  • Blocks Feature #7496: Make it possible to verify the integrity of a Tails USB device added

#34 Updated by intrigeri 7 months ago

  • Feature Branch set to feature/15292-usb-image

#35 Updated by intrigeri 6 months ago

  • Status changed from Confirmed to In Progress

#36 Updated by u 6 months ago

  • Related to Bug #16364: Consider updating Virtualization doc WRT USB images added

#37 Updated by anonym 6 months ago

  • Target version changed from Tails_3.12 to Tails_3.13

#38 Updated by intrigeri 4 months ago

  • Blocks deleted (Bug #12146: Tails installed using dd is not seen as a bootable device on MacBook Pro)

#39 Updated by intrigeri 4 months ago

  • Related to Bug #15989: Update our plans to remove removable flag requirement added

#40 Updated by u 4 months ago

  • Target version changed from Tails_3.13 to Tails_3.14

Same target version as remaining subtasks.

#41 Updated by u 4 months ago

  • Status changed from In Progress to Resolved

#16389, #16004, #16009 are still open.

#42 Updated by intrigeri 2 months ago

  • Target version changed from Tails_3.14 to Tails_3.13.2

#43 Updated by anonym 2 months ago

  • Target version changed from Tails_3.13.2 to Tails_3.14

#44 Updated by intrigeri 2 months ago

  • Target version changed from Tails_3.14 to Tails_3.13.2

Also available in: Atom PDF