Project

General

Profile

Feature #15281

Stack one single SquashFS diff when upgrading

Added by anonym about 2 years ago. Updated 3 months ago.

Status:
Resolved
Priority:
High
Assignee:
Category:
Installation
Target version:
Start date:
04/13/2016
Due date:
% Done:

100%

Feature Branch:
feature/15281-single-squashfs-diff, iuk:feature/15281-single-squashfs-diff, perl5lib:feature/15281-single-squashfs-diff
Type of work:
Code
Starter:
Affected tool:
Upgrader

Description

That is, address a number of UX problems in our upgrade process with an hopefully cheap and temporary solution.


Subtasks

Feature #15279: Refresh Tails signing key before each upgrade checkResolvedsegfault

Feature #15282: Add a prompt right before applying an IUKResolved

Feature #15283: Implement the "one single SquashFS diff" scheme in Tails UpgraderResolvedsegfault

Feature #6876: Have the incremental upgrade process use less RAMResolved

Feature #17152: Port tails-iuk to a more lightweight set of dependenciesResolved

Feature #15284: Adapt release process for the "one single SquashFS diff" upgrade schemeResolved

Feature #15285: Adapt incremental upgrade manual test for the "one single SquashFS diff" upgrade schemeResolved

Feature #15286: Adapt automated test suite for the "one single SquashFS diff" upgrade schemeResolvedsegfault

Feature #15290: Reduce IUK sizeResolved

Bug #15407: Prevent system user uid:s and gid:s from changing between releasesResolved


Related issues

Related to Tails - Feature #11131: Endless automatic upgrades Rejected 01/05/2015
Related to Tails - Feature #15291: Remove less popular packages that users could install themselves Resolved 04/17/2018
Related to Tails - Feature #15277: Update our survey of non-NIH system upgrade solutions Confirmed 02/03/2018
Related to Tails - Feature #11679: Rethink the installation process and upgrade process Resolved 08/20/2016
Related to Tails - Feature #7499: Extend the upgrader to allow full (self) upgrade Confirmed 07/06/2014
Related to Tails - Feature #15287: Make it possible to reproducibly generate IUKs in CI Resolved 02/05/2018
Related to Tails - Feature #15288: Document tricks for power users vs. bigger downloads for automatic upgrade Confirmed 02/05/2018
Related to Tails - Bug #17398: Follow-up to "Stack one single SquashFS diff when upgrading" Resolved
Blocks Tails - Feature #16209: Core work: Foundations Team Confirmed

Associated revisions

Revision 7ddb1dae (diff)
Added by anonym about 2 years ago

Patch tails-iuk and tails-perl5lib adding the "one single SquashFS diff" feature.

It imports the changes in the feature/15281-single-squashfs-diff
branch in the tails-iuk and tails-perl5lib repos.

Refs: #15281

Revision 690c9ebc (diff)
Added by anonym about 2 years ago

Import new snapshot of tails-iuk for #15281.

Now it imports the 'feature/15281-single-squashfs-diff' branch to
commit bc36507314773db64a8f4044f0b424e85a77ef18, meaning that old
SquashFS diff files now should be cleaned up.

Refs: #15281

Revision a3537f89 (diff)
Added by anonym about 2 years ago

Import new snapshot of tails-iuk for #15281 and #15282.

For #15281 we should now not remove kernel+initrd from ./live, and the
prompt for #15282 has been added.

Refs: #15281, #15282

Revision ef629160 (diff)
Added by intrigeri 5 months ago

Endless upgrades: draft deployment plan (refs: #15281)

Revision 70b434d4 (diff)
Added by intrigeri 4 months ago

WIP: adjust to perl5lib being imported into tails.git (refs: #7036)

This also updates the iuk.git snapshot (refs: #15281) with patches come from
iuk.git:feature/15281-single-squashfs-diff at
commit 38ee60cc71761a5b6024e81a52e1c36be051c1ec.

Revision 415ef146 (diff)
Added by intrigeri 4 months ago

Adjust to perl5lib being imported into tails.git (refs: #7036)

This also updates the iuk.git snapshot (refs: #15281) with patches come from
iuk.git:feature/15281-single-squashfs-diff at
commit 38ee60cc71761a5b6024e81a52e1c36be051c1ec.

Revision e5e98537
Added by segfault 3 months ago

Merge branch 'feature/15281-single-squashfs-diff' into stable (Closes: #15281, #15279, #15283, #15286)

History

#1 Updated by anonym about 2 years ago

#2 Updated by anonym about 2 years ago

#3 Updated by anonym about 2 years ago

  • Target version set to Tails_3.6

We might be able to pull this off in time for Tails 3.6. Let's see!

#4 Updated by anonym about 2 years ago

  • Blocked by Feature #15282: Add a prompt right before applying an IUK added

#5 Updated by anonym about 2 years ago

  • Blocks Feature #15288: Document tricks for power users vs. bigger downloads for automatic upgrade added

#6 Updated by anonym about 2 years ago

#7 Updated by anonym about 2 years ago

  • Related to Feature #15291: Remove less popular packages that users could install themselves added

#8 Updated by anonym about 2 years ago

  • Feature Branch changed from https://tails.boum.org/blueprint/Endless_upgrades/ to feature/15281-1bigiuk
  • Blueprint set to https://tails.boum.org/blueprint/Endless_upgrades/

#9 Updated by intrigeri about 2 years ago

  • Description updated (diff)
  • Blueprint changed from https://tails.boum.org/blueprint/Endless_upgrades/ to https://tails.boum.org/blueprint/Endless_upgrades/#iuks-on-steroids

#10 Updated by intrigeri about 2 years ago

  • Related to Feature #6876: Have the incremental upgrade process use less RAM added

#11 Updated by intrigeri about 2 years ago

  • Related to Feature #15277: Update our survey of non-NIH system upgrade solutions added

#12 Updated by intrigeri about 2 years ago

  • Related to deleted (Feature #8415: Migrate from aufs to overlayfs)

#13 Updated by intrigeri about 2 years ago

#14 Updated by intrigeri about 2 years ago

  • Feature Branch changed from feature/15281-1bigiuk to feature/11131-endless-upgrade, iuk:feature/11131-endless-upgrade, perl5lib:feature/11131-endless-upgrade

#15 Updated by intrigeri about 2 years ago

  • Blocked by deleted (Feature #15282: Add a prompt right before applying an IUK)

#16 Updated by intrigeri about 2 years ago

  • Related to Feature #11679: Rethink the installation process and upgrade process added

#17 Updated by intrigeri about 2 years ago

  • Description updated (diff)

#18 Updated by intrigeri about 2 years ago

  • Subject changed from Switch to the 1BigIUK upgrade scheme to Stack one single SquashFS diff when upgrading

#19 Updated by intrigeri about 2 years ago

  • Blueprint changed from https://tails.boum.org/blueprint/Endless_upgrades/#iuks-on-steroids to https://tails.boum.org/blueprint/Endless_upgrades/#single-squashfs-diff

#20 Updated by intrigeri about 2 years ago

  • Description updated (diff)

#21 Updated by anonym about 2 years ago

  • Feature Branch changed from feature/11131-endless-upgrade, iuk:feature/11131-endless-upgrade, perl5lib:feature/11131-endless-upgrade to feature/15281-single-squashfs-diff, iuk:feature/11131-endless-upgrade, perl5lib:feature/11131-endless-upgrade

#22 Updated by anonym about 2 years ago

  • Status changed from Confirmed to In Progress
  • Feature Branch changed from feature/15281-single-squashfs-diff, iuk:feature/11131-endless-upgrade, perl5lib:feature/11131-endless-upgrade to feature/15281-single-squashfs-diff, iuk:feature/15281-single-squashfs-diff, perl5lib:feature/15281-single-squashfs-diff

#23 Updated by intrigeri about 2 years ago

Some of the design doc changes on feature/11131-endless-upgrade were relevant but are not on the new branch.

#24 Updated by intrigeri about 2 years ago

  • Target version changed from Tails_3.6 to Tails_3.7

#25 Updated by intrigeri about 2 years ago

  • Target version changed from Tails_3.7 to Tails_3.8

#26 Updated by intrigeri about 2 years ago

#27 Updated by intrigeri almost 2 years ago

  • Target version changed from Tails_3.8 to Tails_3.10.1

#28 Updated by intrigeri almost 2 years ago

#29 Updated by intrigeri almost 2 years ago

#30 Updated by intrigeri almost 2 years ago

  • Target version changed from Tails_3.10.1 to Tails_3.11

#31 Updated by intrigeri almost 2 years ago

#32 Updated by intrigeri almost 2 years ago

#33 Updated by intrigeri over 1 year ago

  • Related to Feature #7499: Extend the upgrader to allow full (self) upgrade added

#34 Updated by intrigeri over 1 year ago

  • Assignee changed from anonym to intrigeri

segfault, I've taken over most subtasks. I expect some of them can be reassigned to you (depending on how much of #8415 you take) but I have to take a look at the current status first.

#35 Updated by intrigeri over 1 year ago

  • Related to deleted (Feature #6876: Have the incremental upgrade process use less RAM)

#36 Updated by intrigeri over 1 year ago

  • Target version changed from Tails_3.11 to Tails_3.12

#37 Updated by intrigeri over 1 year ago

  • Target version changed from Tails_3.12 to Tails_3.13

#38 Updated by intrigeri over 1 year ago

#39 Updated by intrigeri over 1 year ago

#40 Updated by intrigeri about 1 year ago

  • Target version changed from Tails_3.13 to 2019

#41 Updated by intrigeri about 1 year ago

#42 Updated by intrigeri about 1 year ago

#44 Updated by intrigeri about 1 year ago

  • Assignee deleted (intrigeri)

#45 Updated by intrigeri 7 months ago

  • Description updated (diff)

#46 Updated by intrigeri 5 months ago

#47 Updated by intrigeri 5 months ago

intrigeri wrote:

Some of the design doc changes on feature/11131-endless-upgrade were relevant but are not on the new branch.

I've salvaged these changes except those that are about the IUK format v2, which I'll salvage later as part of #6876.

#48 Updated by intrigeri 5 months ago

  • Assignee set to intrigeri

I could definitely use some help on the non-Perl subtasks, but since most of the work is on my plate, I want to have the parent ticket clearly on my radar.

#49 Updated by intrigeri 4 months ago

  • Target version changed from 2019 to Tails_4.3

Most of this has to be completed in January 2020, as per contract.

#50 Updated by intrigeri 4 months ago

  • Priority changed from Normal to High

#51 Updated by intrigeri 4 months ago

Hi @segfault! As a heads up:

  • I'm done with the bulk of the work here (see subtasks).
  • The corresponding automated tests pass locally already.
  • I'm only waiting for Jenkins results before sending onto your plate for review.
  • You can now start your review whenever you have time for it. The deadline for merging in Jan 5.
  • I'll try to implement the testing strategy that anonym & I came up with on #15283, if time allows.

#52 Updated by intrigeri 4 months ago

  • Status changed from In Progress to Needs Validation

#53 Updated by intrigeri 4 months ago

  • Related to Feature #15287: Make it possible to reproducibly generate IUKs in CI added

#54 Updated by intrigeri 4 months ago

  • Related to Feature #15288: Document tricks for power users vs. bigger downloads for automatic upgrade added

#55 Updated by intrigeri 4 months ago

  • Target version changed from Tails_4.3 to Tails_4.2

(I've moved out of this ticket the subtasks that don't necessarily have to be done in time for 4.2, so it's easier to track here what the blockers are for 4.2 and merging.)

#56 Updated by intrigeri 4 months ago

  • Assignee changed from intrigeri to segfault

#57 Updated by segfault 3 months ago

  • Status changed from Needs Validation to Resolved
  • % Done changed from 81 to 100

#58 Updated by segfault 3 months ago

Note that I did not review:

  • The commits by anonym from February 2018, because I assumed that intrigeri already reviewed those.
  • The code in config/chroot_local-includes/usr/src that was imported from iuk.git and perl5lib.git.

I will create a follow-up ticket for the few remarks I have.

#59 Updated by segfault 3 months ago

  • Related to Bug #17398: Follow-up to "Stack one single SquashFS diff when upgrading" added

Also available in: Atom PDF