Project

General

Profile

Bug #15275

Feature #14568: Additional Software Packages

Feature #14594: Code & integration into Tails: Additional Software Packages GUI

Feature #14595: Code for Additional Software Packages GUI: Persistence Setup

Remove the GNOME Keyring persistent feature

Added by sajolida over 1 year ago. Updated over 1 year ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
Persistence
Target version:
Start date:
02/01/2018
Due date:
% Done:

100%

Feature Branch:
perl5lib:feature/14594-asp-gui, iuk:feature/14594-asp-gui, persistence-setup:feature/14594-asp-gui, feature/14594-asp-gui
Type of work:
Code
Blueprint:
Starter:
Affected tool:

Description

I don't know myself what it's good for in Tails, in terms of practical use cases.

Our documentation says that it's needed to save the passwords of Wi-Fi networks but it's not true: I deactivated GNOME Keyring and deleted the underlying files and I still autoconnect to my Wi-Fi network. The passwords are saved in the nm-system-connections files.


Related issues

Related to Tails - Feature #15265: Propose a new order of the persistent feature Resolved 01/29/2018
Related to Tails - Feature #15280: Reorder persistence features Resolved 04/17/2018
Related to Tails - Feature #16718: Consider adding back a Persistence feature for GNOME keyring Resolved

History

#1 Updated by sajolida over 1 year ago

  • Related to Feature #15265: Propose a new order of the persistent feature added

#2 Updated by intrigeri over 1 year ago

Our documentation says that it's needed to save the passwords of Wi-Fi networks but it's not true

Indeed, that's been wrong since Jessie or something.
And IIRC that was the sole reason why we added this persistence feature in the first place so full ACK for removing!

#3 Updated by intrigeri over 1 year ago

#4 Updated by segfault over 1 year ago

I just noticed that we document another use case for a persistent GNOME Keyring: Storing the passphrase of encrypted volumes.

#5 Updated by sajolida over 1 year ago

Thanks for spotting that. I did some test and indeed if I choose to remember a password for an encrypted USB stick, it is stored in TailsData_unlocked/gnome-keyring/tails.keyring.

Removing the option might break use cases for people and I need to give it a second thought...

#6 Updated by intrigeri over 1 year ago

Removing the option might break use cases for people

My understanding is that:

  • it will make it harder for new users who use an app that saves passwords there to make these passwords persistent
  • it will make the persistence configuration interface simpler (less choices) for everyone else
  • it won't break anything for users who already have made GNOME Keyring data persistent

#7 Updated by sajolida over 1 year ago

  • Assignee changed from sajolida to intrigeri
  • QA Check set to Info Needed
  • Type of work changed from Discuss to Code
  • it won't break anything for users who already have made GNOME Keyring data persistent

Because of #8447? I didn't think about that. That's cool :)

Then I'm convinced again that we should remove it.

intrigeri: as the author of the persistence configuration, do you want to work on this yourself or shall we leave it to someone else?

#8 Updated by intrigeri over 1 year ago

  • Assignee changed from intrigeri to sajolida

sajolida wrote:

  • it won't break anything for users who already have made GNOME Keyring data persistent

Because of #8447?

Nope, this has nothing to do with deleting the data or not, it's about enabling a line in persistence.conf or not. Let me explain. Whether we display or not a persistence feature in the persistence config GUI does not affect what's in the config file. Hiding it from the GUI won't delete the corresponding line in the config file if it was already present there. I did not test this recently but that's how I think the code works. For example, that's why you can have custom persistence config lines in persistence.conf, and they're not deleted when you run the config GUI.

Does this make you change your mind or do you still want us to do that?

intrigeri: as the author of the persistence configuration, do you want to work on this yourself or shall we leave it to someone else?

I can do that at the same time as #15280 (early March, to be completed by the end of June, shipped in 3.8). It's mostly deleting a few lines in the code and decrementing some hard-coded integer values in the test suite accordingly.

#9 Updated by sajolida over 1 year ago

  • Assignee changed from sajolida to intrigeri
  • QA Check deleted (Info Needed)

Does this make you change your mind or do you still want us to do that?

I still want us to do that :)

Waiting until you work on #15280 is fine.

#10 Updated by intrigeri over 1 year ago

  • Feature Branch set to persistence-setup:feature/15280-15275-rework-persistence-features

#11 Updated by intrigeri over 1 year ago

  • Status changed from Confirmed to In Progress
  • % Done changed from 0 to 10

Implemented, passes the upstream test suite. I'll now run this through the Tails test suite.

#12 Updated by intrigeri over 1 year ago

  • Target version changed from Tails_3.6 to Tails_3.7

#13 Updated by intrigeri over 1 year ago

  • Feature Branch changed from persistence-setup:feature/15280-15275-rework-persistence-features to persistence-setup:feature/15280-15275-rework-persistence-features, feature/15280-15275-rework-persistence-features

#14 Updated by intrigeri over 1 year ago

  • Feature Branch changed from persistence-setup:feature/15280-15275-rework-persistence-features, feature/15280-15275-rework-persistence-features to persistence-setup:feature/14594-asp-gui, feature/14594-asp-gui

#15 Updated by intrigeri over 1 year ago

intrigeri wrote:

I'll now run this through the Tails test suite.

Passes!

#16 Updated by intrigeri over 1 year ago

  • % Done changed from 10 to 50

#17 Updated by intrigeri over 1 year ago

  • Feature Branch changed from persistence-setup:feature/14594-asp-gui, feature/14594-asp-gui to perl5lib:feature/14594-asp-gui, persistence-setup:feature/14594-asp-gui, feature/14594-asp-gui

#18 Updated by intrigeri over 1 year ago

  • Feature Branch changed from perl5lib:feature/14594-asp-gui, persistence-setup:feature/14594-asp-gui, feature/14594-asp-gui to perl5lib:feature/14594-asp-gui, iuk:feature/14594-asp-gui, persistence-setup:feature/14594-asp-gui, feature/14594-asp-gui

#19 Updated by intrigeri over 1 year ago

  • Blocked by Feature #14595: Code for Additional Software Packages GUI: Persistence Setup added

#20 Updated by intrigeri over 1 year ago

  • % Done changed from 50 to 90

FTR this will be done when #14595 and friends are merged into devel, which should happen late June / early July.

#21 Updated by intrigeri over 1 year ago

  • Blocked by deleted (Feature #14595: Code for Additional Software Packages GUI: Persistence Setup)

#22 Updated by intrigeri over 1 year ago

  • Parent task set to #14594

#23 Updated by intrigeri over 1 year ago

  • Status changed from In Progress to Resolved
  • Assignee deleted (intrigeri)
  • Target version changed from Tails_3.7 to Tails_3.9
  • % Done changed from 90 to 100

Let's treat this any other subtask of #14595.

#24 Updated by intrigeri over 1 year ago

  • Parent task changed from #14594 to #14595

#25 Updated by intrigeri 2 months ago

  • Related to Feature #16718: Consider adding back a Persistence feature for GNOME keyring added

Also available in: Atom PDF