Project

General

Profile

Feature #15266

Feature #14568: Additional Software Packages

Feature #14574: Design GUI for Additional Software packages

Investigate why buttons disappear from notifications

Added by alant over 1 year ago. Updated over 1 year ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
-
Target version:
-
Start date:
01/29/2018
Due date:
% Done:

0%

QA Check:
Feature Branch:
Type of work:
Research
Blueprint:
Starter:
Affected tool:

Description

After the notification is stored in its "shelf" one can't click on its buttons anymore. Feature or bug?


Related issues

Duplicated by Tails - Feature #15272: Investigate the design of buttons in GNOME notifications Duplicate 01/31/2018

History

#1 Updated by alant over 1 year ago

Related GNOME tickets:

So it looks like a bug, with some activity, but no solution yet.

#2 Updated by alant over 1 year ago

Good news, there's an API to mark the urgency of notification. If marked "Urgent" they behave the way we want: https://wiki.gnome.org/Design/OS/Notifications#Urgent

Notify.Notification.set_urgency(Notify.Urgency.CRITICAL)
Gio.Notification.set_priority(Gio.NotificationPriority.HIGH)

#3 Updated by alant over 1 year ago

  • Status changed from Confirmed to Resolved

#4 Updated by sajolida over 1 year ago

  • Duplicated by Feature #15272: Investigate the design of buttons in GNOME notifications added

Also available in: Atom PDF