Project

General

Profile

Feature #15265

Feature #14568: Additional Software Packages

Feature #14574: Design GUI for Additional Software packages

Propose a new order of the persistent feature

Added by sajolida over 1 year ago. Updated over 1 year ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
Persistence
Target version:
Start date:
01/29/2018
Due date:
% Done:

100%

QA Check:
Feature Branch:
Type of work:
Code
Blueprint:
Starter:
Affected tool:

Description

Maybe based on which ones are more popular?


Related issues

Related to Tails - Bug #15275: Remove the GNOME Keyring persistent feature Resolved 02/01/2018
Blocks Tails - Feature #15280: Reorder persistence features Resolved 04/17/2018

History

#1 Updated by sajolida over 1 year ago

  • Assignee changed from sajolida to intrigeri
  • QA Check set to Ready for QA

I did some stats on Whisperback from 2016+2017 and they kind of makes sense:

Personal Data 1166 97% 1
GnuPG 948 79% 2
Browser Bookmarks 902 75% 3
Network Connections 836 69% 4
Thunderbird 803 67% 5
APT Packages 774 64% 6
APT Lists 756 63% 7
SSH Client 749 62% 8
Bitcoin client 736 61% 9
GNOME Keyring 729 60% 10
Pidgin 727 60% 11
Dotfiles 647 54% 12
Printers 615 51% 13
Claws Mail 67 6% 14

So I'm proposing the follow new order:

  1. Stuff that anybody might use independently of the applications they use in Tails (except Tor Browser):
    1. Personal Data
    2. Browser bookmarks
    3. Network Connections
    4. Additional Software
    5. Printers
  2. Application data
    1. GnuPG
    2. Thunderbird
    3. SSH Client
    4. Bitcoin Client
    5. Pidgin
  3. Stuff for advanced users
    1. Dotfiles

I'm a bit surprised by the order of the applications, so if we wanted to purposefully lower in the list the applications that correspond to more technical users we could do:

  1. Application data
    1. Thunderbird
    2. GnuPG
    3. Bitcoin Client
    4. Pidgin
    5. SSH Client

NB: It still seems to be true that half of the people click on all the options "just in case" because they don't really know what they correspond to.

#2 Updated by sajolida over 1 year ago

  • Related to Bug #15275: Remove the GNOME Keyring persistent feature added

#3 Updated by sajolida over 1 year ago

Ah, and I'm proposing to kill the GNOME Keyring feature in #15275.

#4 Updated by intrigeri over 1 year ago

  • Assignee changed from intrigeri to sajolida
  • QA Check changed from Ready for QA to Dev Needed

Both proposals work for me.

#5 Updated by sajolida over 1 year ago

  • Assignee changed from sajolida to intrigeri
  • QA Check deleted (Dev Needed)
  • Type of work changed from User interface design to Code

Let's do the second one then!

  1. Personal Data
  2. Browser bookmarks
  3. Network Connections
  4. Additional Software
  5. Printers
  6. Thunderbird
  7. GnuPG
  8. Bitcoin Client
  9. Pidgin
  10. SSH Client
  11. Dotfiles

#6 Updated by intrigeri over 1 year ago

#7 Updated by intrigeri over 1 year ago

  • Status changed from Confirmed to New
  • Assignee deleted (intrigeri)
  • % Done changed from 0 to 100

A new order was proposed, created #15280 for the implementation. If you think that's part of this sponsor deliverable, please adjust metadata there accordingly or ask me to do it.

#8 Updated by intrigeri over 1 year ago

  • Status changed from New to Resolved

Also available in: Atom PDF