Project

General

Profile

Feature #15264

Feature #14568: Additional Software Packages

Feature #14574: Design GUI for Additional Software packages

Sketch notifications when the persistent storage is locked or impossible to create

Added by sajolida over 1 year ago. Updated over 1 year ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
-
Target version:
Start date:
01/29/2018
Due date:
% Done:

0%

Feature Branch:
Type of work:
User interface design
Blueprint:
Starter:
Affected tool:
Additional Software Packages

Associated revisions

Revision b20af2d2 (diff)
Added by sajolida over 1 year ago

Add missing interfaces (Will-fix: #15264)

History

#1 Updated by sajolida over 1 year ago

  • Assignee changed from sajolida to alant
  • QA Check set to Ready for QA

See b20af2d277.

#2 Updated by sajolida over 1 year ago

  • Status changed from Confirmed to In Progress

#3 Updated by alant over 1 year ago

  • Assignee changed from alant to sajolida
  • QA Check changed from Ready for QA to Dev Needed

I'm not convinced by the title "Learn about additional software in tails" because it doesn't look like a summary to me. And I think we should mention ecrypted storage somewhere. Something like "Tails can remember additional software if started from USB" (perhaps too long though). And "you could install Mumble automatically from your persistence storage every time you start Tails".

I agree for no notification if persistence is present but not unlocked.

#4 Updated by sajolida over 1 year ago

  • Assignee changed from sajolida to alant
  • QA Check changed from Dev Needed to Ready for QA

I could have guessed that you wouldn't like this one :)

The issues here is that we only have 62 characters (if I remember correctly):

  • The notification is telling people about something thay cannot do right now unless they install Tails on a different medium. We are telling people that something is possible but not for them right now. For that you proposed "You could" or "Tails can" while I propose "Learn". The idea is pretty much the same. I personally prefer "Learn" because it's more straightforward. "Tails can" and "You could" are not as clear. They open a possibility without being clear about the fact that people will need more than the notification (or at least its summary) to make this a reality.
  • We can't assume that running from a USB stick is enough because it's impossible on an intermediary Tails.
  • We can't really mention "your persistent storage" because maybe people can't even have one, for example if they use a DVD or are in a VM.

Making this all fit in 62 characters is challenging, that's why I initially opted for a prompt to read more.

More ideas that fit in 62 characters:

  • Learn how to install Mumble automatically
  • You could install Mumble automatically every time
  • You could install Mumble automatically when you start Tails

What do you think?

#5 Updated by alant over 1 year ago

  • Assignee changed from alant to sajolida
  • QA Check changed from Ready for QA to Dev Needed

sajolida wrote:

  • Learn how to install Mumble automatically

"...when you start Tails"

  • You could install Mumble automatically when you start Tails

One of these looks good to me.

#6 Updated by sajolida over 1 year ago

  • Assignee changed from sajolida to alant
  • QA Check changed from Dev Needed to Ready for QA

Ok, I choose the version which was the shortest.

I also shortened the body of the notification which was a duplicate of the summary.

The new version is:

*You could install Mumble automatically when starting Tails*
To do so, you need to run Tails from a USB stick installed using Tails Installer.

To be consistent and shorter, I also changed all the other labels from "every time you start Tails" to "when starting Tails". It's shorter and probably as clear and easier to translate. If it happens to be not as clear, we'll detect that during the user testing.

#7 Updated by alant over 1 year ago

  • Assignee changed from alant to sajolida
  • QA Check changed from Ready for QA to Dev Needed

Great, look like we agree on everything.

Would you update the mockups in the blueprint, then close mark this as fix commited?

#8 Updated by sajolida over 1 year ago

  • Status changed from In Progress to Resolved
  • QA Check deleted (Dev Needed)

I already upgraded the mockups.

Sometimes they are hard to refresh because they are linked as external images.

Restarting Tails works well, otherwise follow this XKCD tutorial: https://xkcd.com/1854/.

Also available in: Atom PDF