Project

General

Profile

Bug #15258

Thunderbird doesn't display the Subject/To/Date fields of emails sent by Schleuder v3

Added by goupille over 1 year ago. Updated 10 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
-
Target version:
Start date:
01/27/2018
Due date:
% Done:

0%

QA Check:
Info Needed
Feature Branch:
Type of work:
Wait
Blueprint:
Starter:
Affected tool:
Email Client

Description

Since tails 3.4 (but maybe before), when I select an email it doesn't show the right subject in the grey header panel of the compact view. The subject field seems to be the only one affected.
The same thing happens when I open the email in another tab, but opening the email in another window disply the correct subject.

I couldn't reproduce with debian sid, nor find any bug reports about that elsewhere.


Related issues

Blocks Tails - Feature #15334: Core work 2018Q3: Foundations Team Resolved 02/20/2018

History

#1 Updated by goupille over 1 year ago

it seems that thunderbird can't show the subject of emails sent by a schleuder list (in the grey panel, not in the inbox), so it keep showing the subject of the last email

#2 Updated by goupille over 1 year ago

  • Status changed from New to Confirmed

#3 Updated by goupille over 1 year ago

  • Subject changed from Thunderbird doesn't display the right subject to Thunderbird doesn't display the subject of emails sent by schleuder v3 lists

to be more accurate : this happens for emails sent only since the upgrade of schleuder, I guess enigmail is not happy...

#4 Updated by intrigeri over 1 year ago

  • Assignee changed from anonym to goupille
  • QA Check set to Info Needed

to be more accurate : this happens for emails sent only since the upgrade of schleuder, I guess enigmail is not happy...

I confirm I cannot reproduce this on Debian sid which is weird since that's basically the same version is the one we ship in Tails.

But I have no idea if I'm looking at the right place: I don't know what "the grey header panel of the compact view" is. Could you please share a screenshot with anonym and I privately?

#5 Updated by emmapeel over 1 year ago

I have had this reported by users using GPG emails with Thunderbird.

I am not sure this is related to Schleuder, maybe is an Enigmail bug:

https://sourceforge.net/p/enigmail/bugs/738/

#6 Updated by goupille over 1 year ago

I don't think it is the same issue,first because the description of the issue doesn't match, then, mine only occurs with emails received from schleuder lists (other encrypted emails have the right subject), and I'm not affected in debian sid (also enigmail 1.9.9).

#7 Updated by intrigeri about 1 year ago

  • Target version set to Tails_3.6

intrigeri wrote:

But I have no idea if I'm looking at the right place: I don't know what "the grey header panel of the compact view" is. Could you please share a screenshot with anonym and I privately?

This happened but the ticket did not come back to my plate so I lost track of it. Sorry!

Meanwhile: can you reproduce on Tails 3.6~rc1?

#8 Updated by goupille about 1 year ago

  • Assignee changed from goupille to intrigeri

sorry about that... it is still happening on 3.6~rc1

#9 Updated by intrigeri about 1 year ago

  • Target version changed from Tails_3.6 to Tails_3.7
  • QA Check deleted (Info Needed)

I really have no clue of what can cause this problem in Tails but not on sid. I'll try to reproduce with enigmail 2.0~beta1 but even if it helps, that's not suitable for 3.6.

#10 Updated by intrigeri about 1 year ago

  • Subject changed from Thunderbird doesn't display the subject of emails sent by schleuder v3 lists to Thunderbird doesn't display the Subject/To fields of emails sent by Schleuder v3

I've tested on Tails 3.6.1 with enigmail 2.0~beta2-1 and I observe similar behaviour:

  • If the first email I select was sent by Schleuder: the Subject is empty in the grey area
  • Then for the next Schleuder messages I select, the Subject is the one of the last non-Schleuder one I've selected

Disabling AppArmor confinement of Thunderbird does not fix that.

I bet that Enigmail is confused by the pseudo-headers Schleuder adds in the beginning of the email body: there's From, To, but no Subject by default. Configuring a list to include Subject in these pseudo-headers does not fix the bug, too bad.

Next step: try to reproduce on Debian stable.

#11 Updated by intrigeri about 1 year ago

Reproduced on current feature/buster. So it starts to look like something specific to Tails configuration.

#12 Updated by intrigeri about 1 year ago

  • Subject changed from Thunderbird doesn't display the Subject/To fields of emails sent by Schleuder v3 to Thunderbird doesn't display the Subject/To/Date fields of emails sent by Schleuder v3
  • Assignee changed from intrigeri to anonym

intrigeri wrote:

Reproduced on current feature/buster. So it starts to look like something specific to Tails configuration.

On a Tails feature/buster system, I've changed all settings we set in config/chroot_local-includes/etc/thunderbird/pref/thunderbird.js to match those I see on my sid system (that does not expose this problem) and I can still reproduce this bug, even with enigmail 2:2.0~beta2-1. Interestingly, the bug happens only with messages sent by Schleuder v3. The main difference I notice in their pseudo-headers is that those have an empty "Cc:" line in the middle of the pseudo-headers, while Schleuder v2 did not add any such line. But a message sent via Schleuder v3 that has a non-empty "Cc:" pseudo-header also exposes the bug.

Anyway, since that's Tails-specific I'll stop blaming Enigmail and Schleuder: it seems clear that something is wrong in our setup and I have no idea why. anonym, does this ring a bell? Don't spend more than 1 hour on this.

#13 Updated by intrigeri about 1 year ago

BTW one can set the enigmail log directory to /home/amnesia and then get debugging info.

#14 Updated by intrigeri about 1 year ago

  • Assignee changed from anonym to intrigeri

#15 Updated by intrigeri about 1 year ago

  • Target version changed from Tails_3.7 to Tails_3.8

#16 Updated by intrigeri about 1 year ago

I'll come back to this once boum.org runs Schleuder 3.2.3, which fixes bugs in this area.

#17 Updated by intrigeri 11 months ago

  • Target version changed from Tails_3.8 to Tails_3.9

intrigeri wrote:

I'll come back to this once boum.org runs Schleuder 3.2.3, which fixes bugs in this area.

Sadly, this is not going to happen during this cycle.

#18 Updated by intrigeri 11 months ago

#19 Updated by intrigeri 11 months ago

  • Type of work changed from Research to Wait

#20 Updated by emmapeel 11 months ago

I think this problem got fixed in Tails 3.8.

I used to experience it consistently but not since upgrade to 3.8

#21 Updated by intrigeri 11 months ago

  • Assignee changed from intrigeri to goupille
  • QA Check set to Info Needed

emmapeel wrote:

I think this problem got fixed in Tails 3.8.
I used to experience it consistently but not since upgrade to 3.8

Please confirm and then close this ticket if the problem is gone.

#22 Updated by goupille 10 months ago

  • Status changed from Confirmed to Resolved
  • Assignee deleted (goupille)

the problem seems fixed

Also available in: Atom PDF