Project

General

Profile

Feature #15239

Feature #14468: Add VeraCrypt support to Tails

Feature #15223: Iteration 2: Support unlocking VeraCrypt file containers in GNOME

Iteration 2: Write tests for unlocking VeraCrypt file containers in GNOME

Added by segfault almost 2 years ago. Updated 12 months ago.

Status:
Resolved
Priority:
Elevated
Assignee:
-
Category:
Test suite
Target version:
Start date:
01/25/2018
Due date:
% Done:

100%

Feature Branch:
test/14471-veracrypt
Type of work:
Code
Blueprint:
Starter:
Affected tool:

Related issues

Blocks Tails - Feature #14471: Write tests for VeraCrypt support in GNOME Disks Resolved 08/28/2017

Associated revisions

Revision d4df243b (diff)
Added by intrigeri about 1 year ago

VeraCrypt test suite (file container): draft initial scenario (refs: #15239).

Revision de22b031 (diff)
Added by intrigeri about 1 year ago

VeraCrypt test suite (file container): implement steps for the initial scenario (refs: #15239).

Revision 0bc618b4 (diff)
Added by intrigeri about 1 year ago

VeraCrypt test suite (file container): add second scenario (refs: #14469, #15239).

Revision bc4f26d4 (diff)
Added by intrigeri about 1 year ago

VeraCrypt test suite (file container): write the remaining scenarios (refs: #14469, #15239).

Revision d9e74d95 (diff)
Added by intrigeri about 1 year ago

VeraCrypt test suite: restore robustness improvement (refs: #14471, #15239).

Sadly, moving "all notifications have disappeared" here was not sufficient.

Revision 1e02525f (diff)
Added by intrigeri about 1 year ago

VeraCrypt test suite (file container): implement GNOME Disks scenarios (refs: #14471, #15239).

Let's rename the file container to .img in order to simplify these tests.

Revision d8efb0de (diff)
Added by intrigeri about 1 year ago

VeraCrypt test suite: robustness improvement (refs: #14471, #15239).

5 seconds was not sufficient during the last run on lizard.
The failure screenshot shows the expected loop device row
in the UI so presumably retrying a bit longer should fix this.

Revision ec74ae39 (diff)
Added by intrigeri about 1 year ago

VeraCrypt test suite (file container): drop the .img extension (refs: #14471, #15239)

In commit 1e02525f0d39ef344df4676f601dc891aaadff4d I've renamed this volume to
.img in order to simplify these tests, but since then I've implemented disabling
the "*.img, *.iso" filter in GNOME Disks ⇒ we can now test something closer to
what our documentation instructs users to do.

Revision f336487b (diff)
Added by intrigeri about 1 year ago

VeraCrypt test suite (file container): robustness improvement (refs: #14471, #15239).

The symptom this commit tries to solve is: shortly after clicking "Attach Disk
Image…" with Sikuli, the Disks window is minimized. I'm not sure whether it's
a bug in Dogtail or a (quite common) result of mixing up Dogtail and Sikuli.

Revision 235e407a (diff)
Added by intrigeri about 1 year ago

VeraCrypt test suite (file container): robustness improvement (refs: #14471, #15239).

When unlocking file containers, sometimes Dogtail would not find
the "Mount selected partition" button. This is not surprising
as I generally cannot see it when performing the exact same actions
by hand, not sure why it actually works when unlocking partitions.

Anyway, the logical thing to do is to focus the "Filesystem\n107 MB FAT"
item. It is not accessible to Dogtail so let's navigate to it with
the keyboard, which avoids having to introduce another picture
(that would need to vary depending on basic/hidden volumes because their
filesystem size differ).

Revision d01d4b2b
Added by intrigeri about 1 year ago

Merge branch 'test/14471-veracrypt' into stable (Fix-committed: #14471, #15238, #15239)

History

#1 Updated by segfault almost 2 years ago

  • Category set to Test suite

#2 Updated by segfault almost 2 years ago

  • Subject changed from Write tests for unlocking VeraCrypt file containers in GNOME to Iteration 2: Write tests for unlocking VeraCrypt file containers in GNOME

#3 Updated by intrigeri over 1 year ago

  • Blocks Feature #14471: Write tests for VeraCrypt support in GNOME Disks added

#4 Updated by intrigeri over 1 year ago

  • Assignee changed from anonym to intrigeri
  • Target version changed from Tails_3.9 to Tails_3.10.1

#6 Updated by intrigeri over 1 year ago

  • Priority changed from Normal to Elevated

#7 Updated by intrigeri about 1 year ago

  • Feature Branch set to test/14471-veracrypt

#8 Updated by intrigeri about 1 year ago

  • Status changed from Confirmed to In Progress
  • % Done changed from 0 to 20

Done for Unlock VeraCrypt Volumes, let's see what Jenkins thinks. TBD: GNOME Disks.

#9 Updated by intrigeri about 1 year ago

Everything implemented and works locally, now waiting for Jenkins results.

#10 Updated by intrigeri about 1 year ago

  • QA Check set to Ready for QA

#11 Updated by intrigeri about 1 year ago

  • % Done changed from 20 to 50

Finally these tests are now very robust locally, let's see how it fares on Jenkins.

#12 Updated by intrigeri about 1 year ago

  • Assignee changed from intrigeri to CyrilBrulebois

#13 Updated by intrigeri about 1 year ago

  • Target version changed from Tails_3.10.1 to Tails_3.11

#14 Updated by intrigeri about 1 year ago

  • Status changed from In Progress to 11
  • % Done changed from 50 to 100

#15 Updated by intrigeri about 1 year ago

  • Assignee deleted (CyrilBrulebois)
  • QA Check changed from Ready for QA to Pass

Reviewed pass as per #14471#note-24.

#16 Updated by CyrilBrulebois 12 months ago

  • Status changed from 11 to Resolved

Also available in: Atom PDF